aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/gnome-main-menu/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/deskutils/gnome-main-menu/Makefile b/deskutils/gnome-main-menu/Makefile
index 455e426c8bb..bfad940002e 100644
--- a/deskutils/gnome-main-menu/Makefile
+++ b/deskutils/gnome-main-menu/Makefile
@@ -29,4 +29,12 @@ LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= application-browser.schemas slab.schemas
+post-patch:
+ ${REINPLACE_CMD} -e 's|glib/gmacros.h|glib.h|g' \
+ -e 's|glib/gfileutils.h|glib.h|g' \
+ -e 's|glib/gtypes.h|glib.h|g' \
+ ${WRKSRC}/libslab/system-tile.c \
+ ${WRKSRC}/libslab/application-tile.c \
+ ${WRKSRC}/main-menu/src/tomboykeybinder.h
+
.include <bsd.port.mk>