aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/orage/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index e3104883d5c..9c1c537a8d7 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xfce4-calendar
-# Date created: 2003-01-14
-# Whom: Matt Lancereau <matt@rimasec.net>
-#
+# Created by: Matt Lancereau <matt@rimasec.net>
# $FreeBSD$
-#
PORTNAME= orage
PORTVERSION= 4.8.3
@@ -28,17 +24,16 @@ USE_XFCE= configenv libmenu panel
USE_XORG= xext xrender xinerama xi xrandr xcursor xcomposite xdamage x11 \
xfixes
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= BDB ICAL DBUS NOTIFY
+OPTIONS_DEFAULT= DBUS NOTIFY
-OPTIONS= BDB "Enable BDB support" off \
- ICAL "Enable libical support" off \
- DBUS "Enable D-BUS support" on \
- NOTIFY "Enable notification support" on
+ICAL_DESC= libical support
MAN1= globaltime.1 orage.1 tz_convert.1
.include <bsd.port.pre.mk>
-.if defined(WITH_BDB)
+.if ${PORT_OPTIONS:MBDB}
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure
CONFIGURE_ARGS+=--with-bdb4=yes --with-bdb4_dir=${LOCALBASE}
USE_BDB= yes
@@ -48,7 +43,7 @@ INVALIDE_BDB_VER= 5
CONFIGURE_ARGS+=--with-bdb4=no
.endif
-.if defined(WITH_ICAL)
+.if ${PORT_OPTIONS:MICAL}
CONFIGURE_ARGS+=--enable-libical
LIB_DEPENDS+= ical.44:${PORTSDIR}/devel/libical
CFLAGS+= -I${LOCALBASE}/include/libical
@@ -58,7 +53,7 @@ CONFIGURE_ARGS+=--disable-libical
PLIST_SUB+= WITH_ICAL=""
.endif
-.if !defined(WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-dbus
PLIST_SUB+= DBUS=""
@@ -67,7 +62,7 @@ CONFIGURE_ARGS+=--disable-dbus
PLIST_SUB+= DBUS="@comment "
.endif
-.if !defined(WITHOUT_NOTIFY)
+.if ${PORT_OPTIONS:MNOTIFY}
LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--enable-libnotify
.else
@@ -75,12 +70,12 @@ CONFIGURE_ARGS+=--disable-libnotify
.endif
post-patch:
-.if defined(WITH_BDB)
+.if ${PORT_OPTIONS:MBDB}
@${REINPLACE_CMD} -e 's|%%BDB_INCLUDE_DIR%%|${BDB_INCLUDE_DIR}|g ; \
s|%%BDB_LIB_DIR%%|${BDB_LIB_DIR}|g ; \
s|%%BDB_LIB_NAME%%|${BDB_LIB_NAME}|g' ${WRKSRC}/configure
.endif
-.if !defined(WITH_ICAL)
+.if ${PORT_OPTIONS:MICAL}
@${REINPLACE_CMD} -e 's|libical-|no-&|g' ${WRKSRC}/configure
.endif
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure