aboutsummaryrefslogtreecommitdiffstats
path: root/devel/veepee
diff options
context:
space:
mode:
Diffstat (limited to 'devel/veepee')
-rw-r--r--devel/veepee/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/devel/veepee/Makefile b/devel/veepee/Makefile
index d521a001f2e..75c5ca48931 100644
--- a/devel/veepee/Makefile
+++ b/devel/veepee/Makefile
@@ -19,9 +19,12 @@ LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
USE_XLIB= yes
USE_PYTHON= yes
USE_LIBTOOL= yes
-CONFIGURE_ENV= LDFLAGS="-pthread"
+CONFIGURE_ENV= LDFLAGS="-pthread ${PYTHON_LIBS}"
CONFIGURE_ARGS= --with-gd-includes=${LOCALBASE}/include/gd \
--disable-kde
+.if exists(/usr/lib/libcrypto.a)
+PYTHON_LIBS+= -lcrypto
+.endif
pre-patch:
@${PERL} -pi -e 's|-lpthread|-pthread|g' \