aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Shape/Makefile2
-rw-r--r--devel/shapelib/Makefile33
-rw-r--r--devel/shapelib/distinfo5
-rw-r--r--devel/shapelib/files/patch-Makefile52
-rw-r--r--devel/shapelib/files/patch-contrib-Makefile43
-rw-r--r--devel/shapelib/files/patch-shapefil.h11
-rw-r--r--devel/shapelib/pkg-descr18
-rw-r--r--devel/shapelib/pkg-plist12
8 files changed, 21 insertions, 155 deletions
diff --git a/devel/p5-Shape/Makefile b/devel/p5-Shape/Makefile
index 514b704e994..2208b344751 100644
--- a/devel/p5-Shape/Makefile
+++ b/devel/p5-Shape/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Shape
PORTVERSION= 0.04
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel perl5
MASTER_SITES= http://users.tkk.fi/~jolma/pub/
PKGNAMEPREFIX= p5-
diff --git a/devel/shapelib/Makefile b/devel/shapelib/Makefile
index 502e8cf1fed..cfe6c0a4967 100644
--- a/devel/shapelib/Makefile
+++ b/devel/shapelib/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= shapelib
-PORTVERSION= 1.3.0
-PORTREVISION= 9
+PORTVERSION= 1.4.0
CATEGORIES= devel geography
MASTER_SITES= http://download.osgeo.org/shapelib/ \
ftp://ftp.remotesensing.org/shapelib/ \
@@ -18,31 +17,21 @@ OPTIONS_DEFINE= DOCS PROJ
OPTIONS_SUB= yes
MAKE_JOBS_UNSAFE= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+USES= libtool localbase pathfix
-PROJ_LIB_DEPENDS= libproj.so:graphics/proj
-
-.include <bsd.port.pre.mk>
-
-# Ref: /usr/share/mk/bsd.endian.mk
-.if ${ARCH} == "amd64" || ${ARCH} == "arm" || ${ARCH} == "i386" || ${ARCH} == "ia64"
-ENDIAN= -D_LITTLE_ENDIAN
-.else
-ENDIAN= -D_BIG_ENDIAN # mips*eb, powerpc, powerpc64 and sparc
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%ENDIAN%%|${ENDIAN}|g' ${WRKSRC}/contrib/Makefile
+PORTDOCS= *
-post-patch-PROJ-off:
- @${REINPLACE_CMD} -e 's|%%PROJ%%|-DNO_PROJ4|g' ${WRKSRC}/Makefile ${WRKSRC}/contrib/Makefile
-
-post-patch-PROJ-on:
- @${REINPLACE_CMD} -e 's|%%PROJ%%|-DPROJ4|g' ${WRKSRC}/Makefile ${WRKSRC}/contrib/Makefile
+PROJ_CONFIGURE_OFF= --with-proj-cflags="" --with-proj-libs=""
+PROJ_LIB_DEPENDS= libproj.so:graphics/proj
post-install:
- ${LN} -s libshp.so.1 ${STAGEDIR}${PREFIX}/lib/libshp.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/shptest ${STAGEDIR}${PREFIX}/bin/
+
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/web/*.html ${STAGEDIR}${DOCSDIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/shapelib/distinfo b/devel/shapelib/distinfo
index a36c13a77e7..a31a5457642 100644
--- a/devel/shapelib/distinfo
+++ b/devel/shapelib/distinfo
@@ -1,2 +1,3 @@
-SHA256 (shapelib-1.3.0.tar.gz) = 23d474016158ab5077db2f599527631706ba5c0dc7c4178a6a1d685bb014f68f
-SIZE (shapelib-1.3.0.tar.gz) = 156301
+TIMESTAMP = 1481467052
+SHA256 (shapelib-1.4.0.tar.gz) = 3eddd5f2690f2cf18d8d9798267537a2102a289020b9818f9a31eb626f91a7a1
+SIZE (shapelib-1.4.0.tar.gz) = 548990
diff --git a/devel/shapelib/files/patch-Makefile b/devel/shapelib/files/patch-Makefile
deleted file mode 100644
index 448aa109001..00000000000
--- a/devel/shapelib/files/patch-Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
---- Makefile.orig 2011-07-24 04:32:26 UTC
-+++ Makefile
-@@ -1,16 +1,19 @@
-
--PREFIX = /usr/local
--CFLAGS = -g -Wall -fPIC
-+PREFIX ?= /usr/local
-+CFLAGS += -Wall -fPIC
- #CFLAGS = -g -DUSE_CPL
- #CC = g++
-
- LIBOBJ = shpopen.o dbfopen.o safileio.o shptree.o
- SHPBIN = shpcreate shpadd shpdump shprewind dbfcreate dbfadd dbfdump \
-- shptreedump
-+ shptreedump shputils shptest
-
- default: all
-
--all: $(SHPBIN) shptest lib
-+all: $(SHPBIN) lib contrib_tools
-+
-+contrib_tools:
-+ (cd contrib/; ${MAKE} %%PROJ%% all; cd ..)
-
- shpopen.o: shpopen.c shapefil.h
- $(CC) $(CFLAGS) -c shpopen.c
-@@ -98,16 +101,21 @@
-
-
- lib: libshp.a
-+ $(CC) -shared -Wl,-soname,libshp.so.1 -o libshp.so.1 $(LDFLAGS) dbfopen.o safileio.o shpopen.o shptree.o
-
- libshp.a: $(LIBOBJ)
- ar r libshp.a $(LIBOBJ)
-
- lib_install: libshp.a
-- cp libshp.a $(PREFIX)/lib
-- cp shapefil.h $(PREFIX)/include
-+ $(BSD_INSTALL_DATA) shapefil.h $(DESTDIR)$(PREFIX)/include/
-+ $(BSD_INSTALL_DATA) libshp.a $(DESTDIR)$(PREFIX)/lib/
-+ $(BSD_INSTALL_LIB) libshp.so.1 $(DESTDIR)$(PREFIX)/lib/
-
- bin_install: $(SHPBIN)
-- cp $(SHPBIN) $(PREFIX)/bin
-+ $(BSD_INSTALL_PROGRAM) $(SHPBIN) $(DESTDIR)$(PREFIX)/bin/
-+
-+contrib_install:
-+ (cd contrib/; ${MAKE} %%PROJ%% install; cd ..)
-
--install: lib_install bin_install
-+install: lib_install bin_install contrib_install
-
diff --git a/devel/shapelib/files/patch-contrib-Makefile b/devel/shapelib/files/patch-contrib-Makefile
deleted file mode 100644
index 45325b8dc3f..00000000000
--- a/devel/shapelib/files/patch-contrib-Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
---- contrib/Makefile.orig 2010-01-04 04:08:02 UTC
-+++ contrib/Makefile
-@@ -3,19 +3,36 @@
- #CFLAGS = -g
-
- # Endian: define either _LITTLE_ENDIAN or _BIG_ENDIAN
--ENDIAN = -D_LITTLE_ENDIAN
-+#ENDIAN = -D_LITTLE_ENDIAN
-
--CFLAGS = -g -I.. -I$(HOME)/bld/include -DPROJ4 $(ENDIAN) -DDEBUG -DDEBUG2
-+CFLAGS += %%ENDIAN%% %%PROJ%% -I.. -I$(LOCALBASE)/include -L$(LOCALBASE)/lib
-
- SHPOBJ = ../shpopen.o ../dbfopen.o ../safileio.o
-
- SHPGOBJ = ../shpopen.o ../dbfopen.o ../safileio.o shpgeo.o
-
--GEOOBJ = ./shpgeo.o -lm -L$(HOME)/bld/lib -lproj
-+GEOOBJ = ./shpgeo.o -lm -lproj
-
- default: all
-
--all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
-+#all: shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfinfo dbfcat shpinfo shpfix shpcat Shape_PointInPoly shpsort
-+
-+ALLPROG= Shape_PointInPoly dbfcat dbfinfo shpcat shpdxf shpfix shpsort
-+ALLPROJ= shpcentrd shpdata shpinfo shpproj shpwkb
-+
-+.if defined(NO_PROJ4)
-+all: $(ALLPROG)
-+install: allprog_install
-+.else
-+all: $(ALLPROG) $(ALLPROJ)
-+install: allprog_install allproj_install
-+.endif
-+
-+allprog_install: $(ALLPROG)
-+ $(BSD_INSTALL_PROGRAM) $(ALLPROG) $(DESTDIR)$(PREFIX)/bin/
-+
-+allproj_install: $(ALLPROJ)
-+ $(BSD_INSTALL_PROGRAM) $(ALLPROJ) $(DESTDIR)$(PREFIX)/bin/
-
- clean:
- rm -f shpdxf shpproj dbfinfo shpcentrd shpdata shpwkb dbfcat dbfinfo shpinfo shpfix shpcat *.o
diff --git a/devel/shapelib/files/patch-shapefil.h b/devel/shapelib/files/patch-shapefil.h
deleted file mode 100644
index 16a45db7499..00000000000
--- a/devel/shapelib/files/patch-shapefil.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- shapefil.h.orig 2011-07-24 06:15:51 UTC
-+++ shapefil.h
-@@ -138,6 +138,8 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <string.h>
-
- #ifdef USE_DBMALLOC
- #include <dbmalloc.h>
diff --git a/devel/shapelib/pkg-descr b/devel/shapelib/pkg-descr
index a17765dc84d..607706a7519 100644
--- a/devel/shapelib/pkg-descr
+++ b/devel/shapelib/pkg-descr
@@ -1,17 +1,5 @@
- Shapefile C Library V1.2
-
- Purpose
-
- The Shapefile C Library provides the ability to write simple C
- programs for reading, writing and updating (to a limited extent) ESRI
- Shapefiles, and the associated attribute file (.dbf).
-
- Documentation
-
- /usr/local/share/doc/shapelib/shapelib.html - General docs
- /usr/local/share/doc/shapelib/shp_api.html - Shape (.SHP) File API
- /usr/local/share/doc/shapelib/dbg_api.html - Attribute (.DBF) File API
-
-Check Shapelib Homepage below:
+The Shapefile C Library provides the ability to write simple C programs for
+reading, writing and updating (to a limited extent) ESRI Shapefiles, and the
+associated attribute file (.dbf).
WWW: http://shapelib.maptools.org/
diff --git a/devel/shapelib/pkg-plist b/devel/shapelib/pkg-plist
index 491dee7b080..74e05962627 100644
--- a/devel/shapelib/pkg-plist
+++ b/devel/shapelib/pkg-plist
@@ -23,12 +23,6 @@ bin/shputils
include/shapefil.h
lib/libshp.a
lib/libshp.so
-lib/libshp.so.1
-%%PORTDOCS%%%%DOCSDIR%%/codepage.html
-%%PORTDOCS%%%%DOCSDIR%%/dbf_api.html
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/license.html
-%%PORTDOCS%%%%DOCSDIR%%/manifest.html
-%%PORTDOCS%%%%DOCSDIR%%/release.html
-%%PORTDOCS%%%%DOCSDIR%%/shapelib-tools.html
-%%PORTDOCS%%%%DOCSDIR%%/shp_api.html
+lib/libshp.so.2
+lib/libshp.so.2.0.1
+libdata/pkgconfig/shapelib.pc