aboutsummaryrefslogtreecommitdiffstats
path: root/finance
diff options
context:
space:
mode:
Diffstat (limited to 'finance')
-rw-r--r--finance/moneymanagerex/Makefile75
-rw-r--r--finance/moneymanagerex/distinfo26
-rw-r--r--finance/moneymanagerex/files/patch-lib_wxsqlite3_sqlite3_secure_src_extensionfunctions.c14
-rw-r--r--finance/moneymanagerex/files/patch-m4_bakefile.m4 (renamed from finance/moneymanagerex/files/patch-bakefile-0.2.9_autoconf_bakefile.m4)4
-rw-r--r--finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp43
-rw-r--r--finance/moneymanagerex/files/patch-src_webapp.cpp25
-rw-r--r--finance/moneymanagerex/pkg-descr11
-rw-r--r--finance/moneymanagerex/pkg-plist13
8 files changed, 182 insertions, 29 deletions
diff --git a/finance/moneymanagerex/Makefile b/finance/moneymanagerex/Makefile
index 72b6fc6475e..c53cb78b538 100644
--- a/finance/moneymanagerex/Makefile
+++ b/finance/moneymanagerex/Makefile
@@ -2,46 +2,83 @@
# $FreeBSD$
PORTNAME= mmex
-PORTVERSION= 1.0.0.0
+PORTVERSION= 1.2.6
+DISTVERSIONPREFIX= v
CATEGORIES= finance
-MASTER_SITES= SF/moneymanagerex/moneymanagerex/Version%20${PORTVERSION} \
- https://github.com/vslavik/bakefile/releases/download/v0.2.9/:bakefile
-DISTFILES= mmex_${PORTVERSION}_src.tar.bz2 \
- bakefile-0.2.9.tar.gz:bakefile
+MASTER_SITES= https://github.com/vslavik/bakefile/releases/download/v0.2.9/:bakefile \
+ SF/wxcode/Components/wxSQLite3:wxsqlite3
+DISTFILES= bakefile-0.2.9${EXTRACT_SUFX}:bakefile \
+ ${WXSQLITE3_DISTNAME}${EXTRACT_SUFX}:wxsqlite3
MAINTAINER= ports@FreeBSD.org
COMMENT= Free, open-source, easy-to-use personal finance software
LICENSE= GPLv2
-NO_WRKSUBDIR= yes
+USE_GITHUB= yes
+GH_ACCOUNT= moneymanagerex
+GH_PROJECT= moneymanagerex
-USES= compiler:c++11-lib gettext gmake tar:bzip2
+WXSQLITE3_DISTNAME= wxsqlite3-3.2.1
+
+GH_TUPLE= Regaddi:Chart.js:f13f99b:chart_js \
+ FVANCOP:ChartNew.js:77e7f87:chartnew_js \
+ diepes:sorttable.js:3c63cb0:sorttable_js \
+ moneymanagerex:database:5d7129f:database \
+ moneymanagerex:LuaGlue:c51d11a:luaglue \
+ moneymanagerex:cajun:3684900:cajun \
+ moneymanagerex:html-template:cd434ee:html_template \
+ moneymanagerex:csv-parser:ca3f0d7:csv_parser \
+ moneymanagerex:ctpp:20158e0:ctpp \
+ moneymanagerex:mongoose:97583a6:mongoose
+
+USES= autoreconf compiler:c++11-lib gettext gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
USE_WX= 3.0
-WX_UNICODE= yes
WX_CONF_ARGS= absolute
-USE_AUTOTOOLS= aclocal autoconf
-ACLOCAL_ARGS= -I m4 -I bakefile-0.2.9/autoconf \
- --automake-acdir=${ACLOCAL_DIR}
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include \
+ -DHAVE_ACOSH \
+ -DHAVE_ASINH \
+ -DHAVE_ATANH \
+ -DHAVE_ISBLANK \
+ -DSQLITE_USER_AUTHENTICATION=0
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${CHOSEN_COMPILER_TYPE} == "gcc"
+LIB_DEPENDS+= libboost_system.so:${PORTSDIR}/devel/boost-libs
+LDFLAGS+= -lboost_system
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC_database}/* ${WRKSRC}/database
+ @${MV} ${WRKSRC_chart_js}/* ${WRKSRC}/3rd/Chart.js
+ @${MV} ${WRKSRC_chartnew_js}/* ${WRKSRC}/3rd/ChartNew.js
+ @${MV} ${WRKSRC_luaglue}/* ${WRKSRC}/3rd/LuaGlue
+ @${MV} ${WRKSRC_cajun}/* ${WRKSRC}/3rd/cajun
+ @${MV} ${WRKSRC_csv_parser}/* ${WRKSRC}/3rd/csv-parser
+ @${MV} ${WRKSRC_ctpp}/* ${WRKSRC}/3rd/ctpp
+ @${MV} ${WRKSRC_html_template}/* ${WRKSRC}/3rd/cgitemplate
+ @${MV} ${WRKSRC_mongoose}/* ${WRKSRC}/3rd/mongoose
+ @${MV} ${WRKSRC_sorttable_js}/* ${WRKSRC}/3rd/sorttable.js
+ @${MV} ${WRKDIR}/${WXSQLITE3_DISTNAME}/* ${WRKSRC}/lib/wxsqlite3
+ @${MV} ${WRKDIR}/bakefile-0.2.9/autoconf/*.m4 ${WRKSRC}/m4
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|$$(datadir)/man|$$(prefix)/man|' ${WRKSRC}/Makefile.in
+ 's|\*.txt|contrib.txt version.txt| ; \
+ s|$$(datadir)/man|$$(prefix)/man| ; \
+ s|-ldl$$||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
- 's|\[noext\]|[]|' ${WRKSRC}/configure.ac
+ '/^AC_INIT/s|1.2.3|${PORTVERSION}| ; \
+ s|\[noext\]|[]|' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e \
's| -g0 -O2||' ${WRKSRC}/m4/wxpresets.m4
-pre-configure:
- @(cd ${WRKSRC} && ${SH} update_revision.sh)
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/finance/moneymanagerex/distinfo b/finance/moneymanagerex/distinfo
index 11e963532c0..f95d8e5eed0 100644
--- a/finance/moneymanagerex/distinfo
+++ b/finance/moneymanagerex/distinfo
@@ -1,4 +1,26 @@
-SHA256 (mmex_1.0.0.0_src.tar.bz2) = c28761bf9bef5f75cb25b887e89439f8e107957688004697b28e914f5d5ccb69
-SIZE (mmex_1.0.0.0_src.tar.bz2) = 11077632
SHA256 (bakefile-0.2.9.tar.gz) = 9f3c65411ad3932027e3c3e765337d89be2f9cf5ee9a204da80e92a8c2d76ca5
SIZE (bakefile-0.2.9.tar.gz) = 775528
+SHA256 (wxsqlite3-3.2.1.tar.gz) = 312f2cf63c76a70bae92b78ea6fb7e9485fb23c3ee728daa418babab881939e4
+SIZE (wxsqlite3-3.2.1.tar.gz) = 2810940
+SHA256 (moneymanagerex-moneymanagerex-v1.2.6_GH0.tar.gz) = aa107ec8165fefa757d6a00378b5fc2c4e6b9c8c6087834a4fea92d0c2447bdc
+SIZE (moneymanagerex-moneymanagerex-v1.2.6_GH0.tar.gz) = 5394607
+SHA256 (Regaddi-Chart.js-f13f99b_GH0.tar.gz) = d951bd59c04942547998200974d2db148fe2ffd72ab29a4bf3ac4bb19252e68d
+SIZE (Regaddi-Chart.js-f13f99b_GH0.tar.gz) = 71113
+SHA256 (FVANCOP-ChartNew.js-77e7f87_GH0.tar.gz) = 6ec3470ac81dadceed8b97ff905d44c8659c6144d27987f9281000aa47dcca3d
+SIZE (FVANCOP-ChartNew.js-77e7f87_GH0.tar.gz) = 193800
+SHA256 (diepes-sorttable.js-3c63cb0_GH0.tar.gz) = 9cc27341400d917dfa24e10f4de86550d35794c69388c311e9fcfd2ba83be403
+SIZE (diepes-sorttable.js-3c63cb0_GH0.tar.gz) = 6177
+SHA256 (moneymanagerex-database-5d7129f_GH0.tar.gz) = faf5eb922e616fddbcc7affee333bedf4a7aaef3319db296c0a0da51a67f6011
+SIZE (moneymanagerex-database-5d7129f_GH0.tar.gz) = 13424
+SHA256 (moneymanagerex-LuaGlue-c51d11a_GH0.tar.gz) = b392fe598b8ec1d93865d6c86341d141a04c817842d29bc65589fbd6c4274b4c
+SIZE (moneymanagerex-LuaGlue-c51d11a_GH0.tar.gz) = 19959
+SHA256 (moneymanagerex-cajun-3684900_GH0.tar.gz) = c48f107e86feb1bd2367e4d33d9e5f1807279503055cc804de0a02fcf21c3f5c
+SIZE (moneymanagerex-cajun-3684900_GH0.tar.gz) = 15316
+SHA256 (moneymanagerex-html-template-cd434ee_GH0.tar.gz) = 104d3c4ff07fb2c9952488dc269047e41e2312c1f15db3cbf5b1200952157fd2
+SIZE (moneymanagerex-html-template-cd434ee_GH0.tar.gz) = 38036
+SHA256 (moneymanagerex-csv-parser-ca3f0d7_GH0.tar.gz) = d4a7176cfcb62addebeb3e126e64dad8a646e07fbc3481f3128cd08e41b0d036
+SIZE (moneymanagerex-csv-parser-ca3f0d7_GH0.tar.gz) = 446850
+SHA256 (moneymanagerex-ctpp-20158e0_GH0.tar.gz) = 38548b87348a0ffe16ac7bec4a6a0b0a66552bc92a3ea0c114471c67f0e00192
+SIZE (moneymanagerex-ctpp-20158e0_GH0.tar.gz) = 234651
+SHA256 (moneymanagerex-mongoose-97583a6_GH0.tar.gz) = 73c2fac2c5efc7d071a6634cafeaab3380d4ba9de482678713ed2ea6a0ec7967
+SIZE (moneymanagerex-mongoose-97583a6_GH0.tar.gz) = 111952
diff --git a/finance/moneymanagerex/files/patch-lib_wxsqlite3_sqlite3_secure_src_extensionfunctions.c b/finance/moneymanagerex/files/patch-lib_wxsqlite3_sqlite3_secure_src_extensionfunctions.c
new file mode 100644
index 00000000000..edc4630b8ba
--- /dev/null
+++ b/finance/moneymanagerex/files/patch-lib_wxsqlite3_sqlite3_secure_src_extensionfunctions.c
@@ -0,0 +1,14 @@
+--- lib/wxsqlite3/sqlite3/secure/src/extensionfunctions.c.orig 2015-03-03 21:30:22 UTC
++++ lib/wxsqlite3/sqlite3/secure/src/extensionfunctions.c
+@@ -208,9 +208,9 @@ int double_cmp(const void *a, const void
+
+ #endif /* _MAP_H_ */
+
+-typedef uint8_t u8;
++//typedef uint8_t u8;
+ //typedef uint16_t u16;
+-typedef int64_t i64;
++//typedef int64_t i64;
+
+ static char *sqlite3StrDup( const char *z ) {
+ char *res = sqlite3_malloc( strlen(z)+1 );
diff --git a/finance/moneymanagerex/files/patch-bakefile-0.2.9_autoconf_bakefile.m4 b/finance/moneymanagerex/files/patch-m4_bakefile.m4
index d6b559f5009..541b76b3dc1 100644
--- a/finance/moneymanagerex/files/patch-bakefile-0.2.9_autoconf_bakefile.m4
+++ b/finance/moneymanagerex/files/patch-m4_bakefile.m4
@@ -1,5 +1,5 @@
---- bakefile-0.2.9/autoconf/bakefile.m4.orig 2011-02-02 15:06:48 UTC
-+++ bakefile-0.2.9/autoconf/bakefile.m4
+--- m4/bakefile.m4.orig 2011-02-02 15:06:48 UTC
++++ m4/bakefile.m4
@@ -444,6 +444,7 @@ AC_DEFUN([AC_BAKEFILE_SHARED_LD],
powerpc-apple-macos* | \
diff --git a/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp b/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp
new file mode 100644
index 00000000000..4339a2d853d
--- /dev/null
+++ b/finance/moneymanagerex/files/patch-src_import__export_univcsvdialog.cpp
@@ -0,0 +1,43 @@
+--- src/import_export/univcsvdialog.cpp.orig 2016-03-05 06:10:45 UTC
++++ src/import_export/univcsvdialog.cpp
+@@ -37,6 +37,13 @@
+
+ #include "csv_parser/csv_parser.hpp"
+
++#ifdef _LIBCPP_VERSION
++#define TO_WSTRING(x) std::to_wstring(x)
++#else
++#include <boost/lexical_cast.hpp>
++#define TO_WSTRING(x) boost::lexical_cast<std::wstring>(x)
++#endif
++
+ wxIMPLEMENT_DYNAMIC_CLASS(mmUnivCSVDialog, wxDialog);
+
+ wxBEGIN_EVENT_TABLE(mmUnivCSVDialog, wxDialog)
+@@ -409,7 +416,7 @@ void mmUnivCSVDialog::SetSettings(const
+ csvFieldOrder_.clear();
+ for (int i = 0; i < 99; i++)
+ {
+- const std::wstring w = to_wstring(i);
++ const std::wstring w = TO_WSTRING(i);
+ const wxString& value = wxString(json::String(o[w]));
+ if (!value.empty())
+ {
+@@ -536,7 +543,7 @@ void mmUnivCSVDialog::OnSave(wxCommandEv
+ int count = 0;
+ for (std::vector<int>::const_iterator it = csvFieldOrder_.begin(); it != csvFieldOrder_.end(); ++it)
+ {
+- const auto w = to_wstring(count++);
++ const auto w = TO_WSTRING(count++);
+ int i = *it;
+ o[w] = json::String(CSVFieldName_[i].ToStdWstring());
+ wxLogDebug("%i - %i - %s", count-1, i, CSVFieldName_[i]);
+@@ -669,7 +676,7 @@ void mmUnivCSVDialog::OnImport(wxCommand
+ payeeID_ = -1;
+ categID_ = -1;
+ subCategID_ = -1;
+- val_ = NULL;
++ val_ = 0;
+
+ this->csv2tab_separated_values(line, delimit_);
+ wxStringTokenizer tkz(line, "\t", wxTOKEN_RET_EMPTY_ALL);
diff --git a/finance/moneymanagerex/files/patch-src_webapp.cpp b/finance/moneymanagerex/files/patch-src_webapp.cpp
new file mode 100644
index 00000000000..cdfad4a17cf
--- /dev/null
+++ b/finance/moneymanagerex/files/patch-src_webapp.cpp
@@ -0,0 +1,25 @@
+--- src/webapp.cpp.orig 2016-03-05 06:10:45 UTC
++++ src/webapp.cpp
+@@ -31,6 +31,13 @@ Foundation, Inc., 59 Temple Place, Suite
+ #include <wx/sstream.h>
+ #include <wx/protocol/http.h>
+
++#ifdef _LIBCPP_VERSION
++#define TO_WSTRING(x) std::to_wstring(x)
++#else
++#include <boost/lexical_cast.hpp>
++#define TO_WSTRING(x) boost::lexical_cast<std::wstring>(x)
++#endif
++
+ //Expected WebAppVersion
+ const wxString WebAppParam::ApiExpectedVersion = "1.0.1";
+
+@@ -374,7 +381,7 @@ bool mmWebApp::WebApp_DownloadNewTransac
+
+ for (int i = 0; i < static_cast<int>(jsonTransaction.Size()); i++)
+ {
+- TrProgrStr = std::to_wstring(i);
++ TrProgrStr = TO_WSTRING(i);
+
+ WebTran.ID = wxAtoi(wxString(json::String(jsonTransaction[TrProgrStr][L"ID"])));
+
diff --git a/finance/moneymanagerex/pkg-descr b/finance/moneymanagerex/pkg-descr
index 66d2763ecd7..d1d091f5a16 100644
--- a/finance/moneymanagerex/pkg-descr
+++ b/finance/moneymanagerex/pkg-descr
@@ -1,11 +1,10 @@
-Money Manager Ex is free, open-source, cross-platform, easy-to-use personal
-finance software. It primarily helps to organize one's finances and keeps
-track of where, when, and how the money goes. It is also a great tool to
-get a bird's eye view of your financial worth.
+Money Manager Ex is a free, open-source, cross-platform, easy-to-use personal
+finance software. It primarily helps organize one's finances and keeps
+track of where, when and how the money goes.
-Money Manager includes all the basic features that 90% of users would want
+MMEX includes all the basic features that 90% of users would want
to see in a personal finance application. The design goals are to
concentrate on simplicity and user-friendliness -- something one can use
everyday.
-WWW: http://www.codelathe.com/mmex/
+WWW: http://www.moneymanagerex.org/
diff --git a/finance/moneymanagerex/pkg-plist b/finance/moneymanagerex/pkg-plist
index 5c476aa9e43..74ae4935987 100644
--- a/finance/moneymanagerex/pkg-plist
+++ b/finance/moneymanagerex/pkg-plist
@@ -2,6 +2,11 @@ bin/mmex
man/man1/mmex.1.gz
share/applications/mmex.desktop
share/icons/hicolor/scalable/apps/mmex.svg
+%%DATADIR%%/Info.plist
+%%DATADIR%%/contrib.txt
+%%DATADIR%%/license.txt
+%%DATADIR%%/mmdb.icns
+%%DATADIR%%/mmex.icns
%%DATADIR%%/po/en/arabic.mo
%%DATADIR%%/po/en/bulgarian.mo
%%DATADIR%%/po/en/chinese_chs.mo
@@ -16,6 +21,7 @@ share/icons/hicolor/scalable/apps/mmex.svg
%%DATADIR%%/po/en/german.mo
%%DATADIR%%/po/en/greek.mo
%%DATADIR%%/po/en/hebrew.mo
+%%DATADIR%%/po/en/hindi.mo
%%DATADIR%%/po/en/hungarian.mo
%%DATADIR%%/po/en/indonesian.mo
%%DATADIR%%/po/en/italian.mo
@@ -23,6 +29,7 @@ share/icons/hicolor/scalable/apps/mmex.svg
%%DATADIR%%/po/en/norwegian.mo
%%DATADIR%%/po/en/polish.mo
%%DATADIR%%/po/en/portuguese.mo
+%%DATADIR%%/po/en/portuguese_br.mo
%%DATADIR%%/po/en/portuguese_portugal.mo
%%DATADIR%%/po/en/romanian.mo
%%DATADIR%%/po/en/russian.mo
@@ -36,5 +43,11 @@ share/icons/hicolor/scalable/apps/mmex.svg
%%DATADIR%%/po/en/turkish.mo
%%DATADIR%%/po/en/ukrainian.mo
%%DATADIR%%/po/en/vietnamese.mo
+%%DATADIR%%/res/Chart.js
+%%DATADIR%%/res/ChartNew.js
+%%DATADIR%%/res/home_page.htt
%%DATADIR%%/res/kaching.wav
+%%DATADIR%%/res/master.css
%%DATADIR%%/res/mmex.ico
+%%DATADIR%%/res/sorttable.js
+%%DATADIR%%/version.txt