aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/php56-fastdfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/php56-fastdfs/Makefile')
-rw-r--r--ftp/php56-fastdfs/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/ftp/php56-fastdfs/Makefile b/ftp/php56-fastdfs/Makefile
new file mode 100644
index 00000000000..36010f780e5
--- /dev/null
+++ b/ftp/php56-fastdfs/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= php56-fastdfs
+PORTVERSION= 5.0.8
+CATEGORIES= ftp
+
+MAINTAINER= daniel@blodan.se
+COMMENT= PHP 5.6 module for accessing a FastDFS cluster
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libfastcommon.so:devel/libfastcommon \
+ libfdfsclient.so:ftp/fastdfs
+
+USE_GITHUB= yes
+GH_ACCOUNT= happyfish100
+GH_PROJECT= fastdfs
+GH_TAGNAME= 87659981148a362812912b6d4752d281ac05f0b6
+
+USES= php:ext
+IGNORE_WITH_PHP= 55 70
+PHP_DEFAULT= 5.6
+
+WRKSRC_SUBDIR= php_client
+
+PHP_MODNAME= fastdfs_client
+
+.include <bsd.port.mk>