aboutsummaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/zphoto/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 10c03be738a..21384074e10 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -17,14 +17,12 @@ COMMENT= Zooming photo album generator
LIB_DEPENDS= ming.5:${PORTSDIR}/graphics/ming \
popt.0:${PORTSDIR}/devel/popt
-.if !defined (WITHOUT_AVIPLAY)
-LIB_DEPENDS+= aviplay.0:${PORTSDIR}/multimedia/avifile
-.endif
.if !defined (WITHOUT_ZIP)
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
.endif
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-avifile
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
@@ -36,9 +34,6 @@ PLIST_FILES+= bin/wxzphoto
.else
CONFIGURE_ARGS+= --disable-wx
.endif
-.if defined (WITHOUT_AVIPLAY)
-CONFIGURE_ARGS+= --disable-avifile
-.endif
.if defined (WITHOUT_ZIP)
CONFIGURE_ARGS+= --disable-zip
.endif