aboutsummaryrefslogtreecommitdiffstats
path: root/lang/phantomjs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/phantomjs/Makefile')
-rw-r--r--lang/phantomjs/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index c13cbe8ba40..d2e3084e2b2 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -15,8 +15,7 @@ BROKEN_sparc64= does not link on sparc64
NOT_FOR_ARCHS= armv6 armv7
NOT_FOR_ARCHS_REASON= Platform.h: Not supported ARM architecture
-BUILD_DEPENDS= bash:shells/bash \
- python:lang/python
+BUILD_DEPENDS= bash:shells/bash
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libicui18n.so:devel/icu \
@@ -34,6 +33,7 @@ GH_TUPLE= Vitallium:phantomjs-3rdparty-win:19051aa:msvc2013/src/qt/3rdparty \
RUBY_NO_RUN_DEPENDS= yes
PLIST_FILES= bin/phantomjs
NO_CCACHE= yes
+BINARY_ALIAS= python=${PYTHON_CMD}
OPTIONS_DEFINE= X11
X11_USE= XORG=x11