aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index b715d5919c7..edafd36665e 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -107,6 +107,18 @@ PLIST_SUB+= SUB_HTDIG=""
PLIST_SUB+= SUB_HTDIG="@comment "
.endif
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "You may change the following build options:"
+ @${ECHO} "MM_USERNAME=mailman The username of the Mailman user."
+ @${ECHO} "MM_USERID=91 The user ID of the Mailman user."
+ @${ECHO} "MM_GROUPNAME=mailman The group to which the Mailman user will belong."
+ @${ECHO} "MM_GROUPID=MM_USERID The group ID for the Mailman user."
+ @${ECHO} "MM_DIR=mailman Mailman will be installed in ${PREFIX}/${MM_DIR}."
+ @${ECHO} "CGI_GID=www The group name or id under which your web server executes CGI scripts."
+ @${ECHO} "IMGDIR=www/icons Icon images will be installed in ${PREFIX}/${IMGDIR}."
+ @${ECHO} ""
+
post-patch:
@${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
${WRKSRC}/Mailman/Defaults.py.in