aboutsummaryrefslogtreecommitdiffstats
path: root/mail/zmailer/files
diff options
context:
space:
mode:
Diffstat (limited to 'mail/zmailer/files')
-rw-r--r--mail/zmailer/files/extra-patch-EAI_NODATA37
-rw-r--r--mail/zmailer/files/patch-Makefile.in10
-rw-r--r--mail/zmailer/files/patch-aa51
-rw-r--r--mail/zmailer/files/patch-ab64
-rw-r--r--mail/zmailer/files/patch-ac10
-rw-r--r--mail/zmailer/files/patch-ad24
-rw-r--r--mail/zmailer/files/patch-ae11
-rw-r--r--mail/zmailer/files/patch-af11
-rw-r--r--mail/zmailer/files/patch-ag11
-rw-r--r--mail/zmailer/files/patch-ah11
-rw-r--r--mail/zmailer/files/patch-proto::Makefile.in21
-rw-r--r--mail/zmailer/files/patch-proto::post-install.sh.in11
-rw-r--r--mail/zmailer/files/patch-smtpserver::smtpcmds.c11
-rw-r--r--mail/zmailer/files/pkg-install.in4
14 files changed, 126 insertions, 161 deletions
diff --git a/mail/zmailer/files/extra-patch-EAI_NODATA b/mail/zmailer/files/extra-patch-EAI_NODATA
new file mode 100644
index 00000000000..b42624c6e7f
--- /dev/null
+++ b/mail/zmailer/files/extra-patch-EAI_NODATA
@@ -0,0 +1,37 @@
+--- smtpserver/mxverify.c.orig Fri Apr 16 15:45:46 2004
++++ smtpserver/mxverify.c Fri Apr 16 15:46:38 2004
+@@ -607,7 +607,6 @@
+ if (retmode == '+') {
+ if (rc == -EX_NOHOST ||
+ rc == -EX_UNAVAILABLE ||
+- rc == EAI_NODATA ||
+ rc == EAI_NONAME)
+ return -2; /* Definitely hard errors */
+ if (rc == 2)
+--- transports/smtp/smtp.c.orig Fri Apr 16 15:48:44 2004
++++ transports/smtp/smtp.c Fri Apr 16 15:54:18 2004
+@@ -2912,6 +2912,7 @@
+ return EX_DEFERALL;
+ }
+
++#if 0 /* FreeBSD 5.x doesn't have it */
+ if ( r == EAI_NODATA ) {
+ sprintf(SS->remotemsg,"smtp; 500 (getaddrinfo<%.200s>: No data)",host);
+ time(&endtime);
+@@ -2925,6 +2926,7 @@
+ return EX_DEFERALL;
+ return EX_UNAVAILABLE;
+ }
++#endif
+
+ r = EX_UNAVAILABLE; /* This gives instant rejection */
+ if (rc == EX_TEMPFAIL) r = rc;
+@@ -2944,7 +2946,7 @@
+ if (r != EX_TEMPFAIL)
+ r = EX_NOHOST;
+ #endif
+- } else if (gai_err == EAI_NONAME || gai_err == EAI_NODATA) {
++ } else if (gai_err == EAI_NONAME) {
+ sprintf(SS->remotemsg,
+ "smtp; 500 (nameserver data inconsistency. No MX, no address: '%.200s' (%s))",
+ host, gai_err == EAI_NONAME ? "NONAME" : "NODATA");
diff --git a/mail/zmailer/files/patch-Makefile.in b/mail/zmailer/files/patch-Makefile.in
new file mode 100644
index 00000000000..f702dd1f9a2
--- /dev/null
+++ b/mail/zmailer/files/patch-Makefile.in
@@ -0,0 +1,10 @@
+--- Makefile.in.orig Wed Apr 14 17:22:31 2004
++++ Makefile.in Wed Apr 14 17:23:04 2004
+@@ -130,6 +130,7 @@
+ @cd transports ; $(MAKE) $(MFLAGS) install
+ @cd libc ; $(MAKE) $(MFLAGS) install
+ @cd utils ; $(MAKE) $(MFLAGS) install
++ @cd man ; $(MAKE) $(MFLAGS) install
+ $(MAKE) $(MFLAGS) post-install-note
+
+ post-install-note:
diff --git a/mail/zmailer/files/patch-aa b/mail/zmailer/files/patch-aa
index 8c2b1668203..fbaa6b69493 100644
--- a/mail/zmailer/files/patch-aa
+++ b/mail/zmailer/files/patch-aa
@@ -1,20 +1,35 @@
---- configure.in.orig Mon Jul 19 00:38:50 1999
-+++ configure.in Sun Sep 29 01:34:20 2002
-@@ -936,7 +936,7 @@
- AC_SUBST(AUTHLIB)
- AC_CHECK_HEADERS(security/pam_appl.h shadow.h)
- if test "$ac_cv_header_security_pam_appl_h" = "yes"; then
-- AUTHLIB="-lpam -ldl"
-+ AUTHLIB="-lpam"
- else
- if test "$ac_cv_header_shadow_h" = "yes"; then
- AUTHLIB="-lshadow"
-@@ -956,7 +956,7 @@
- AC_MSG_RESULT([%%% AIEEE! NO <netinet/in.h> HEADER ?!])
- fi
+--- configure.orig Fri Dec 26 10:29:15 2003
++++ configure Fri Dec 26 10:33:26 2003
+@@ -280,6 +280,7 @@
+ # Factoring default headers for most tests.
+ ac_includes_default="\
+ #include <stdio.h>
++#include <sys/param.h>
+ #if HAVE_SYS_TYPES_H
+ # include <sys/types.h>
+ #endif
+@@ -20317,7 +20318,7 @@
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
--AC_TRY_COMPILE([#include <sys/socket.h>],[socklen_t sl = 2;],
-+AC_TRY_COMPILE([#include <sys/types.h> #include <sys/socket.h>],[socklen_t sl = 2;],
- AC_DEFINE(HAVE_SOCKLEN_T))
+-#include <sys/types.h>
++#include <sys/param.h>
+ #include <sys/mount.h>
+ #include <sys/fs_types.h>
+ int
+@@ -20493,6 +20494,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
++#include <sys/param.h>
+ #include <sys/mount.h>
- AC_ARG_WITH(ipv6,[ --with-ipv6 Have IPv6 in system, and want to use it],
+ _ACEOF
+@@ -20539,6 +20541,7 @@
+ /* end confdefs.h. */
+
+ #include <sys/fs_types.h>
++#include <sys/param.h>
+ #include <sys/mount.h>
+ _ACEOF
+ if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
diff --git a/mail/zmailer/files/patch-ab b/mail/zmailer/files/patch-ab
index 070c235965f..f167d88b90d 100644
--- a/mail/zmailer/files/patch-ab
+++ b/mail/zmailer/files/patch-ab
@@ -1,54 +1,10 @@
---- configure.orig Mon Jul 19 00:48:10 1999
-+++ configure Sun Sep 29 01:36:22 2002
-@@ -94,6 +94,8 @@
- --with-getpwnam-library=\"-L.. -l..\"
- Linking options for non-std getpwnam() libraries"
- ac_help="$ac_help
-+ --with-openssl Use openssl"
-+ac_help="$ac_help
- --with-openssl-prefix=/dir/path (defines both include and lib)"
- ac_help="$ac_help
- --with-openssl-include=/dir/incl/path"
-@@ -4661,7 +4663,7 @@
- done
-
- if test "$ac_cv_header_security_pam_appl_h" = "yes"; then
-- AUTHLIB="-lpam -ldl"
-+ AUTHLIB="-lpam"
- else
- if test "$ac_cv_header_shadow_h" = "yes"; then
- AUTHLIB="-lshadow"
-@@ -4723,6 +4725,7 @@
- cat > conftest.$ac_ext <<EOF
- #line 4725 "configure"
- #include "confdefs.h"
-+#include <sys/types.h>
- #include <sys/socket.h>
- int main() {
- socklen_t sl = 2;
-@@ -7847,6 +7850,9 @@
-
-
-
-+# Check whether we are using openssl.
-+if test "x$with_openssl" != xno; then
-+
- # Check whether --with-openssl-prefix or --without-openssl-prefix was given.
- if test "${with_openssl_prefix+set}" = set; then
- withval="$with_openssl_prefix"
-@@ -7929,12 +7935,13 @@
- OPENSSLPREFIX="/usr"
- OPENSSLINCL=""
- if test -f "$OPENSSLPREFIX/lib/libssl.so" ; then
-- OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.so $OPENSSLPREFIX/lib/libcrypto.so"
-+ OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.so $OPENSSLPREFIX/lib/libcrypto.so \$(EXTRA_SSL_LIBS)"
- else
-- OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.a $OPENSSLPREFIX/lib/libcrypto.a"
-+ OPENSSLLIB="$OPENSSLPREFIX/lib/libssl.a $OPENSSLPREFIX/lib/libcrypto.a \$(EXTRA_SSL_LIBS)"
- fi
- echo "$ac_t""You have OpenSSL version 0.9.3a (or newer) at system root!" 1>&6
- fi
-+fi
- fi
-
-
+--- transports/smtp/getmxrr.c.orig Mon Jun 23 12:04:35 2003
++++ transports/smtp/getmxrr.c Fri Dec 26 11:30:58 2003
+@@ -416,7 +416,6 @@
+ break;
+ case EAI_NONAME:
+ case EAI_FAIL:
+- case EAI_NODATA:
+ case EAI_SERVICE:
+ default:
+ break;
diff --git a/mail/zmailer/files/patch-ac b/mail/zmailer/files/patch-ac
deleted file mode 100644
index 56448631e69..00000000000
--- a/mail/zmailer/files/patch-ac
+++ /dev/null
@@ -1,10 +0,0 @@
---- Makefile.in.orig Mon Jul 19 16:32:01 1999
-+++ Makefile.in Mon Jul 19 16:32:27 1999
-@@ -107,6 +107,7 @@
- @cd transports ; $(MAKE) $(MFLAGS) install
- @cd libc ; $(MAKE) $(MFLAGS) install
- @cd utils ; $(MAKE) $(MFLAGS) install
-+ @cd man ; $(MAKE) $(MFLAGS) install
-
- router/router:
- cd router ; $(MAKE) $(MFLAGS) router-a
diff --git a/mail/zmailer/files/patch-ad b/mail/zmailer/files/patch-ad
deleted file mode 100644
index 6e12dce4308..00000000000
--- a/mail/zmailer/files/patch-ad
+++ /dev/null
@@ -1,24 +0,0 @@
---- libc/Makefile.in.orig Sat Jul 31 15:49:28 1999
-+++ libc/Makefile.in Sat Jul 31 15:50:07 1999
-@@ -74,15 +74,15 @@
- lint $(DEFS) $(INCL) $(LIBC_INCL) $(SOURCE)
-
- install: $(TOPDIR)/libs/libzmailer.a
-- -if [ ! -d $(prefix)$(LIBRARYDIR) ] ; then \
-- $(MKDIR) $(prefix)$(LIBRARYDIR); \
-+ -if [ ! -d $(LIBRARYDIR) ] ; then \
-+ $(MKDIR) $(LIBRARYDIR); \
- fi
-- -if [ ! -d $(prefix)$(INCLUDEDIR) ] ; then \
-- $(MKDIR) $(prefix)$(INCLUDEDIR); \
-+ -if [ ! -d $(INCLUDEDIR) ] ; then \
-+ $(MKDIR) $(INCLUDEDIR); \
- fi
-- -$(INSTALL) -m 644 $(TOPDIR)/libs/libzmailer.a $(prefix)$(LIBRARYDIR)/libzmailer.a
-+ -$(INSTALL) -m 644 $(TOPDIR)/libs/libzmailer.a $(LIBRARYDIR)/libzmailer.a
- -$(RANLIB) $(prefix)$(LIBRARYDIR)/libzmailer.a
-- -$(INSTALL) -m 644 $(TOPDIR)/include/mail.h $(prefix)$(INCLUDEDIR)/zmailer.h
-+ -$(INSTALL) -m 644 $(TOPDIR)/include/mail.h $(INCLUDEDIR)/zmailer.h
-
- clean-recursive clean:
- -rm -f $(TOPDIR)/libs/$(LIBNAME).a make.log whathost-test
diff --git a/mail/zmailer/files/patch-ae b/mail/zmailer/files/patch-ae
deleted file mode 100644
index 83dc479697b..00000000000
--- a/mail/zmailer/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- protoc/cf/SMTP.cf.in.orig Sun Aug 29 14:20:54 1999
-+++ proto/cf/SMTP.cf.in Sun Aug 29 14:21:03 1999
-@@ -88,7 +88,7 @@
- }
-
- orgdomains=x
--: ${MAILCONF:=/etc/mail.conf}
-+: ${MAILCONF:=$MAILSHARE/mail.conf}
- if [ ! -r $MAILCONF ]; then
- echo "$0: missing $MAILCONF: using the following values:"
- mailconf
diff --git a/mail/zmailer/files/patch-af b/mail/zmailer/files/patch-af
deleted file mode 100644
index 3ac31d42826..00000000000
--- a/mail/zmailer/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- libc/Makefile.in.tmp Sun Aug 29 18:16:42 1999
-+++ libc/Makefile.in Sun Aug 29 18:17:49 1999
-@@ -81,7 +81,7 @@
- $(MKDIR) $(INCLUDEDIR); \
- fi
- -$(INSTALL) -m 644 $(TOPDIR)/libs/libzmailer.a $(LIBRARYDIR)/libzmailer.a
-- -$(RANLIB) $(prefix)$(LIBRARYDIR)/libzmailer.a
-+ -$(RANLIB) $(LIBRARYDIR)/libzmailer.a
- -$(INSTALL) -m 644 $(TOPDIR)/include/mail.h $(INCLUDEDIR)/zmailer.h
-
- clean-recursive clean:
diff --git a/mail/zmailer/files/patch-ag b/mail/zmailer/files/patch-ag
deleted file mode 100644
index 02442775a99..00000000000
--- a/mail/zmailer/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- compat/rmail/Makefile.in.orig Sun Aug 29 18:26:53 1999
-+++ compat/rmail/Makefile.in Sun Aug 29 18:27:02 1999
-@@ -15,7 +15,7 @@
- RMAIL_LIB= @LIBRESOLV@ @LIBSOCKET@
- INSTALL= @INSTALL@
- TOPDIR= ../..
--RMAILPATH= $(prefix)@RMAILPATH@
-+RMAILPATH= @RMAILPATH@
- LN_S= "@LN_S@"
- MKDIR= @MKDIR@
- #
diff --git a/mail/zmailer/files/patch-ah b/mail/zmailer/files/patch-ah
deleted file mode 100644
index 73f244321df..00000000000
--- a/mail/zmailer/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- compat/sendmail/Makefile.in.orig Sun Aug 29 18:26:10 1999
-+++ compat/sendmail/Makefile.in Sun Aug 29 18:26:19 1999
-@@ -21,7 +21,7 @@
- LIB= -L$(TOPDIR)/libs -lzm -lzc
- LIBDEB= $(TOPDIR)/libs/libtag
- CFLAGS= $(COPTS) $(CPPFLAGS) $(DEFS) $(INCL) $(SENDMAIL_INCL)
--SENDMAILPATH= $(prefix)@SENDMAILPATH@
-+SENDMAILPATH= @SENDMAILPATH@
-
- SOURCE= sendmail.c
-
diff --git a/mail/zmailer/files/patch-proto::Makefile.in b/mail/zmailer/files/patch-proto::Makefile.in
new file mode 100644
index 00000000000..30afdda08bb
--- /dev/null
+++ b/mail/zmailer/files/patch-proto::Makefile.in
@@ -0,0 +1,21 @@
+--- proto/Makefile.in.orig Fri Oct 24 23:33:43 2003
++++ proto/Makefile.in Fri Apr 16 13:43:29 2004
+@@ -91,10 +91,6 @@
+ echo $(MKDIR) $(DESTDIR)$$MAILBIN/ta && \
+ $(MKDIR) $(DESTDIR)$$MAILBIN/ta ; \
+ fi ; \
+- if [ ! -d $(DESTDIR)$$MAILBIN/bak ]; then \
+- echo $(MKDIR) $(DESTDIR)$$MAILBIN/bak && \
+- $(MKDIR) $(DESTDIR)$$MAILBIN/bak ; \
+- fi ; \
+ if [ ! -d $(DESTDIR)$$POSTOFFICE ]; then \
+ echo $(MKDIR) $(DESTDIR)$$POSTOFFICE && \
+ $(MKDIR) $(DESTDIR)$$POSTOFFICE ; \
+@@ -130,7 +126,6 @@
+
+ mailbin: $(PZCONFIG) $(PMAILBIN) $(MD5SUM)
+ -@(. $(PZCONFIG) ; \
+- if [ ! -d $(DESTDIR)$$MAILBIN/bak ]; then $(MKDIR) $(DESTDIR)$$MAILBIN/bak ; fi ; \
+ for file in $(PMAILBIN) ; \
+ do \
+ name=`expr $$file : '\([^.]*\)'` ; \
diff --git a/mail/zmailer/files/patch-proto::post-install.sh.in b/mail/zmailer/files/patch-proto::post-install.sh.in
new file mode 100644
index 00000000000..c352a1a9bbb
--- /dev/null
+++ b/mail/zmailer/files/patch-proto::post-install.sh.in
@@ -0,0 +1,11 @@
+--- proto/post-install.sh.in.orig Fri Apr 16 12:45:45 2004
++++ proto/post-install.sh.in Fri Apr 16 12:46:00 2004
+@@ -373,7 +373,7 @@
+ ", $POSTOFFICE);
+
+ if (! -d "$POSTOFFICE/.") {
+- mymysystem("$MKDIR -p $POSTOFFICE");
++ mysystem("$MKDIR -p $POSTOFFICE");
+
+ }
+ mysystem("chmod 2755 $POSTOFFICE/.");
diff --git a/mail/zmailer/files/patch-smtpserver::smtpcmds.c b/mail/zmailer/files/patch-smtpserver::smtpcmds.c
deleted file mode 100644
index f64ad2a5368..00000000000
--- a/mail/zmailer/files/patch-smtpserver::smtpcmds.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- smtpserver/smtpcmds.c Mon Aug 19 19:19:54 2002
-+++ smtpserver/smtpcmds.c.orig Mon Aug 19 19:16:28 2002
-@@ -223,7 +223,7 @@
- if (STYLE(SS->cfinfo, 'h')) {
- char argbuf[MAXHOSTNAMELEN+30];
- char *s;
-- sprintf(argbuf,"%s %s", SS->rhostname,
-+ snprintf(argbuf, sizeof(argbuf), "%s %s", SS->rhostname,
- ((SS->ihostaddr && (SS->ihostaddr[0] != '\0'))
- ? SS->ihostaddr : "[0.0.0.0]"));
- if ((s = router(SS, RKEY_HELLO, 1, argbuf, strlen(argbuf))) == NULL)
diff --git a/mail/zmailer/files/pkg-install.in b/mail/zmailer/files/pkg-install.in
new file mode 100644
index 00000000000..fc72ea00a88
--- /dev/null
+++ b/mail/zmailer/files/pkg-install.in
@@ -0,0 +1,4 @@
+#!/bin/sh
+if [ "$2" = POST-INSTALL ]; then
+ %%PREFIX%%/sbin/post-install
+fi