aboutsummaryrefslogtreecommitdiffstats
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/opensmtpd-devel/Makefile1
-rw-r--r--mail/opensmtpd-devel/files/smtpd.in14
-rw-r--r--mail/opensmtpd/Makefile3
-rw-r--r--mail/opensmtpd/files/smtpd.in14
4 files changed, 16 insertions, 16 deletions
diff --git a/mail/opensmtpd-devel/Makefile b/mail/opensmtpd-devel/Makefile
index dcc378e2c53..5db9c5afa3e 100644
--- a/mail/opensmtpd-devel/Makefile
+++ b/mail/opensmtpd-devel/Makefile
@@ -5,6 +5,7 @@ PORTNAME= opensmtpd
PORTVERSION= 201602131907
DISTVERSIONSUFFIX= p1
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
diff --git a/mail/opensmtpd-devel/files/smtpd.in b/mail/opensmtpd-devel/files/smtpd.in
index 5530b1c2b14..46fe0be02ed 100644
--- a/mail/opensmtpd-devel/files/smtpd.in
+++ b/mail/opensmtpd-devel/files/smtpd.in
@@ -18,11 +18,6 @@
. /etc/rc.subr
-check_process()
-{
- /bin/pgrep -j none -f "^$smtpd_procname\$"
-}
-
name="smtpd"
rcvar=smtpd_enable
@@ -34,18 +29,21 @@ extra_commands="configtest"
load_rc_config $name
: ${smtpd_enable:="NO"}
-: ${smtpd_config:="%%PREFIX%%/etc/mail/smtpd.conf"}
-: ${smtpd_procname:="%%PREFIX%%/sbin/smtpd"}
+: ${smtpd_config:="%%PREFIX%%/etc/mail/${name}.conf"}
+: ${smtpd_procname:="%%PREFIX%%/sbin/${name}"}
: ${smtpd_flags:=""}
command=${smtpd_procname}
+command_args="-f ${smtpd_config} ${command_args}"
+required_files="${smtpd_config}"
procname=${smtpd_procname}
+pidfile="/var/run/${name}.pid"
smtpd_checkconfig()
{
echo "Performing sanity check on smtpd configuration:"
- eval ${command} ${smtpd_flags} -n
+ eval ${command} ${command_args} ${smtpd_flags} -n
}
smtpd_precmd()
diff --git a/mail/opensmtpd/Makefile b/mail/opensmtpd/Makefile
index e0b41e1cbee..38f607b7e4a 100644
--- a/mail/opensmtpd/Makefile
+++ b/mail/opensmtpd/Makefile
@@ -4,6 +4,7 @@
PORTNAME= opensmtpd
PORTVERSION= 5.9.2p1
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/
@@ -68,7 +69,9 @@ CONFIGURE_ARGS+= --with-libasr=${LOCALBASE} \
post-patch:
${REINPLACE_CMD} -e '/chmod 2555/d' ${WRKSRC}/mk/smtpctl/Makefile.in
+.if ${PORT_OPTIONS:MTABLE_DB}
post-install:
@${LN} -sf ${PREFIX}/sbin/smtpctl ${STAGEDIR}${PREFIX}/libexec/opensmtpd/makemap
+.endif
.include <bsd.port.post.mk>
diff --git a/mail/opensmtpd/files/smtpd.in b/mail/opensmtpd/files/smtpd.in
index 6fa92ca45c1..46fe0be02ed 100644
--- a/mail/opensmtpd/files/smtpd.in
+++ b/mail/opensmtpd/files/smtpd.in
@@ -18,11 +18,6 @@
. /etc/rc.subr
-check_process()
-{
- /bin/pgrep -j none -f "${smtpd_procname}"
-}
-
name="smtpd"
rcvar=smtpd_enable
@@ -34,18 +29,21 @@ extra_commands="configtest"
load_rc_config $name
: ${smtpd_enable:="NO"}
-: ${smtpd_config:="%%PREFIX%%/etc/mail/smtpd.conf"}
-: ${smtpd_procname:="%%PREFIX%%/sbin/smtpd"}
+: ${smtpd_config:="%%PREFIX%%/etc/mail/${name}.conf"}
+: ${smtpd_procname:="%%PREFIX%%/sbin/${name}"}
: ${smtpd_flags:=""}
command=${smtpd_procname}
+command_args="-f ${smtpd_config} ${command_args}"
+required_files="${smtpd_config}"
procname=${smtpd_procname}
+pidfile="/var/run/${name}.pid"
smtpd_checkconfig()
{
echo "Performing sanity check on smtpd configuration:"
- eval ${command} ${smtpd_flags} -n
+ eval ${command} ${command_args} ${smtpd_flags} -n
}
smtpd_precmd()