aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/profanity/files/patch-configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/profanity/files/patch-configure.ac')
-rw-r--r--net-im/profanity/files/patch-configure.ac32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/profanity/files/patch-configure.ac b/net-im/profanity/files/patch-configure.ac
new file mode 100644
index 00000000000..7949b2ae0a1
--- /dev/null
+++ b/net-im/profanity/files/patch-configure.ac
@@ -0,0 +1,32 @@
+--- configure.ac.orig 2015-03-09 09:51:22.000000000 +0100
++++ configure.ac 2015-03-09 09:56:17.000000000 +0100
+@@ -141,22 +141,21 @@
+ ### Windows uses native OS calls
+ ### OSX requires terminal-notifier
+
+-AS_IF([test "x$PLATFORM" = xosx],
+- [AS_IF([test "x$enable_notifications" != xno],
++AS_IF([test "x$enable_notifications" != xno],
+ [NOTIFIER_PATH="no"
+ AC_PATH_PROG(NOTIFIER_PATH, terminal-notifier, no)
+ AS_IF([test "x$NOTIFIER_PATH" = xno],
+ [AS_IF([test "x$enable_notifications" = xyes],
+- [AC_MSG_ERROR([terminal-notifier not found, required for desktop notifications.])],
++ [AC_MSG_WARN([terminal-notifier not found, required for desktop notifications on OS X.])],
+ [AC_MSG_NOTICE([Desktop notifications not supported.])])],
+- [AC_DEFINE([HAVE_OSXNOTIFY], [1], [terminal notifier])])])],
+- [test "x$PLATFORM" = xnix],
+- [AS_IF([test "x$enable_notifications" != xno],
++ [AC_DEFINE([HAVE_OSXNOTIFY], [1], [terminal notifier])])])
++
++AS_IF([test "x$enable_notifications" != xno],
+ [PKG_CHECK_MODULES([libnotify], [libnotify],
+ [AC_DEFINE([HAVE_LIBNOTIFY], [1], [libnotify module])],
+ [AS_IF([test "x$enable_notifications" = xyes],
+- [AC_MSG_ERROR([libnotify is required but does not exist])],
+- [AC_MSG_NOTICE([libnotify support will be disabled])])])])])
++ [AC_MSG_WARN([libnotify is required but does not exist])],
++ [AC_MSG_NOTICE([libnotify support will be disabled])])])])
+
+ # TODO: rewrite this
+ if test "x$with_xscreensaver" = xyes; then