aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p/qtorrent
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qtorrent')
-rw-r--r--net-p2p/qtorrent/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-p2p/qtorrent/Makefile b/net-p2p/qtorrent/Makefile
index 065f46c32f1..aea50c53337 100644
--- a/net-p2p/qtorrent/Makefile
+++ b/net-p2p/qtorrent/Makefile
@@ -22,6 +22,12 @@ USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+.if defined(PACKAGE_BUILDING)
+TMPDIR?= /tmp
+MAKE_ENV+= TMPDIR="${TMPDIR}"
+CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
+.endif
+
pre-everything::
@${ECHO_MSG} "===>"
@${ECHO_MSG} "===> For qtorrent to work you need to compile"
@@ -30,7 +36,7 @@ pre-everything::
post-patch:
.for i in torrentsettings torrentwindow
- @${LOCALBASE}/bin/pyuic -o ${WRKSRC}/pyqtorrent/${i}.py ${WRKSRC}/pyqtorrent/${i}.ui
+ @${SETENV} ${MAKE_ENV} ${LOCALBASE}/bin/pyuic -o ${WRKSRC}/pyqtorrent/${i}.py ${WRKSRC}/pyqtorrent/${i}.ui
.endfor
.include <bsd.port.mk>