aboutsummaryrefslogtreecommitdiffstats
path: root/net-p2p
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoin/Makefile37
-rw-r--r--net-p2p/bitcoin/distinfo4
2 files changed, 21 insertions, 20 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 7e97f5e30b2..559d7f6a64c 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bitcoin
-PORTVERSION= 0.7.0
+PORTVERSION= 0.7.1
CATEGORIES= net-p2p finance
MAINTAINER= robbak@robbak.com
@@ -14,20 +14,23 @@ COMMENT= Virtual Peer-to-Peer Currency Client
LIB_DEPENDS= boost_date_time:${PORTSDIR}/devel/boost-libs
-OPTIONS= GUI "Build with QT3 GUI" on \
- UPNP "Build with UPNP support" off \
- QRCODES "Build with QR code display" on
+OPTIONS_DEFINE= GUI UPNP QRCODES
+OPTIONS_DEFAULT= GUI QRCODES
-USE_GITHUB= yes
-GH_ACCOUNT= bitcoin
+GUI_DESC= Build as a QT3 GUI
+UPNP_DESC= Build with UPNP support
+QRCODES_DESC= Build with QR code display
+
+USE_GITHUB= yes
+GH_ACCOUNT= bitcoin
GH_PROJECT= bitcoin
-GH_COMMIT= a76c22e
+GH_COMMIT= d082365
GH_TAGNAME= v${PORTVERSION}
USE_GMAKE= yes
USE_OPENSSL= yes
USE_BDB= yes
-WANT_BDB_VER= 47
+WANT_BDB_VER= 48
CXXFLAGS+= -I${LOCALBASE}/include -I${BDB_INCLUDE_DIR}
CXXFLAGS+= -L${LOCALBASE}/lib -L${BDB_LIB_DIR}
@@ -35,7 +38,7 @@ CXXFLAGS+= -Wno-invalid-offsetof
.include <bsd.port.options.mk>
-.if defined(WITH_GUI) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
USE_QT_VER= 4
USE_QT4= corelib gui qmake_build linguist uic moc rcc
BINARY= bitcoin-qt
@@ -45,7 +48,7 @@ ALL_TARGET= ${BINARY}
MAKE_ARGS+= -C ${WRKSRC}/src
.endif
-.if defined(WITH_QRCODES)
+.if ${PORT_OPTIONS:MQRCODES}
LIB_DEPENDS+= qrencode:${PORTSDIR}/graphics/libqrencode
QMAKE_USE_QRCODE=1
.else
@@ -54,7 +57,7 @@ QMAKE_USE_QRCODE=0
PLIST_FILES= bin/${BINARY}
-.if defined(WITH_UPNP)
+.if ${PORT_OPTIONS:MUPNP}
LIB_DEPENDS+= miniupnpc:${PORTSDIR}/net/miniupnpc
QMAKE_USE_UPNP= 1
.else
@@ -67,19 +70,17 @@ post-patch:
@${CP} ${WRKSRC}/src/protocol.h ${WRKSRC}/src/protocol.h.orig
@${AWK} 'BEGIN { f = 0 } { if ( $$0 ~ /^#include/ && f == 0 ) { f = 1; print "#include <sys/socket.h>"; print "#include <netinet/in.h>" }; print }' \
${WRKSRC}/src/protocol.h.orig > ${WRKSRC}/src/protocol.h
-
+.if !${PORT_OPTIONS:MGUI} || defined(WITHOUT_X11)
@cd ${WRKSRC}/src && ${CP} -p makefile.unix Makefile
@${REINPLACE_CMD} \
- -e 's|wx-config|${WX_CONFIG}|g' \
- -e 's|^CXXFLAGS=.*$$|CXXFLAGS += $$(DEFS)|' \
- -e 's|^USE_UPNP.*$$||' \
+ -e 's|^USE_UPNP.*$$|USE_UPNP=${QMAKE_USE_UPNP}|' \
-e 's|-l pthread|${PTHREAD_LIBS}|g' \
- -e 's:-O3::' -e 's:-\(march=[A-Za-z0-9]*\)::g' \
-e 's:-l dl::' \
${WRKSRC}/src/Makefile
+.endif
do-configure:
-.if defined(WITH_GUI) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} USE_UPNP=${QMAKE_USE_UPNP} USE_QRCODE=${QMAKE_USE_QRCODE} \
QMAKE_LRELEASE=lrelease-qt4 PREFIX=${PREFIX} INCLUDEPATH=${BDB_INCLUDE_DIR} \
@@ -88,7 +89,7 @@ do-configure:
do-install:
@${MKDIR} ${PREFIX}/bin
-.if defined(WITH_GUI) && !defined(WITHOUT_X11)
+.if ${PORT_OPTIONS:MGUI} && !defined(WITHOUT_X11)
${INSTALL_PROGRAM} ${WRKSRC}/${BINARY} ${PREFIX}/bin/
.else
${INSTALL_PROGRAM} ${WRKSRC}/src/${BINARY} ${PREFIX}/bin/
diff --git a/net-p2p/bitcoin/distinfo b/net-p2p/bitcoin/distinfo
index 4ad4558828b..0ff7a1e4145 100644
--- a/net-p2p/bitcoin/distinfo
+++ b/net-p2p/bitcoin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bitcoin-0.7.0.tar.gz) = d0b5ca34c61e8fbd6dca53f2730fa3d8e3df1f7bb40d5e42f8ea4cd3bf32a221
-SIZE (bitcoin-0.7.0.tar.gz) = 1603153
+SHA256 (bitcoin-0.7.1.tar.gz) = eb1c4bb59a6a6557e59dec5d90ab7c45b660898f535fafaeaed051aeb347b94d
+SIZE (bitcoin-0.7.1.tar.gz) = 1623510
013-05-09 04:26:42 +0800'>2013-05-091-2/+2 * - Bump PORTREVISION after update of x11/libxfce4util, and x11-wm/xfce4-panelolivierd2013-05-091-3/+3 * - Convert to USES=pkgconfigbdrewery2013-05-091-1/+2 * Mark MAKE_JOBS_SAFEehaupt2013-05-081-0/+1 * update sqwebmail 5.6.1oliver2013-05-082-4/+3 * update courier-imap to 4.13oliver2013-05-082-3/+3 * The previous commit (r316786) broke 'extract' since it redefined WRKSRC.ehaupt2013-05-082-5/+5 * Mark as broken and deprecated, since this port does not work with pythonrm2013-05-081-0/+4 * Update to 0.9.0 release.ale2013-05-074-9/+18 * Update to 0.9.0 release.ale2013-05-076-107/+119 * Add some shebangfix to allow building most of the ports tree without /usr/bin...bapt2013-05-074-9/+16 * - Update to 2.8.3bdrewery2013-05-072-3/+4 * - Convert to use shebangfix USES flagehaupt2013-05-071-8/+7 * Convert to use shebangfix USES flag.ehaupt2013-05-071-9/+3 * - Add LICENSEsunpoet2013-05-071-5/+4 * Fix with USES+= ncursesbapt2013-05-061-3/+2 * Convert USE_NCURSES by USES=ncursesbapt2013-05-065-17/+9 * Make these ports build with glib 2.36kwm2013-05-061-0/+4 * Update to 0.19.tobez2013-05-062-8/+4 * Fix installation of ports that rely on cp -n for installing files. r245960flo2013-05-051-1/+1 * Fix build on currentbapt2013-05-041-1/+1 * Chase security/libgcrypt updateehaupt2013-05-044-10/+6 * Fix build with bmakebapt2013-05-031-5/+5 * Fix build with bmake as makebapt2013-05-031-0/+3 * - Update to 2.201culot2013-05-022-8/+4 * - Set expiration date to 2013-06-01, depends on expired mail/p5-vpopmailrene2013-05-021-11/+13 * - Update to 1.9.9.13107bdrewery2013-05-022-4/+4 * - add OPTION DKIMdinoex2013-05-012-2/+21 * Add licence info to some portscrees2013-05-011-5/+4 * - Remove redundant :install target on LIB_DEPENDS and RUN_DEPENDSbdrewery2013-05-011-5/+2 * - Fix cases where 2 USES= were usedbdrewery2013-05-012-4/+2 * - conversion of USE_GETTEXT to USES frameworkjgh2013-05-011-9/+5 * - Update to 3.1.77. [1]stefan2013-04-304-9/+56 * Remove expired ports:rene2013-04-308-319/+0 * - Update MASTER_SITESmiwi2013-04-301-1/+1 * Remove latest references to USE_BISONbapt2013-04-291-1/+0 * Rely on bsdtar to autodetermine the format of the distfiles when possiblebapt2013-04-296-12/+11 * - Update to 5.3.1p1ashish2013-04-282-4/+4 * - rename patch, since it's now applied uncoditionally and remove EXTRA_PATCHE...rm2013-04-272-6/+4 * - Convert USE_ICONV=yes to USES=iconvmva2013-04-2739-50/+40 * Remove MySQL 4.1, it has been unsupported upstream for almost 3.5 years.flo2013-04-271-13/+4 * Update to 2.5.4.stefan2013-04-262-5/+5 * - Convert USE_GETTEXT to USES (part 4)ak2013-04-264-7/+4 * - Mark CONFLICTS among mail/libspf2, mail/p5-Mail-SPF and mail/p5-Mail-SPF-Qu...sunpoet2013-04-264-22/+13 * Fix a regression that had crept in with r314621. Do notsahil2013-04-265-5/+5 * Update to 1.4.31.novel2013-04-252-3/+3 * - Convert USE_GETTEXT to USES (part 3)ak2013-04-2551-51/+51 * - fix NOPORTDOCSjgh2013-04-253-22/+60 * For some unmaintained ports:eadler2013-04-252-10/+6 * - Fix ezmlm support by using subcommands of ezmlm-listbdrewery2013-04-243-3/+39 * - Convert USE_GETTEXT to USES (part 1)ak2013-04-244-8/+4 * - Update to 4.2.1ehaupt2013-04-244-22/+23 * Upgrade to new version 6.3.26.mandree2013-04-242-3/+3 * Finish converting the whole ports tree to USES=pkgconfigbapt2013-04-2310-31/+14 * Convert to USES=gettextehaupt2013-04-231-1/+1 * - Update to Postfix 2.11 Snapshot 20130405sahil2013-04-233-11/+14 * - Update to 2.8.14 and adjust CONFLICTSsahil2013-04-233-13/+17 * - Update to 2.7.13 and adjust CONFLICTSsahil2013-04-233-9/+15 * - Update to 2.6.19, update CONFLICTS and marksahil2013-04-232-5/+10 * Repo-copy mail/postfix -> mail/postfix29, and updatesahil2013-04-2313-12/+847 * Fix build with clang 3.3flo2013-04-232-0/+47 * - update to 8.14.7dinoex2013-04-232-3/+3 * Reassign skv@ ports to the heapbapt2013-04-223-18/+6 * Horde ports update:mm2013-04-228-12/+12 * Fix typo in GD_DESC.olgeni2013-04-211-1/+1 * - Update to 0.85bdrewery2013-04-152-6/+9 * - Add a DIST_SUBDIR to avoid conflicting with mail/mailutils distfilebdrewery2013-04-132-7/+4 * - Update to 3.2.13 to fix security vulnerabilitiesbdrewery2013-04-114-11/+7 * - update thunderbird, firefox-esr, linux-thunderbird and linux-firefox toflo2013-04-0464-3586/+189 * Don't install catman pages; causes leftovers.crees2013-03-301-0/+1 * GNU Emacs updatesashish2013-03-309-8/+9 * This port now needs textproc/aspell to build.ehaupt2013-03-301-0/+2 * - Update Haskell ports from the development repositorypgj2013-03-305-9/+8 * Add working mirror for tls patchbdrewery2013-03-301-1/+2 * Fix COMMENTeadler2013-03-291-1/+1 * For perl@ owned ports:eadler2013-03-298-39/+14 * Update to 2.8.2madpilot2013-03-297-50/+50 * Style: tab -> space.eadler2013-03-2912-12/+12 * Update to 0.8.6 release.ale2013-03-282-3/+3 * Mechanically convert unmaintained ports which use "gnomehack" to use "pathfix...eadler2013-03-282-13/+6 * - Update to 5.3p1ashish2013-03-273-7/+25 * share/gnome-2.0 is handled by gnomehier.kwm2013-03-271-2/+0 * - Make php53 default to fix conflict between php54 and php53miwi2013-03-273-0/+6 * - Update to 2.11.1cs2013-03-272-2/+2 * New port: mail/p5-Net-SMTP-TLS-ButMaintained:zi2013-03-275-0/+43 * Fix typo on var namegarga2013-03-261-1/+1 * Update to new upstream release 6.3.25.mandree2013-03-263-5/+5 * - Fix depend gnupg1beech2013-03-251-1/+1 * - Add explicit pkgconf dependencybdrewery2013-03-242-10/+4 * - convert to optionsngflo2013-03-243-15/+195 * - convert USE_CMAKE to USESmakc2013-03-236-6/+6 * - remove three self-tests again, two because they were meant to bemandree2013-03-221-1/+2 * Fix tripple quoting that will cause problems when the ports tree is switched ...eadler2013-03-221-6/+2 * - Update to 4.4.3ume2013-03-214-23/+42 * Correct dumpfile location.ume2013-03-201-1/+2 * This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.eadler2013-03-191-1/+1 * balsa: add back pre.mk and post.mk seem to fix the failurekwm2013-03-191-1/+3 * Convert almost all gnome@ ports to OptionsNG, trim header, use USES=pathfixkwm2013-03-192-35/+33 * - adopt optionsNGjgh2013-03-195-434/+292 * - Rename and add missing description for QMAIL_PORTbdrewery2013-03-181-4/+5 * Take maintainershipbdrewery2013-03-181-1/+1 * - Take maintainershipbdrewery2013-03-183-7/+5 * - Grab maintainershipbeech2013-03-181-1/+1 * - Take maintainershipbdrewery2013-03-183-16/+11 * - Take maintainershipbdrewery2013-03-181-9/+6 * - Take maintainershipbdrewery2013-03-172-8/+13 * - Convert to PEAR_AUTOINSTALLmiwi2013-03-175-36/+17 * In categories starting with [h-m], remove empty lines from pkg-plist (anddanfe2013-03-174-4/+0 * - Reset Maintainerscheidell2013-03-171-1/+1 * - Update the port to 4.4.1swills2013-03-173-46/+24 * - Fix leftover /var/qmail/control/localsbdrewery2013-03-161-1/+0 * - MYSQL and PGSQL are default in b.o.d.mmiwi2013-03-161-4/+2 * - adopt optionsNGjgh2013-03-161-16/+12 * - Use VPOPMAIL_DIR as install target since that isbdrewery2013-03-162-32/+33 * - add DESC bit for TOKYOCABINETjgh2013-03-161-1/+1 * - Convert USE_QMAIL_RUN, USE_QMAIL_BUILD and WANT_QMAIL into USES featurebdrewery2013-03-1632-141/+70 * - Unbreak buildmiwi2013-03-151-3/+1 * - Convert to PEAR_AUTOINSTALLmiwi2013-03-151-4/+2 * - rename CYRUS_SASL2 option to SASL [1,2]jgh2013-03-151-5/+6 * - Trim headermiwi2013-03-151-9/+3 * - Convert to PEAR_AUTOINSTALLmiwi2013-03-151-13/+3 * - Convert to PEAR_AUTOINSTALLmiwi2013-03-151-14/+2 * - fix CYRUS_SASL2 breakagejgh2013-03-151-1/+1 * Add new rc script for sympacrees2013-03-155-40/+228 * - Update to 4.39.1miwi2013-03-142-3/+3 * - adopt optionsNG and remove legacy information from pkg-descrjgh2013-03-143-313/+178 * - Update to 1.0100gblach2013-03-142-3/+3 * Fix OPTIONS_DEFINE being defined twicebdrewery2013-03-121-3/+1 * - Fix error when QMAIL_PREFIX is not defined due to extra spacesbdrewery2013-03-121-1/+1 * 2013-03-05 ftp/proma: Broken for more than 6 monthbapt2013-03-105-76/+0 * Change MAINTAINER to my FreeBSD.org address.tmseck2013-03-101-1/+1 * - Update to version 0.8.3pawel2013-03-097-117/+68 * - update thunderbird, firefox-esr, linux-thunderbird and linux-firefox toflo2013-03-096-92/+92 * Clean up my ports (and a couple of ports@ owned ones):eadler2013-03-091-0/+2 * - Drop support for perl < 12.xaz2013-03-091-8/+1 * - Update to 1.8.6beech2013-03-093-452/+29 * Remove indefinite article from COMMENTehaupt2013-03-082-12/+4 * Convert USE_BISON to USES= bisonbapt2013-03-085-23/+10