aboutsummaryrefslogtreecommitdiffstats
path: root/palm/jpilot-picsnvideos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/jpilot-picsnvideos/Makefile')
-rw-r--r--palm/jpilot-picsnvideos/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/palm/jpilot-picsnvideos/Makefile b/palm/jpilot-picsnvideos/Makefile
new file mode 100644
index 00000000000..c9303cf77a7
--- /dev/null
+++ b/palm/jpilot-picsnvideos/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: jpilot-picsnvideos
+# Date created: 18 Feb 2010
+# Whom: Sascha Klauder <sklauder@trimind.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= picsnvideos
+PORTVERSION= 0.2
+CATEGORIES= palm comms graphics
+MASTER_SITES= SF/${PORTNAME}/source%20code/${PORTVERSION}
+PKGNAMEPREFIX= jpilot-
+
+MAINTAINER= sklauder@trimind.de
+COMMENT= JPilot plugin to to download photos and videos
+
+RUN_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
+BUILD_DEPENDS= jpilot:${PORTSDIR}/palm/jpilot
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${PREFIX}/lib"
+PORTDOCS= README AUTHORS
+PLIST_FILES= lib/jpilot/plugins/libpicsnvideos.la \
+ lib/jpilot/plugins/libpicsnvideos.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for FILE in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>