aboutsummaryrefslogtreecommitdiffstats
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/orthanc/Makefile7
-rw-r--r--science/orthanc/distinfo4
-rw-r--r--science/orthanc/pkg-plist2
3 files changed, 7 insertions, 6 deletions
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index 7814c28a149..a4cc9f68d29 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= orthanc
-PORTVERSION= 0.9.3
+PORTVERSION= 0.9.4
CATEGORIES= science graphics net www
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/orthanc/:main \
http://www.montefiore.ulg.ac.be/~jodogne/Orthanc/ThirdPartyDownloads/:mongoose
@@ -38,7 +38,7 @@ CMAKE_ARGS= -DDCMTK_LIBRARIES="dcmdsig;charls;dcmjpls" \
-DUSE_SYSTEM_MONGOOSE=OFF \
-DUNIT_TESTS_WITH_HTTP_CONNEXIONS=OFF
-USES= cmake:outsource python:build lua:51 dos2unix
+USES= cmake:outsource dos2unix lua:51 python:build
DOS2UNIX_FILES= CMakeLists.txt
USE_LDCONFIG= yes
USE_OPENSSL= yes
@@ -46,6 +46,7 @@ USE_RC_SUBR= orthanc
WRKSRC= ${WRKDIR}/Orthanc-${PORTVERSION}
USERS= orthanc
GROUPS= orthanc
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
# This is mongoose sources, downloaded from Orthanc author homepage. Orthanc
# requires mongoose webserver, but after version 3.8, mongoose developers has
@@ -81,7 +82,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 1001000
-IGNORE= supported only on 10.1 by upstream, not all unit tests are passed
+IGNORE= supported only on 10.x by upstream, not all unit tests are passed
.endif
.if ${OSVERSION} > 1100000
diff --git a/science/orthanc/distinfo b/science/orthanc/distinfo
index 11c8e4bd5d5..1efa94326cc 100644
--- a/science/orthanc/distinfo
+++ b/science/orthanc/distinfo
@@ -1,4 +1,4 @@
-SHA256 (orthanc/Orthanc-0.9.3.tar.gz) = b0cfa7223c038d5ba13b823531da40e0edcec57105bd84ed36294f09aef4d0f3
-SIZE (orthanc/Orthanc-0.9.3.tar.gz) = 675679
+SHA256 (orthanc/Orthanc-0.9.4.tar.gz) = 8cff5c50ea62d47fe99674c7c21297dd8e8bca6c38a5c9350f023f069d189c35
+SIZE (orthanc/Orthanc-0.9.4.tar.gz) = 1103580
SHA256 (orthanc/mongoose-3.8.tgz) = 6afc2c377614a01a24b78560a62d1316b29372afe08eae3715b56c877be71c6e
SIZE (orthanc/mongoose-3.8.tgz) = 1577314
diff --git a/science/orthanc/pkg-plist b/science/orthanc/pkg-plist
index a6756d11f1a..52cf3812d1c 100644
--- a/science/orthanc/pkg-plist
+++ b/science/orthanc/pkg-plist
@@ -12,5 +12,5 @@ include/orthanc/OrthancCDatabasePlugin.h
include/orthanc/OrthancCPlugin.h
include/orthanc/OrthancCppDatabasePlugin.h
%%DATADIR%%/plugins/libServeFolders.so
-%%DATADIR%%/plugins/libServeFolders.so.0.9.3
+%%DATADIR%%/plugins/libServeFolders.so.%%PORTVERSION%%
sbin/Orthanc