aboutsummaryrefslogtreecommitdiffstats
path: root/security/nmap
diff options
context:
space:
mode:
Diffstat (limited to 'security/nmap')
-rw-r--r--security/nmap/Makefile23
-rw-r--r--security/nmap/distinfo1
-rw-r--r--security/nmap/files/nmap.187
-rw-r--r--security/nmap/pkg-comment1
-rw-r--r--security/nmap/pkg-descr12
-rw-r--r--security/nmap/pkg-plist2
6 files changed, 126 insertions, 0 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
new file mode 100644
index 00000000000..0247f07d251
--- /dev/null
+++ b/security/nmap/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# Ports collection makefile for: nmap
+# Version required: 1.51
+# Date created: Tue Aug 04, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= nmap-1.51
+CATEGORIES= security
+MASTER_SITES= http://www.insecure.org/nmap/
+
+MAINTAINER= obrien@FreeBSD.org
+
+GNU_CONFIGURE= yes
+MAN1= nmap.1
+
+post-install:
+ @strip ${PREFIX}/bin/nmap
+ @${INSTALL_MAN} ${FILESDIR}/nmap.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/nmap/distinfo b/security/nmap/distinfo
new file mode 100644
index 00000000000..ed2e8d80b96
--- /dev/null
+++ b/security/nmap/distinfo
@@ -0,0 +1 @@
+MD5 (nmap-1.51.tar.gz) = 1a5e2d4fbc455120a581c1bd68dbd9d7
diff --git a/security/nmap/files/nmap.1 b/security/nmap/files/nmap.1
new file mode 100644
index 00000000000..091ef06c37d
--- /dev/null
+++ b/security/nmap/files/nmap.1
@@ -0,0 +1,87 @@
+.\"
+.\" Copyright (c) 1998 David E. O'Brien
+.\"
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE DEVELOPERS ``AS IS'' AND ANY EXPRESS OR
+.\" IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+.\" OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+.\" IN NO EVENT SHALL THE DEVELOPERS BE LIABLE FOR ANY DIRECT, INDIRECT,
+.\" INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+.\" NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+.\" DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+.\" THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+.\" (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+.\" THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+.\"
+.\" $Id$
+.\"
+.\" .TH NMAP 1L local
+.Dd August 4, 1998
+.Dt NMAP 1
+.Os BSD
+.Sh NAME
+.Nm nmap
+.Nd network port scanner
+.Sh SYNOPSIS
+.Nm nmap
+.Op Ar options
+.Ar hostname
+.Op Ar /mask
+.Sh DESCRIPTION
+.Nm
+is a utility for port scanning large networks, although it works fine for
+single hosts. The guiding philosophy for the creation of
+.Nm
+was TMTOWTDI (There's More Than One Way To Do It). This is the Perl slogan, but
+it is equally applicable to scanners. Sometimes you need speed, other times you
+may need stealth. In some cases, bypassing firewalls may be required. Not to
+mention the fact that you may want to scan different protocols (UDP, TCP, ICMP,
+etc.). You just can't do all this with one scanning mode. And you don't want to
+have 10 different scanners around, all with different interfaces and
+capabilities. Thus
+.Nm
+incorporats virtually every scanning technique known.
+Specifically,
+.Nm
+supports:
+
+ Vanilla TCP connect() scanning,
+ TCP SYN (half open) scanning,
+ TCP FIN (stealth) scanning,
+ TCP ftp proxy (bounce attack) scanning
+ SYN/FIN scanning using IP fragments (bypasses packet filters),
+ UDP recvfrom() scanning,
+ UDP raw ICMP port unreachable scanning,
+ ICMP scanning (ping-sweep), and
+ Reverse-ident scanning.
+
+.Nm
+also supports a number of performance and reliability features such as dynamic
+delay time calculations, packet timeout and retransmission, parallel port
+scanning, detection of down hosts via parallel pings, and flexible target and
+port specification.
+.Sh FILES
+none.
+.Sh SEE ALSO
+.Xr mscan 1L ,
+.Xr nc 1L ,
+.Xr scrobe 1L
+.Sh DIAGNOSTICS
+none.
+.Sh BUGS
+none known.
+.Sh AUTHORS
+This man page has been written by David O'Brien (obrien@cs.ucdavis.edu)
+.\" .Sh HISTORY
+.\" .Nm
+.\" appeared in FreeBSD 3.0.
diff --git a/security/nmap/pkg-comment b/security/nmap/pkg-comment
new file mode 100644
index 00000000000..3ef3521f935
--- /dev/null
+++ b/security/nmap/pkg-comment
@@ -0,0 +1 @@
+port scanning utility for large networks
diff --git a/security/nmap/pkg-descr b/security/nmap/pkg-descr
new file mode 100644
index 00000000000..c77e677a1b2
--- /dev/null
+++ b/security/nmap/pkg-descr
@@ -0,0 +1,12 @@
+nmap is a utility for port scanning large networks, although it works fine
+for single hosts. The guiding philosophy for the creation of nmap was TMTOWTDI
+(There's More Than One Way To Do It). Sometimes you need speed, other times
+you may need stealth. In some cases, bypassing firewalls may be required. Not
+to mention the fact that you may want to scan different protocols (UDP, TCP,
+ICMP, etc.). You just can't do all this with one scanning mode. Thus nmap
+incorporats virtually every scanning technique known of.
+
+See the nmap homepage at http://www.insecure.org/nmap/index.html
+
+-- David
+ obrien@cs.ucdavis.edu
diff --git a/security/nmap/pkg-plist b/security/nmap/pkg-plist
new file mode 100644
index 00000000000..8f498c525c3
--- /dev/null
+++ b/security/nmap/pkg-plist
@@ -0,0 +1,2 @@
+bin/nmap
+man/man1/nmap.1.gz
ilder-devel?h=gnome-3.24&id=87f4d471fb27b9547c1a0de221b51f4c31684157'>- Welcome X.org 7.2 \o/.flz2007-05-201-1/+1 * - Remove QTDIR from CONFIGURE_ENV, it's in there already thanks to frameworkpav2007-02-131-1/+1 * Mark broken under 4.X.cy2007-01-111-1/+8 * Pkg-plist fixup.cy2006-12-131-0/+2 * Record checksum of final distfile from author.cy2006-12-112-2/+5 * Update from 2.0.10 to 2.1.8.cy2006-12-114-67/+48 * No need to conditionalise USE_GETOPT_LONG.lawrance2006-02-131-4/+1 * Remove subdirectory from MASTER_SITES= line; it's already handledfenner2005-11-281-1/+1 * Update to 2.0.10mnag2005-11-143-3/+13 * - Update to 2.0.8pav2005-07-203-2/+4 * Upgrade to 2.0.5.vanilla2005-05-138-47/+12 * Update to 2.0.5vs2005-01-173-4/+4 * Upgrade to 2.0.4.vanilla2004-12-053-4/+12 * Fix build on 4-stablevanilla2004-10-276-1/+55 * Upgrade to 2.0.2vanilla2004-10-143-267/+48 * BROKEN on 5.x: Does not compilekris2004-09-191-1/+7 * - Portlintpav2004-05-261-3/+3 * SIZEify (maintainer timeout)trevor2004-03-311-0/+1 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-1/+1 * - Update 1.1.2clement2004-01-184-140/+127 * - Update to 1.1.1sergei2003-12-196-258/+268 * PR: 56405foxfair2003-09-06