aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile2
-rw-r--r--www/xpi-conkeror/Makefile56
-rw-r--r--www/xpi-conkeror/distinfo6
-rw-r--r--www/xpi-conkeror/files/patch-conkeror18
-rw-r--r--www/xpi-conkeror/pkg-descr2
5 files changed, 61 insertions, 23 deletions
diff --git a/www/Makefile b/www/Makefile
index ed70971fb10..d603211e502 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -101,7 +101,6 @@
SUBDIR += codeigniter
SUBDIR += comclear
SUBDIR += commonist
- SUBDIR += conkeror
SUBDIR += contenido
SUBDIR += coppermine
SUBDIR += crawl
@@ -1671,6 +1670,7 @@
SUBDIR += xpi-clearfields
SUBDIR += xpi-close-all-tabs
SUBDIR += xpi-colorfultabs
+ SUBDIR += xpi-conkeror
SUBDIR += xpi-cookiesafe
SUBDIR += xpi-cssviewer
SUBDIR += xpi-customizegoogle
diff --git a/www/xpi-conkeror/Makefile b/www/xpi-conkeror/Makefile
index 5679ab66d6a..0464b5d983a 100644
--- a/www/xpi-conkeror/Makefile
+++ b/www/xpi-conkeror/Makefile
@@ -6,30 +6,50 @@
#
PORTNAME= conkeror
-PORTVERSION= 0.42
-PORTREVISION= 2
-DISTVERSIONPREFIX= firefox-
+PORTVERSION= 20090821
CATEGORIES= www
-MASTER_SITES= MOZDEV
-PKGNAMEPREFIX?=
+MASTER_SITES= http://mirror.4bit.ws/ \
+ ${MASTER_SITE_LOCAL} \
+ ${MASTER_SITE_FREEBSD}
+MASTER_SITE_SUBDIR= dhn
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= wahjava@gmail.com
COMMENT= A completely keyboard driven browser based on firefox
-RUN_DEPENDS= ${CONK_APP}:${PORTSDIR}/www/${CONK_APP}
+WRKSRC= ${WRKDIR}/conkeror
+USE_GECKO= libxul
-CONK_ARGS= -chrome chrome://conkeror/content
-CONK_APP?= ${PKGNAMEPREFIX}firefox
-CONK_EXEC?= ${PKGNAMEPREFIX}${PORTNAME}
-USE_XPI= ${CONK_APP}
-PLIST_FILES= bin/${CONK_EXEC}
-XPI_ID= {a79fe89b-6662-4ff4-8e88-09950ad4dfde}
-XPI_FILES= chrome/conkeror.jar components/nsCrank.js install.rdf chrome.manifest
-XPI_DIRS= chrome components
+BUILD_ID=echo -n `whoami`@`hostname`_`date +%s`
+
+post-patch:
+ cd ${WRKSRC} && \
+ ${REINPLACE_CMD} -e "s/%%PREFIX%%/${PREFIX:S/\//\\\//g}/g" \
+ ${WRKSRC}/conkeror && \
+ ${MV} debian/conkeror.desktop . && \
+ ${RM} -rf debian tests && \
+ ${MKDIR} share && \
+ ${MV} branding chrome components content \
+ contrib defaults locale modules search-engines help style share
+
+do-build:
+ ${MAKE} -C ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/conkeror
+ ${MKDIR} ${DESKTOPDIR}
+ cd ${WRKSRC}/share && ${COPYTREE_SHARE} . ${DATADIR}
+ ${SED} -e "s/BuildID=git/BuildID=$$(${BUILD_ID})/g" \
+ -e "s/^Version=\(.*\)$$/Version=\1 (FreeBSD-${OSREL})/g" \
+ <${WRKSRC}/application.ini >${DATADIR}/application.ini
+ ${REINPLACE_CMD} -e "s/\\\$$CONKEROR_VERSION\\$$/`${GREP} \
+ '^Version=' ${WRKSRC}/application.ini |${SED} \
+ -e 's/^Version=//'` (FreeBSD-${OSREL})/g" ${DATADIR}/components/application.js
+ ${INSTALL_SCRIPT} ${WRKSRC}/conkeror ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/conkeror.desktop ${DESKTOPDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/conkeror-spawn-helper ${PREFIX}/libexec/conkeror/
+ ${LN} -sf ${PREFIX}/libexec/conkeror/conkeror-spawn-helper ${DATADIR}/
post-install:
- @${ECHO_CMD} exec `${WHICH} ${CONK_APP}` ${CONK_ARGS} > ${PREFIX}/bin/${CONK_EXEC}
- @${CHMOD} 555 ${PREFIX}/bin/${CONK_EXEC}
+ @-update-desktop-database
-.include "${.CURDIR}/../xpi-adblock/Makefile.xpi"
.include <bsd.port.mk>
diff --git a/www/xpi-conkeror/distinfo b/www/xpi-conkeror/distinfo
index 7d36582f552..253bdf167d4 100644
--- a/www/xpi-conkeror/distinfo
+++ b/www/xpi-conkeror/distinfo
@@ -1,3 +1,3 @@
-MD5 (xpi/conkeror-firefox-0.42.xpi) = db3fd94485ced11e6a6685064a0c2e8e
-SHA256 (xpi/conkeror-firefox-0.42.xpi) = 64bd54093b96ba5897a1180d3aeb56e48a6edf9b83750c5fb5675bfdb0d272de
-SIZE (xpi/conkeror-firefox-0.42.xpi) = 62867
+MD5 (conkeror-20090821.tar.gz) = c6563dfec0802cf7e28f826edbdf953a
+SHA256 (conkeror-20090821.tar.gz) = a6e5a66ee2f8997e2d4ea769a2d6df0226e8f4c726f20535b45bc75b0098feb9
+SIZE (conkeror-20090821.tar.gz) = 238630
diff --git a/www/xpi-conkeror/files/patch-conkeror b/www/xpi-conkeror/files/patch-conkeror
new file mode 100644
index 00000000000..f16e2ae74ae
--- /dev/null
+++ b/www/xpi-conkeror/files/patch-conkeror
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- conkeror.orig
++++ conkeror
+@@ -0,0 +1,12 @@
++#!/bin/sh
++
++XULRUNNER=$(which xulrunner)
++
++if [ -z "${XULRUNNER}" ]; then
++ echo Unable to locate xulrunner binary.
++elif [ ! -x "${XULRUNNER}" ]; then
++ echo ${XULRUNNER} is not executable.
++else
++ exec ${XULRUNNER} /usr/local/share/conkeror/application.ini
++fi
++
diff --git a/www/xpi-conkeror/pkg-descr b/www/xpi-conkeror/pkg-descr
index 2d3792ce2c5..4ad588bc022 100644
--- a/www/xpi-conkeror/pkg-descr
+++ b/www/xpi-conkeror/pkg-descr
@@ -5,4 +5,4 @@ means all the keybindings and to-die-for features of
Emacs that can be imitated by a javascript/XUL web
browser Just Work.
-WWW: http://conkeror.mozdev.org/
+WWW: http://conkeror.org/
Makefile?h=gstreamer0.10-removal&id=00f6d948dcde127bdf3f66540574d7ba484443ae'>This port provides full CUPS support for the Konica-Minolta Magicolor 2430DLpav2005-10-091-0/+1 * Italian version of Adobe Reader.ale2005-10-081-0/+1 * localized versions of Adobe Reader (formerly Acrobat Reader)trevor2005-10-081-0/+1 * print/preview-latex has been integrated into print/auctex.hrs2005-09-301-1/+0 * Add foomatic-db-hpijs, foomatic data for the HPIJS printer drivers.lofi2005-09-211-0/+1 * add new port: Photo Image Print System for Linux --- EPSON PM-930C (for LPR)ume2005-08-281-0/+1 * This includes some tools that are in FreeType 1's contrib directory.pav2005-07-291-0/+1 * New port print/texinfo version 4.8: A typeset documentation systemlioux2005-05-311-0/+1 * Add flpsed 0.3.4, WYSIWYG pseudo Postscript editor.danfe2005-05-251-0/+1 * New port py-rtf, a library to create RTF documents using the Python language.tg2005-05-111-0/+1 * New port ec-fonts-mftraced version 1.0.12: EC PostScript Type1 fontslioux2005-04-191-0/+1 * add dvisvg 0.7.4dijliao2005-04-151-0/+1 * Add fpdf 1.53, a free PHP class to generate PDF files with pure PHP.thierry2005-04-061-0/+1 * add new ports: Photo Image Print System for Linux --- EPSON Stylusume2005-03-201-0/+1 * This is acroread7, the new version of Adobe Acrobat reader.joerg2005-03-201-0/+1 * PDFjam, by David Firth, is a small collection of shell scriptspav2005-03-191-0/+1 * A small tool to merge several PDF files into one PDF filepav2005-03-191-0/+1 * Add libgnomeprintmm, C++ bindings for the GNOME printing backend library.marcus2005-03-121-0/+1 * New port of Photo Image Print System for Linux --- EPSON Stylusume2005-02-271-0/+1 * As previously announced, remove ports that have reached their expiry date,kris2005-02-191-1/+0 * Remove print/teTeX-latex2e because the new print/teTeX-texmf alreadyhrs2005-02-061-1/+0 * Add alignmargins, a utility script to generate custom margins in PPDs forlofi2005-01-281-0/+1 * Add foomatic-filters, wrapper scripts for foomatic.lofi2005-01-281-0/+1 * - Move print/ggv2 to print/ggvpav2005-01-251-1/+1 * Move acroread5 to acroread, as requested by tg and vs.trevor2004-12-241-1/+1 * Remove print/txfonts and print/pxfonts. The files installed by thesehrs2004-12-201-2/+0 * Add latexmk, tool which completely automates the process of generating a LaTeXpav2004-12-191-0/+1 * As previously announced, remove print/acroread due to security problems.linimon2004-11-281-1/+0 * Ruby/GnomePrint is a Ruby binding of libgnomeprint.mezz2004-11-161-0/+1 * Add print/teTeX-latex2e, The latest version of LaTeX2e macro packagehrs2004-10-261-0/+1 * Announce the release of GPL Ghostscript. This release is based onkrion2004-10-161-0/+2 * add slave portume2004-08-301-0/+1 * add slave portume2004-08-301-0/+1 * add slave portume2004-08-301-0/+1 * add slave portume2004-08-301-0/+1 * add slave portume2004-08-301-0/+1 * add slave portume2004-08-301-0/+1 * add slave portume2004-08-301-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PX-G900.ume2004-08-291-0/+1 * add slave port for Photo Image Print System for Linux ---ume2004-08-291-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PX-V700ume2004-08-281-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PX-V700ume2004-08-281-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-G800ume2004-08-281-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-G700ume2004-08-281-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-730Cume2004-08-281-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-4000PXume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-740Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-740Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-970Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-970Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-940Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-870Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-870Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PM-980Cume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PX-V600ume2004-08-271-0/+1 * add slave port for Photo Image Print System for Linux --- EPSON PX-V500ume2004-08-271-0/+1 * Complete repocopy from print/tipa to print/latex-tipavs2004-08-181-1/+1 * Add tex-omegaware-old, old versions of ovf2ovp, ovp2ovf,hrs2004-07-251-0/+1 * Add latex-msc 1.14, laTeX macro package for drawing Message Sequence Charts.vs2004-07-191-0/+1 * add pslib 0.2.2ijliao2004-07-131-0/+1 * Add cups-samba, a client-side drivers for CUPS/Samba FreeBSD serverpav2004-06-271-0/+1 * Add pecl-panda 0.1.0, a PECL extension to create PDF documents.ale2004-06-251-0/+1 * Add pecl-pdflib 2.0, a PECL extension to create PDF on the fly.ale2004-06-251-0/+1 * Remove expired ports, plus the three ports that depended on them.kris2004-06-211-1/+0 * Add teTeX-basekris2004-06-191-0/+1 * print/teTeX restructuring:hrs2004-06-181-0/+1 * Add cups-pdf, a virtual printer for CUPS to produce PDF files.pav2004-06-181-0/+1 * Remove teTeX-base again. Fixing modules breaks INDEX.erwin2004-06-071-1/+0 * Add teTeX-baseerwin2004-06-071-0/+1 * Add pmw, a computer program for high quality music typesetting.pav2004-05-291-0/+1 * Add latex-ucs 20040307, a LaTeX package for using UTF-8 as inputthierry2004-05-251-0/+1 * Add libotf 0.9,krion2004-05-191-0/+1 * Add dvipsk-tetex, a port for the dvipsk utilityhrs2004-05-131-0/+1 * Upgrade to fontforge.nork2004-05-011-1/+0 * Update to 20031210.nork2004-05-011-0/+1 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-021-0/+2 * Add pdftk, a simple tool for doing everyday things with PDF documents.pav2004-04-021-0/+1 * Retire this port. It has served its purpose, and now everything thatmarcus2004-03-231-1/+0 * - Remove print/rubber, it's duplicate of textproc/rubber.pav2004-03-221-1/+0 * Add latex-lineno 3.10.20031112,krion2004-03-061-0/+1 * Add latex-arydshln 1.6.20030825,krion2004-03-061-0/+1 * Add latex-pict2e 0.2.20040219,krion2004-03-051-0/+1 * Add tipa, a collection of fonts and macros to use the T3-encoded IPA with LaT...pav2004-02-281-0/+1 * Add latex-logpap 0.6.20040201,krion2004-02-141-0/+1 * Add gl2ps 1.1.2,krion2004-01-311-0/+1 * Add latex-index 4.02.b.20040120,krion2004-01-301-0/+1 * Add latex-subfloat 2.14.20030821,krion2004-01-291-0/+1 * Add latex-booktabs 1.618.20030328,krion2004-01-261-0/+1 * Add latex-bytefield 1.1.20021008,krion2004-01-261-0/+1 * Add latex-biblist 1.4.19920113,krion2004-01-261-0/+1 * Add latex-bibunits 2.2.20001010,krion2004-01-261-0/+1 * Add latex-bibtopic 1.0.20020822,krion2004-01-261-0/+1 * Add latex-feynmf 1.08.19961202,krion2004-01-261-0/+1 * Add latex-timing 1.0.19940515,krion2004-01-261-0/+1 * Add latex-layouts 2.6.20031125,krion2004-01-261-0/+1 * Add latex-subfig 1.1.20040112,krion2004-01-261-0/+1 * Add latex-caption 3.0.20031220,krion2004-01-261-0/+1 * Add tex-texmflocal 1.0,krion2004-01-261-0/+1 * Add latex-mathabx 1.0.20031201,krion2004-01-251-0/+1 * Add latex-keystroke 1.0.20001109,krion2004-01-251-0/+1 * Add pxfonts 1.0, yet another Palatino-style font for LaTeX.krion2004-01-241-0/+1 * Add latex-beamer 1.21,krion2004-01-241-0/+1 * Add latex-xcolor 1.06,krion2004-01-241-0/+1 * Add latex-pgf 0.50,krion2004-01-241-0/+1 * Add print/kaspaliste.linimon2004-01-071-0/+1 * add ttfquery 0.2.6ijliao2004-01-051-0/+1 * add texpower 0.0.9dijliao2003-12-301-0/+1 * Add two new KDE apps to deal with CDs:linimon2003-12-291-0/+2 * add pfbtopfa 1.0ijliao2003-12-241-0/+1 * New port: epsmerge, merge multiple EPS files into single PS or EPS output.bms2003-12-091-0/+1 * add typetools 1.80ijliao2003-12-051-0/+1 * add libpdf++ 0.0.3ijliao2003-12-051-0/+1 * add tipograf 0.4ijliao2003-12-051-0/+1 * development version of print/lilypond:eik2003-11-211-0/+1 * Add gribouy 0.0.8, Gribouy is a Type1 font editor.bland2003-11-201-0/+1 * Add gnomephotoprinter 0.6, Gnome Photo Printer is intended forbland2003-11-171-0/+1 * Add libpaper, a library providing routines for paper size management.lofi2003-11-171-0/+1 * As announced on Aug 7, remove the broken pdflib4 portkris2003-11-081-1/+0 * The pktrace program has been renamed to mftrace.trevor2003-11-051-1/+1 * New port mapagi version 0.6: Pagination utility that prints yourlioux2003-10-271-0/+1 * New port: print/phppdflibedwin2003-10-121-0/+1 * new port: print/epsonepl "Printer filter for EPSON EPL-5700L etc"edwin2003-10-101-0/+1 * New port: print/foomatic-db-engineedwin2003-10-081-0/+1 * Port of rubber.edwin2003-10-061-0/+1 * New port for print/mupedwin2003-10-061-0/+1 * Add p5-Net-Printer 0.32, perl extension for direct-to-lpd printing.erwin2003-08-291-0/+1 * As announced on May 6, remove the broken print/xpp port.kris2003-08-081-1/+0 * Add xfce4-print 3.99.2, xFce 4 graphical frontend for printing.oliver2003-07-291-0/+1 * Add gnome-cups-manager, a GNOME administration GUI for the CUPS print system.marcus2003-07-161-0/+1 * Add libgnomecups, the GNOME interface to the CUPS print system.marcus2003-07-161-0/+1 * Begin the de-orbit burn of the GNOME 1.4 desktop. This is phase I. Allmarcus2003-07-161-1/+0 * Unhook acroread-*font before actual deletion of each ports.kuriyama2003-07-081-1/+0 * Remove this port due to possible security bug.kuriyama2003-07-081-1/+0 * Add abcm2ps, command line program which converts ABC files to PS music sheets.arved2003-06-271-0/+1 * Original source never maintained.kiri2003-05-071-1/+0 * As announced on 27 March 2003 in <20030328052350.GA18971@rot13.obsecurity.org>,kris2003-05-061-1/+0 * print/pdflib -> print/pdflib4edwin2003-04-141-0/+1 * Add pdflib-perl.marcus2003-04-061-0/+1 * New port: print/foomatic-dbedwin2003-04-011-0/+1 * dvipdfm-cjk -> dvipdfmx, and upgrade to 20030313ijliao2003-03-301-1/+1 * Re-add libgnomeprint-2.0 for ports that will need it:marcus2003-02-211-0/+1 * dvipdfm is now part of teTeXijliao2003-02-201-1/+0 * add Acrobat Reader 5 CJK font packsijliao2003-02-061-0/+1 * Add PostScript::Simple 0.05 - a perl module to produce PostScript files.tobez2003-02-041-0/+1 * add font2svgijliao2003-01-171-0/+1 * These ports have been FORBIDDEN for 3 months, and removal was announcedkris2002-12-091-13/+0 * Add Pup. pup (Printer Utility Program) is a GUI utility for maintaining yourarved2002-11-231-0/+1 * Add gtklp, a GTK+ frontend to CUPS.marcus2002-11-181-0/+1 * Remove obsoleted port.kuriyama2002-10-191-1/+0 * add wprint 2.04ijliao2002-10-151-0/+1 * New port abntex version 0.5: Both classes and styles for both LaTexlioux2002-09-201-0/+1 * Uses KDE2. No upgrade path known.alane2002-09-131-1/+0 * add bibcursed 2.0.0ijliao2002-08-111-0/+1 * add txtbdf2ps 0.7.1ijliao2002-08-101-0/+1 * add psmark 2.0ijliao2002-08-041-0/+1 * New port: print/cups-pstoraster, a very limited version of easy software'salane2002-07-251-0/+1 * Add ggv2 after a repo-copy from ggv. ggv2 is the GNOME 2.0 Postscript andmarcus2002-07-081-0/+1 * add dvipdfm-cjk 20020531ijliao2002-07-061-0/+1 * add txfonts 3.1.1ijliao2002-06-191-0/+1 * Add envelope 1.0.0, command-line Postscript envelope printer.alane2002-06-131-0/+1 * Add PassiveTeX. PassiveTeX is an XML Formatting Objects processor,nik2002-06-041-0/+1 * add pktrace 1.0.4ijliao2002-06-031-0/+1 * xmltex is an XML parser and formatting system written in TeX.nik2002-05-291-0/+1 * Update acroread5 to acroread5dwcjr2002-05-241-0/+1 * add latex2slides 0.8.1ijliao2002-05-231-0/+1 * Add lgrind 3.67, produce beautiful listings of source code with LaTeX.cy2002-05-161-0/+1 * Add ghostscript-gnu-jpnfont ghostscript-gnu-korfont ghostscript-gnu-commfontkris2002-05-151-0/+1 * add axpoint 1.21ijliao2002-05-141-0/+1 * add p5-PDFLib 0.12ijliao2002-05-141-0/+1 * add hpijs 1.1ijliao2002-05-081-0/+1 * add libijs 0.3.4ijliao2002-05-081-0/+1 * A new port print/adobe-cmapsmita2002-05-031-0/+1 * Say goodbye to Qt 1.x and all of its dependents. The one port I foundwill2002-04-191-1/+0 * Remove texinfokris2002-04-111-1/+0 * add gimp-print 4.2.0ijliao2002-04-031-0/+1 * Update libgnomeprint to 1.111.0 after a repo-copy from gnomeprint and connectsobomax2002-03-201-0/+1 * add scribus 0.5ijliao2002-03-151-0/+1 * Add muttprint 0.61, utility to print mail with mutt.dwcjr2002-02-121-0/+1 * add catdvi 0.12ijliao2002-02-111-0/+1 * Add pdflibdwcjr2002-01-271-0/+1 * Add preview-latex, LaTeX previewer on Emacs 21.yoichi2002-01-271-0/+1 * Add ghostscript-gnu-cjk 6.52,mita2002-01-18