aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/radare-cutter/Makefile29
-rw-r--r--x11/radare-cutter/distinfo3
-rw-r--r--x11/radare-cutter/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index a6df1353bed..2a054f0505a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -281,6 +281,7 @@
SUBDIR += qterminal
SUBDIR += qterminal-l10n
SUBDIR += qxkb
+ SUBDIR += radare-cutter
SUBDIR += randrproto
SUBDIR += recordproto
SUBDIR += rendercheck
diff --git a/x11/radare-cutter/Makefile b/x11/radare-cutter/Makefile
new file mode 100644
index 00000000000..0f102a19b45
--- /dev/null
+++ b/x11/radare-cutter/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= radare-cutter
+PORTVERSION= 1.1
+DISTVERSIONPREFIX= v
+CATEGORIES= x11
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= GUI for radare2 reverse engineering framework
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libr2.so:devel/radare2
+
+USES= pkgconfig qmake
+USE_GITHUB= yes
+GH_ACCOUNT= radareorg
+GH_PROJECT= cutter
+
+USE_QT5= buildtools_build core gui svg widgets
+
+WRKSRC_SUBDIR= src
+
+PLIST_FILES= bin/cutter \
+ share/applications/cutter.desktop \
+ share/pixmaps/cutter.svg
+
+.include <bsd.port.mk>
diff --git a/x11/radare-cutter/distinfo b/x11/radare-cutter/distinfo
new file mode 100644
index 00000000000..782d5b51443
--- /dev/null
+++ b/x11/radare-cutter/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514874553
+SHA256 (radareorg-cutter-v1.1_GH0.tar.gz) = ed1be7778f6a733343d4628a0ba2598f6c3f521e08c6d45289a58c2313e2297b
+SIZE (radareorg-cutter-v1.1_GH0.tar.gz) = 635945
diff --git a/x11/radare-cutter/pkg-descr b/x11/radare-cutter/pkg-descr
new file mode 100644
index 00000000000..315013e99c8
--- /dev/null
+++ b/x11/radare-cutter/pkg-descr
@@ -0,0 +1,3 @@
+A Qt and C++ GUI for radare2 reverse engineering framework
+
+WWW: https://github.com/radareorg/cutter