From f6e6aa3a02327d5b21a0cad9e5c445f830ce8418 Mon Sep 17 00:00:00 2001
From: sobomax <sobomax@FreeBSD.org>
Date: Mon, 3 Feb 2003 13:26:32 +0000
Subject: Update to 0.8.0.

PR:		47827
Submitted by:	David Magda <dmagda+fbugs@ee.ryerson.ca>
---
 audio/sweep/Makefile              | 27 +++++++++++++++++++--------
 audio/sweep/distinfo              |  2 +-
 audio/sweep/files/patch-aa        | 11 -----------
 audio/sweep/files/patch-ab        | 10 ----------
 audio/sweep/files/patch-configure | 13 +++++++++++++
 audio/sweep/pkg-comment           |  2 +-
 audio/sweep/pkg-descr             | 32 ++++----------------------------
 audio/sweep/pkg-plist             |  7 ++++++-
 8 files changed, 44 insertions(+), 60 deletions(-)
 delete mode 100644 audio/sweep/files/patch-aa
 delete mode 100644 audio/sweep/files/patch-ab
 create mode 100644 audio/sweep/files/patch-configure

(limited to 'audio/sweep')

diff --git a/audio/sweep/Makefile b/audio/sweep/Makefile
index e43d2d85dbc..c33d33f4b6e 100644
--- a/audio/sweep/Makefile
+++ b/audio/sweep/Makefile
@@ -6,28 +6,39 @@
 #
 
 PORTNAME=	sweep
-PORTVERSION=	0.1.1
+PORTVERSION=	0.8.0
 CATEGORIES=	audio gnome
 MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
 MASTER_SITE_SUBDIR=	${PORTNAME}
 
 MAINTAINER=	sobomax@FreeBSD.org
 
+LIB_DEPENDS=	sndfile.1:${PORTSDIR}/audio/libsndfile \
+		samplerate.0:${PORTSDIR}/audio/libsamplerate \
+		vorbis.2:${PORTSDIR}/audio/libvorbis \
+		speex.0:${PORTSDIR}/audio/speex \
+		mad.1:${PORTSDIR}/audio/mad \
+		tdb.1:${PORTSDIR}/databases/tdb
+
 USE_X_PREFIX=	yes
-USE_GNOME=	yes
 USE_GMAKE=	yes
 USE_LIBTOOL=	yes
-
+USE_REINPLACE=	yes
+USE_GNOMENG=	yes
+USE_GNOME=	gnomeprefix gnomehier gnomehack gtk12
 CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS=	--with-extralibdir=${LOCALBASE}/lib \
+		--with-extraincdir=${LOCALBASE}/include \
+		--with-vorbis=${LOCALBASE}/lib \
+		--with-vorbis=${LOCALBASE}/include/vorbis \
+		--with-ogg=${LOCALBASE}/lib \
+		--with-ogg=${LOCALBASE}/include/ogg
 
 MAN1=		sweep.1
 
-pre-patch:
-	@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+	@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
 		s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-	@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
-		's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
-		 s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
 
 .include <bsd.port.mk>
diff --git a/audio/sweep/distinfo b/audio/sweep/distinfo
index 2b03ced4201..fbad1b1be74 100644
--- a/audio/sweep/distinfo
+++ b/audio/sweep/distinfo
@@ -1 +1 @@
-MD5 (sweep-0.1.1.tar.gz) = 6676bbd453e33863626a17a8892dde7a
+MD5 (sweep-0.8.0.tar.gz) = 9089996c81da430e29749a4b18dd0833
diff --git a/audio/sweep/files/patch-aa b/audio/sweep/files/patch-aa
deleted file mode 100644
index 224eba887c6..00000000000
--- a/audio/sweep/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/file_ops.c	2000/09/25 09:15:46	1.1
-+++ src/file_ops.c	2000/09/25 09:15:49
-@@ -54,7 +54,7 @@
-   if (!pathname) return NULL;
- 
-   samplefile = afOpenFile(pathname, "r", NULL);
--  if (samplefile <= 0)
-+  if (samplefile == AF_NULL_FILEHANDLE)
-     /*    return (int) samplefile;*/
-     return NULL;
- 
diff --git a/audio/sweep/files/patch-ab b/audio/sweep/files/patch-ab
deleted file mode 100644
index 800422e290b..00000000000
--- a/audio/sweep/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/driver.c	2000/09/25 09:09:58	1.1
-+++ src/driver.c	2000/09/25 09:10:23
-@@ -24,6 +24,7 @@
- 
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <sys/time.h>
- #include <sys/types.h>
- #include <sys/stat.h>
diff --git a/audio/sweep/files/patch-configure b/audio/sweep/files/patch-configure
new file mode 100644
index 00000000000..be4a3e204a9
--- /dev/null
+++ b/audio/sweep/files/patch-configure
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- configure	2003/02/03 12:59:06	1.1
++++ configure	2003/02/03 12:59:33
+@@ -5761,6 +5761,7 @@
+ 
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+ 
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/sweep/pkg-comment b/audio/sweep/pkg-comment
index 81f1c3ac90e..6c8efe474fd 100644
--- a/audio/sweep/pkg-comment
+++ b/audio/sweep/pkg-comment
@@ -1 +1 @@
-A sound editor for GNOME desktop
+A sound editor for the GNOME/GTK 1.2 desktop
diff --git a/audio/sweep/pkg-descr b/audio/sweep/pkg-descr
index c3b34a57b9f..18a9675c4c7 100644
--- a/audio/sweep/pkg-descr
+++ b/audio/sweep/pkg-descr
@@ -1,30 +1,6 @@
-Sweep is an editor for sound samples. It operates on files of various formats
-such as .wav, .aiff and .au, and has multiple undo/redo levels and filters.
-
-Sweep features: 
- o Loading and saving of PCM encoded sound formats including AIFF, Sun/NeXT AU
-   and WAV. 
- o Multiple views of each sound: you can view different parts of the same sound
-   in different windows simultaneously, with variable zooming in each view. You
-   can view the entire sound at once, or zoom right down to the individual
-   sample values. 
- o Discontinuous selections: you can select regions of a sound with the mouse.
-   By holding down the <Shift> key whilst selecting more regions, each region
-   is added to the total selection. Also, selection boundaries can be moved,
-   and selection regions merged, at any time.
- o Cut, copy and paste: conventional cut or copy selected regions of a sound,
-   and paste into the same or other sounds.
- o Multiple undo and redo: all operations are reversible and can be re-applied.
- o Simple effects filters: normalisation (maximal amplification without
-   degradation) and time reversing of selected regions. 
- o Playback: playback of entire sound, or of selected regions only. Looped
-   playback of entire sound or selected regions. Editing and effects are not
-   disabled during playback, giving you instantaneous feedback of the result of
-   each action. 
- o Piano-style playback: the computer keyboard keys behave like musical keys
-   for playback of instrument samples, so you can hear how the sample will
-   sound when used in a sequencer or tracker. 
- o Separate volume levels per view, which can be adjusted with the mouse wheel
-   if available. 
+Sweep is an audio editor and live playback tool for GNU/Linux, BSD and
+compatible systems. It supports many music and voice formats including
+WAV, AIFF, Ogg Vorbis, Speex and MP3, with multichannel editing and
+LADSPA effects plugins.
 
 WWW: http://sweep.sourceforge.net/
diff --git a/audio/sweep/pkg-plist b/audio/sweep/pkg-plist
index a0d60ee1869..d0932399fba 100644
--- a/audio/sweep/pkg-plist
+++ b/audio/sweep/pkg-plist
@@ -1,5 +1,4 @@
 bin/sweep
-include/sweep/config.h
 include/sweep/sweep.h
 include/sweep/sweep_filter.h
 include/sweep/sweep_i18n.h
@@ -16,6 +15,9 @@ lib/sweep/libbyenergy.so.1
 lib/sweep/libecho.a
 lib/sweep/libecho.so
 lib/sweep/libecho.so.1
+lib/sweep/libfade.a
+lib/sweep/libfade.so
+lib/sweep/libfade.so.1
 lib/sweep/libladspameta.a
 lib/sweep/libladspameta.so
 lib/sweep/libladspameta.so.1
@@ -29,9 +31,12 @@ share/gnome/apps/Multimedia/sweep.desktop
 share/gnome/pixmaps/sweep.png
 share/gnome/sweep/sweep_logo.ppm
 share/locale/de/LC_MESSAGES/sweep.mo
+share/locale/en_AU/LC_MESSAGES/sweep.mo
 share/locale/fr/LC_MESSAGES/sweep.mo
 share/locale/hu/LC_MESSAGES/sweep.mo
 share/locale/it/LC_MESSAGES/sweep.mo
+share/locale/pl/LC_MESSAGES/sweep.mo
+share/locale/ru/LC_MESSAGES/sweep.mo
 @dirrm share/gnome/sweep
 @dirrm lib/sweep
 @dirrm include/sweep
-- 
cgit