From b44a6f5a177f119691e9347c6b5bdaff99f2a89a Mon Sep 17 00:00:00 2001
From: lawrance <lawrance@FreeBSD.org>
Date: Wed, 29 Jun 2005 14:03:12 +0000
Subject: Add pynids 0.5, python interface to libnids.

PR:		ports/82593
Submitted by:	Corey Smith
---
 net/Makefile         |  1 +
 net/pynids/Makefile  | 27 +++++++++++++++++++++++++++
 net/pynids/distinfo  |  2 ++
 net/pynids/pkg-descr | 11 +++++++++++
 4 files changed, 41 insertions(+)
 create mode 100644 net/pynids/Makefile
 create mode 100644 net/pynids/distinfo
 create mode 100644 net/pynids/pkg-descr

(limited to 'net')

diff --git a/net/Makefile b/net/Makefile
index 6864d44f10d..8ef02d61179 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -679,6 +679,7 @@
     SUBDIR += py-xmlrpclib
     SUBDIR += py-zsi
     SUBDIR += pygopherd
+    SUBDIR += pynids
     SUBDIR += pypvm
     SUBDIR += pyslsk
     SUBDIR += pythondirector
diff --git a/net/pynids/Makefile b/net/pynids/Makefile
new file mode 100644
index 00000000000..d1c94182367
--- /dev/null
+++ b/net/pynids/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for:   pynids
+# Date created:                22 Jun 2005
+# Whom:                        Corey Smith
+#
+# $FreeBSD$
+#
+
+PORTNAME=	pynids
+PORTVERSION=	0.5
+CATEGORIES=	net python
+MASTER_SITES=	http://pilcrow.madison.wi.us/pynids/
+PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
+DISTNAME=	pynids-${PORTVERSION}
+DIST_SUBDIR=	python
+
+MAINTAINER=	corsmith@gmail.com
+COMMENT=	Python interface to libnids
+
+BUILD_DEPENDS=	${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+USE_PYTHON=	yes
+USE_PYDISTUTILS=	yes
+USE_PYTHON_PREFIX=	yes
+
+PLIST_FILES=	%%PYTHON_SITELIBDIR%%/nidsmodule.so
+
+.include <bsd.port.mk>
diff --git a/net/pynids/distinfo b/net/pynids/distinfo
new file mode 100644
index 00000000000..f6c74f43364
--- /dev/null
+++ b/net/pynids/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/pynids-0.5.tar.gz) = ae8fab78881aa60cb2d9e50c9348cf87
+SIZE (python/pynids-0.5.tar.gz) = 136808
diff --git a/net/pynids/pkg-descr b/net/pynids/pkg-descr
new file mode 100644
index 00000000000..080414348cb
--- /dev/null
+++ b/net/pynids/pkg-descr
@@ -0,0 +1,11 @@
+pynids is a python wrapper for libnids, a Network Intrusion Detection
+System library offering sniffing, IP defragmentation, TCP stream
+reassembly and TCP port scan detection. Let your own python routines
+examine (or kill) network conversations.
+
+pynids is free software, licensed under the GPL.
+
+WWW: http://pilcrow.madison.wi.us/pynids/
+
+- Corey Smith
+corsmith@gmail.com
-- 
cgit