From 49bc14e4ed461e1061e880ab3d99c09bdefc7bd2 Mon Sep 17 00:00:00 2001
From: knu <knu@FreeBSD.org>
Date: Tue, 22 Jun 2004 04:09:43 +0000
Subject: Oops, the previous patch was bogus.  Sorry.

---
 sysutils/portupgrade-devel/Makefile                |  2 +-
 sysutils/portupgrade-devel/files/patch-portinfo.rb | 19 ++++++++-----------
 sysutils/portupgrade/Makefile                      |  2 +-
 sysutils/portupgrade/files/patch-portinfo.rb       | 19 ++++++++-----------
 4 files changed, 18 insertions(+), 24 deletions(-)

(limited to 'sysutils')

diff --git a/sysutils/portupgrade-devel/Makefile b/sysutils/portupgrade-devel/Makefile
index cc5d42fbc9b..baf92609e5f 100644
--- a/sysutils/portupgrade-devel/Makefile
+++ b/sysutils/portupgrade-devel/Makefile
@@ -7,7 +7,7 @@
 
 PORTNAME=	portupgrade
 PORTVERSION=	20040529
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	sysutils
 MASTER_SITES=	ftp://ftp.iDaemons.org/pub/distfiles/ \
 		${MASTER_SITE_LOCAL}
diff --git a/sysutils/portupgrade-devel/files/patch-portinfo.rb b/sysutils/portupgrade-devel/files/patch-portinfo.rb
index 2465672975f..749629114d5 100644
--- a/sysutils/portupgrade-devel/files/patch-portinfo.rb
+++ b/sysutils/portupgrade-devel/files/patch-portinfo.rb
@@ -1,11 +1,6 @@
-Index: lib/portinfo.rb
-===================================================================
-RCS file: /home/cvs/pkgtools/lib/portinfo.rb,v
-retrieving revision 1.16
-diff -u -r1.16 portinfo.rb
---- lib/portinfo.rb	8 Nov 2002 17:18:27 -0000	1.16
-+++ lib/portinfo.rb	21 Jun 2004 17:36:11 -0000
-@@ -17,9 +17,9 @@
+--- lib/portinfo.rb.orig	Sat Nov  9 02:18:27 2002
++++ lib/portinfo.rb	Tue Jun 22 13:07:48 2004
+@@ -17,11 +17,9 @@
      line.is_a?(String) or raise ArgumentError,
        "You must specify a one line text of port info."
  
@@ -13,7 +8,9 @@ diff -u -r1.16 portinfo.rb
 +    values = line.chomp.split(FIELD_SEPARATOR)
  
 -    if values.size != NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
-+    if values.size < NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
-       raise ArgumentError, "Port info line must consist of #{NFIELDS} fields."
-     end
+-      raise ArgumentError, "Port info line must consist of #{NFIELDS} fields."
+-    end
++    values.push("") while values.size < NFIELDS
+ 
+     @attr = {}
  
diff --git a/sysutils/portupgrade/Makefile b/sysutils/portupgrade/Makefile
index cc5d42fbc9b..baf92609e5f 100644
--- a/sysutils/portupgrade/Makefile
+++ b/sysutils/portupgrade/Makefile
@@ -7,7 +7,7 @@
 
 PORTNAME=	portupgrade
 PORTVERSION=	20040529
-PORTREVISION=	1
+PORTREVISION=	2
 CATEGORIES=	sysutils
 MASTER_SITES=	ftp://ftp.iDaemons.org/pub/distfiles/ \
 		${MASTER_SITE_LOCAL}
diff --git a/sysutils/portupgrade/files/patch-portinfo.rb b/sysutils/portupgrade/files/patch-portinfo.rb
index 2465672975f..749629114d5 100644
--- a/sysutils/portupgrade/files/patch-portinfo.rb
+++ b/sysutils/portupgrade/files/patch-portinfo.rb
@@ -1,11 +1,6 @@
-Index: lib/portinfo.rb
-===================================================================
-RCS file: /home/cvs/pkgtools/lib/portinfo.rb,v
-retrieving revision 1.16
-diff -u -r1.16 portinfo.rb
---- lib/portinfo.rb	8 Nov 2002 17:18:27 -0000	1.16
-+++ lib/portinfo.rb	21 Jun 2004 17:36:11 -0000
-@@ -17,9 +17,9 @@
+--- lib/portinfo.rb.orig	Sat Nov  9 02:18:27 2002
++++ lib/portinfo.rb	Tue Jun 22 13:07:48 2004
+@@ -17,11 +17,9 @@
      line.is_a?(String) or raise ArgumentError,
        "You must specify a one line text of port info."
  
@@ -13,7 +8,9 @@ diff -u -r1.16 portinfo.rb
 +    values = line.chomp.split(FIELD_SEPARATOR)
  
 -    if values.size != NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
-+    if values.size < NFIELDS || values[NFIELDS - 1].index(FIELD_SEPARATOR)
-       raise ArgumentError, "Port info line must consist of #{NFIELDS} fields."
-     end
+-      raise ArgumentError, "Port info line must consist of #{NFIELDS} fields."
+-    end
++    values.push("") while values.size < NFIELDS
+ 
+     @attr = {}
  
-- 
cgit