aboutsummaryrefslogtreecommitdiffstats
path: root/embed/xulrunner/utils/Makefile.am
diff options
context:
space:
mode:
authorChristian Persch <chpe@src.gnome.org>2007-09-13 21:09:13 +0800
committerChristian Persch <chpe@src.gnome.org>2007-09-13 21:09:13 +0800
commit4fe73188e1d1acf72a346d939a86691c73bb6ebd (patch)
tree459738eb5c4db5b52ffcfce7afec7f5c5a6a9b58 /embed/xulrunner/utils/Makefile.am
parent0651f74cfd3a68649a96c2f2b70a93c48451c010 (diff)
downloadgsoc2013-epiphany-4fe73188e1d1acf72a346d939a86691c73bb6ebd.tar.gz
gsoc2013-epiphany-4fe73188e1d1acf72a346d939a86691c73bb6ebd.tar.zst
gsoc2013-epiphany-4fe73188e1d1acf72a346d939a86691c73bb6ebd.zip
Move AutoJSContextStack and AutoWindowModalState helpers to
embed/xulrunner/utils instead of having two copies of it in src and embed. svn path=/trunk/; revision=7424
Diffstat (limited to 'embed/xulrunner/utils/Makefile.am')
-rw-r--r--embed/xulrunner/utils/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/embed/xulrunner/utils/Makefile.am b/embed/xulrunner/utils/Makefile.am
index e69de29bb..5d6fe699d 100644
--- a/embed/xulrunner/utils/Makefile.am
+++ b/embed/xulrunner/utils/Makefile.am
@@ -0,0 +1,32 @@
+NULL =
+
+noinst_LTLIBRARIES = libephyxulrunnerutils.la
+
+libephyxulrunnerutils_la_SOURCES = \
+ AutoJSContextStack.cpp \
+ AutoJSContextStack.h \
+ AutoWindowModalState.cpp \
+ AutoWindowModalState.h \
+ $(NULL)
+
+libephyxulrunnerutils_la_CPPFLAGS = \
+ $(LIBXUL_CXXCPPFLAGS) \
+ $(LIBXUL_INCLUDES) \
+ $(AM_CPPFLAGS)
+
+libephyxulrunnerutils_la_CXXFLAGS = \
+ $(LIBXUL_CXXFLAGS) \
+ $(GTK_CFLAGS) \
+ $(AM_CXXFLAGS)
+
+libephyxulrunnerutils_la_LDFLAGS = \
+ $(AM_LDFLAGS)
+
+libephyxulrunnerutils_la_LIBADD = \
+ $(LIBXUL_LIBS)
+
+CLEANFILES =
+ $(NULL)
+
+EXTRA_DIST = \
+ $(NULL)