aboutsummaryrefslogtreecommitdiffstats
path: root/lib/egg/Makefile.am
diff options
context:
space:
mode:
authorXan Lopez <xan@igalia.com>2012-05-09 18:53:05 +0800
committerXan Lopez <xan@igalia.com>2012-05-09 18:53:18 +0800
commitdb44be25ec9de222f9a2af112e5bc623465473b0 (patch)
tree03b184b22e24e308b0005f7ab001ff31ca833e67 /lib/egg/Makefile.am
parenta025e7d7a50df9f7ebea6aaf9c86ca40ef03440e (diff)
downloadgsoc2013-epiphany-db44be25ec9de222f9a2af112e5bc623465473b0.tar.gz
gsoc2013-epiphany-db44be25ec9de222f9a2af112e5bc623465473b0.tar.zst
gsoc2013-epiphany-db44be25ec9de222f9a2af112e5bc623465473b0.zip
lib/egg: remove some leftovers
Diffstat (limited to 'lib/egg/Makefile.am')
-rw-r--r--lib/egg/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/lib/egg/Makefile.am b/lib/egg/Makefile.am
index a869848c0..08026f8c3 100644
--- a/lib/egg/Makefile.am
+++ b/lib/egg/Makefile.am
@@ -12,7 +12,7 @@ EGGHEADERS = \
noinst_HEADERS = \
$(EGGHEADERS) \
- eggmarshalers.h
+ $(NULL)
noinst_LTLIBRARIES = libegg.la
@@ -27,7 +27,6 @@ libegg_la_CPPFLAGS = \
-I$(top_builddir)/lib/egg \
-DCURSOR_DIR=\"$(pkgdatadir)/art\" \
-DG_LOG_DOMAIN=\""Egg"\" \
- -DEGG_SM_CLIENT_BACKEND_XSMP=1 \
$(AM_CPPFLAGS)
libegg_la_CFLAGS = \
@@ -37,29 +36,13 @@ libegg_la_CFLAGS = \
libegg_la_LIBADD =
BUILT_SOURCES = \
- eggmarshalers.c \
- eggmarshalers.h \
eggtypebuiltins.c \
eggtypebuiltins.h
stamp_files = \
- stamp-eggmarshalers.c \
- stamp-eggmarshalers.h \
stamp-eggtypebuiltins.c \
stamp-eggtypebuiltins.h
-eggmarshalers.h: stamp-eggmarshalers.h
- @true
-stamp-eggmarshalers.h: eggmarshalers.list
- $(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --header > eggmarshalers.h \
- && echo timestamp > $(@F)
-
-eggmarshalers.c: stamp-eggmarshalers.c
- @true
-stamp-eggmarshalers.c: eggmarshalers.list
- $(AM_V_GEN) $(GLIB_GENMARSHAL) --prefix=_egg_marshal $(srcdir)/eggmarshalers.list --header --body > eggmarshalers.c \
- && echo timestamp > $(@F)
-
eggtypebuiltins.c: stamp-eggtypebuiltins.c Makefile
@true
stamp-eggtypebuiltins.c: Makefile $(EGGHEADERS)
@@ -106,7 +89,7 @@ EGGFILES=$(EGGSOURCES) $(EGGHEADERS)
EGGDIR=$(srcdir)/../../../libegg/libegg
regenerate-built-sources:
- EGGFILES="$(EGGFILES) eggmarshalers.list" EGGDIR="$(EGGDIR)" $(srcdir)/update-from-egg.sh
+ EGGFILES="$(EGGFILES)" EGGDIR="$(EGGDIR)"
CLEANFILES = $(stamp_files) $(BUILT_SOURCES)
DISTCLEANFILES = $(stamp_files) $(BUILT_SOURCES)