aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am56
1 files changed, 33 insertions, 23 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 53cb7c4c7..e47c8331b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,60 +41,70 @@ else
nautilus_view_sources =
endif
+headerdir = $(prefix)/include/epiphany-@EPIPHANY_MAJOR@/epiphany
+header_DATA = $(INST_H_FILES)
+
+NO_INST_H_FILES = \
+ ephy-automation.h \
+ ephy-encoding-menu.h \
+ ephy-favicon-action.h \
+ ephy-favorites-menu.h \
+ ephy-go-action.h \
+ ephy-history-window.h \
+ ephy-location-action.h \
+ ephy-navigation-action.h \
+ ephy-plugin.h \
+ ephy-spinner-action.h \
+ ephy-tabs-menu.h \
+ ephy-toolbars-model.h \
+ language-editor.h \
+ pdm-dialog.h \
+ prefs-dialog.h \
+ ppview-toolbar.h \
+ statusbar.h \
+ toolbar.h \
+ window-commands.h
+
+INST_H_FILES = \
+ ephy-notebook.h \
+ ephy-shell.h \
+ ephy-tab.h \
+ ephy-window.h \
+ session.h
+
epiphany_bin_SOURCES = \
$(ephy_automation_interface_idl_sources) \
$(nautilus_view_sources) \
ephy-automation.c \
- ephy-automation.h \
ephy-encoding-menu.c \
- ephy-encoding-menu.h \
ephy-favicon-action.c \
- ephy-favicon-action.h \
ephy-favorites-menu.c \
- ephy-favorites-menu.h \
ephy-go-action.c \
- ephy-go-action.h \
ephy-history-window.c \
- ephy-history-window.h \
ephy-location-action.c \
- ephy-location-action.h \
ephy-main.c \
ephy-navigation-action.c \
- ephy-navigation-action.h \
ephy-notebook.c \
- ephy-notebook.h \
ephy-plugin.c \
- ephy-plugin.h \
ephy-shell.c \
- ephy-shell.h \
ephy-spinner-action.c \
- ephy-spinner-action.h \
ephy-tab.c \
ephy-tab.h \
ephy-tabs-menu.c \
- ephy-tabs-menu.h \
ephy-toolbars-model.c \
ephy-toolbars-model.h \
ephy-window.c \
- ephy-window.h \
language-editor.c \
- language-editor.h \
pdm-dialog.c \
- pdm-dialog.h \
popup-commands.c \
- popup-commands.h \
prefs-dialog.c \
- prefs-dialog.h \
ppview-toolbar.c \
- ppview-toolbar.h \
session.c \
- session.h \
statusbar.c \
- statusbar.h \
toolbar.c \
- toolbar.h \
window-commands.c \
- window-commands.h
+ $(INST_H_FILES) \
+ $(NOINST_H_FILES)
epiphany_bin_LDADD = \
$(top_builddir)/embed/libephyembed.la \