aboutsummaryrefslogtreecommitdiffstats
path: root/packages/monorepo-scripts
diff options
context:
space:
mode:
authorFabio Berger <me@fabioberger.com>2018-08-15 08:41:03 +0800
committerFabio Berger <me@fabioberger.com>2018-08-15 08:41:03 +0800
commit83e3bb899ed88c8ac32331d2f1b533e52d5ad8cd (patch)
treed4f869ee80e81ee6fdcff83dcc53517acd07744f /packages/monorepo-scripts
parentcb5d8d75bf03910d1e763eb34907ada296ed3062 (diff)
downloaddexon-0x-contracts-83e3bb899ed88c8ac32331d2f1b533e52d5ad8cd.tar.gz
dexon-0x-contracts-83e3bb899ed88c8ac32331d2f1b533e52d5ad8cd.tar.zst
dexon-0x-contracts-83e3bb899ed88c8ac32331d2f1b533e52d5ad8cd.zip
Move purging private underscored items to the doc json generation phase
Diffstat (limited to 'packages/monorepo-scripts')
-rw-r--r--packages/monorepo-scripts/src/utils/doc_generate_and_upload_utils.ts31
1 files changed, 19 insertions, 12 deletions
diff --git a/packages/monorepo-scripts/src/utils/doc_generate_and_upload_utils.ts b/packages/monorepo-scripts/src/utils/doc_generate_and_upload_utils.ts
index 187358421..2bc5441fc 100644
--- a/packages/monorepo-scripts/src/utils/doc_generate_and_upload_utils.ts
+++ b/packages/monorepo-scripts/src/utils/doc_generate_and_upload_utils.ts
@@ -143,7 +143,10 @@ export async function generateAndUploadDocsAsync(packageName: string, isStaging:
}
});
- // For each entry, see if it was exported in index.ts. If not, remove it.
+ // For each entry, remove it if:
+ // - it was not exported in index.ts
+ // - the constructor is to be ignored
+ // - it begins with an underscore
const exportPathToTypedocNames: ExportNameToTypedocNames = {};
_.each(typedocOutput.children, (file, i) => {
const exportPath = findExportPathGivenTypedocName(exportPathToExportedItems, packageName, file.name);
@@ -155,18 +158,22 @@ export async function generateAndUploadDocsAsync(packageName: string, isStaging:
_.each(file.children, (child, j) => {
if (!_.includes(exportItems, child.name)) {
delete finalTypeDocOutput.children[i].children[j];
+ return;
}
- if (child.kindString === 'Class' && _.includes(CLASSES_WITH_HIDDEN_CONSTRUCTORS, child.name)) {
- const classChildren = typedocOutput.children[i].children[j].children;
- _.each(classChildren, (classChild, k) => {
- if (classChild.kindString === 'Constructor') {
- delete finalTypeDocOutput.children[i].children[j].children[k];
- finalTypeDocOutput.children[i].children[j].children = _.compact(
- finalTypeDocOutput.children[i].children[j].children,
- );
- }
- });
- }
+ const innerChildren = typedocOutput.children[i].children[j].children;
+ _.each(innerChildren, (innerChild, k) => {
+ const isHiddenConstructor =
+ child.kindString === 'Class' &&
+ _.includes(CLASSES_WITH_HIDDEN_CONSTRUCTORS, child.name) &&
+ innerChild.kindString === 'Constructor';
+ const isPrivate = _.startsWith(innerChild.name, '_');
+ if (isHiddenConstructor || isPrivate) {
+ delete finalTypeDocOutput.children[i].children[j].children[k];
+ finalTypeDocOutput.children[i].children[j].children = _.compact(
+ finalTypeDocOutput.children[i].children[j].children,
+ );
+ }
+ });
});
finalTypeDocOutput.children[i].children = _.compact(finalTypeDocOutput.children[i].children);
});
ss='add' style='width: 33.3%;'/> -rw-r--r--comms/qt5-serialport/Makefile1
-rw-r--r--databases/qt5-sql/Makefile1
-rw-r--r--devel/qt5-assistant/Makefile1
-rw-r--r--devel/qt5-buildtools/Makefile1
-rw-r--r--devel/qt5-concurrent/Makefile1
-rw-r--r--devel/qt5-core/Makefile1
-rw-r--r--devel/qt5-dbus/Makefile1
-rw-r--r--devel/qt5-designer/Makefile1
-rw-r--r--devel/qt5-help/Makefile1
-rw-r--r--devel/qt5-linguist/Makefile1
-rw-r--r--devel/qt5-linguisttools/Makefile1
-rw-r--r--devel/qt5-location/Makefile1
-rw-r--r--devel/qt5-qdbus/Makefile1
-rw-r--r--devel/qt5-qdbusviewer/Makefile1
-rw-r--r--devel/qt5-qdoc-data/Makefile1
-rw-r--r--devel/qt5-qdoc/Makefile1
-rw-r--r--devel/qt5-qmake/Makefile1
-rw-r--r--devel/qt5-script/Makefile1
-rw-r--r--devel/qt5-scripttools/Makefile1
-rw-r--r--devel/qt5-scxml/Makefile1
-rw-r--r--devel/qt5-testlib/Makefile1
-rw-r--r--devel/qt5-uitools/Makefile1
-rw-r--r--graphics/qt5-3d/Makefile2
-rw-r--r--graphics/qt5-graphicaleffects/Makefile1
-rw-r--r--graphics/qt5-imageformats/Makefile2
-rw-r--r--graphics/qt5-opengl/Makefile1
-rw-r--r--graphics/qt5-pixeltool/Makefile1
-rw-r--r--graphics/qt5-svg/Makefile1
-rw-r--r--graphics/qt5-wayland/Makefile1
-rw-r--r--lang/qt5-qml/Makefile1
-rw-r--r--misc/qt5-doc/Makefile1
-rw-r--r--misc/qt5-examples/Makefile1
-rw-r--r--misc/qt5-l10n/Makefile1
-rw-r--r--multimedia/qt5-multimedia/Makefile2
-rw-r--r--net/qt5-network/Makefile2
-rw-r--r--print/qt5-printsupport/Makefile1
-rw-r--r--sysutils/qt5-qtdiag/Makefile1
-rw-r--r--sysutils/qt5-qtpaths/Makefile1
-rw-r--r--sysutils/qt5-qtplugininfo/Makefile1
-rw-r--r--textproc/qt5-xml/Makefile1
-rw-r--r--textproc/qt5-xmlpatterns/Makefile1
-rw-r--r--www/qt5-webchannel/Makefile3
-rw-r--r--www/qt5-webengine/Makefile1
-rw-r--r--www/qt5-websockets-qml/Makefile1
-rw-r--r--www/qt5-websockets/Makefile1
-rw-r--r--x11-toolkits/qt5-canvas3d/Makefile1
-rw-r--r--x11-toolkits/qt5-charts/Makefile1
-rw-r--r--x11-toolkits/qt5-datavis3d/Makefile1
-rw-r--r--x11-toolkits/qt5-gamepad/Makefile1
-rw-r--r--x11-toolkits/qt5-gui/Makefile2
-rw-r--r--x11-toolkits/qt5-quick/Makefile1
-rw-r--r--x11-toolkits/qt5-quickcontrols/Makefile2
-rw-r--r--x11-toolkits/qt5-quickcontrols2/Makefile1
-rw-r--r--x11-toolkits/qt5-uiplugin/Makefile1
-rw-r--r--x11-toolkits/qt5-virtualkeyboard/Makefile1
-rw-r--r--x11-toolkits/qt5-widgets/Makefile1
-rw-r--r--x11/qt5-qev/Makefile1
-rw-r--r--x11/qt5-x11extras/Makefile1
63 files changed, 65 insertions, 8 deletions
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 4b8b89bfbffb..b65823ece023 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -107,7 +107,8 @@ USES+= pkgconfig
# Other ports from other Qt modules will automatically build examples and
# tests if the directories exist because of mkspecs/features/qt_parts.prf.
EXTRACT_AFTER_ARGS?= ${DISTNAME:S,$,/examples,:S,^,--exclude ,} \
- ${DISTNAME:S,$,/tests,:S,^,--exclude ,}
+ ${DISTNAME:S,$,/tests,:S,^,--exclude ,} \
+ --no-same-owner --no-same-permissions
. endif # ! ${_QT_VERSION:M4*}
CONFIGURE_ENV+= MAKE="${MAKE:T}"
diff --git a/accessibility/qt5-speech/Makefile b/accessibility/qt5-speech/Makefile
index a3c1f30444c3..96746235ffae 100644
--- a/accessibility/qt5-speech/Makefile
+++ b/accessibility/qt5-speech/Makefile
@@ -2,6 +2,7 @@
PORTNAME= speech
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= accessibility
PKGNAMEPREFIX= qt5-
diff --git a/comms/qt5-connectivity/Makefile b/comms/qt5-connectivity/Makefile
index 7248ec7112b9..67c8aafaf2f4 100644
--- a/comms/qt5-connectivity/Makefile
+++ b/comms/qt5-connectivity/Makefile
@@ -2,6 +2,7 @@
PORTNAME= connectivity
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
diff --git a/comms/qt5-sensors/Makefile b/comms/qt5-sensors/Makefile
index 9b253262a828..90640ed6d2e6 100644
--- a/comms/qt5-sensors/Makefile
+++ b/comms/qt5-sensors/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sensors
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
diff --git a/comms/qt5-serialbus/Makefile b/comms/qt5-serialbus/Makefile
index 7fc107800cc4..92080554e774 100644
--- a/comms/qt5-serialbus/Makefile
+++ b/comms/qt5-serialbus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialbus
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
diff --git a/comms/qt5-serialport/Makefile b/comms/qt5-serialport/Makefile
index 55ba42ccafbd..8947329f2d03 100644
--- a/comms/qt5-serialport/Makefile
+++ b/comms/qt5-serialport/Makefile
@@ -2,6 +2,7 @@
PORTNAME= serialport
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= comms
PKGNAMEPREFIX= qt5-
diff --git a/databases/qt5-sql/Makefile b/databases/qt5-sql/Makefile
index cb336ee6270c..0180a1bdebdc 100644
--- a/databases/qt5-sql/Makefile
+++ b/databases/qt5-sql/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sql
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= databases
PKGNAMEPREFIX= qt5-
diff --git a/devel/qt5-assistant/Makefile b/devel/qt5-assistant/Makefile
index 75c9d7524b95..163b81b24200 100644
--- a/devel/qt5-assistant/Makefile
+++ b/devel/qt5-assistant/Makefile
@@ -2,6 +2,7 @@
PORTNAME= assistant
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
diff --git a/devel/qt5-buildtools/Makefile b/devel/qt5-buildtools/Makefile
index cd0caf63ebde..0c0fe21bef00 100644
--- a/devel/qt5-buildtools/Makefile
+++ b/devel/qt5-buildtools/Makefile
@@ -2,6 +2,7 @@
PORTNAME= buildtools
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= qt5-
diff --git a/devel/qt5-concurrent/Makefile b/devel/qt5-concurrent/Makefile
index 9d5a26f792f9..386d7d2dfddd 100644
--- a/devel/qt5-concurrent/Makefile
+++ b/devel/qt5-concurrent/Makefile