aboutsummaryrefslogtreecommitdiffstats
path: root/packages/website/ts/pages/documentation/documentation.tsx
diff options
context:
space:
mode:
Diffstat (limited to 'packages/website/ts/pages/documentation/documentation.tsx')
-rw-r--r--packages/website/ts/pages/documentation/documentation.tsx246
1 files changed, 114 insertions, 132 deletions
diff --git a/packages/website/ts/pages/documentation/documentation.tsx b/packages/website/ts/pages/documentation/documentation.tsx
index 1731c19fe..2315847ad 100644
--- a/packages/website/ts/pages/documentation/documentation.tsx
+++ b/packages/website/ts/pages/documentation/documentation.tsx
@@ -3,23 +3,21 @@ import * as _ from 'lodash';
import CircularProgress from 'material-ui/CircularProgress';
import * as React from 'react';
import DocumentTitle = require('react-document-title');
-import {
- scroller,
-} from 'react-scroll';
+import { scroller } from 'react-scroll';
import semverSort = require('semver-sort');
-import {TopBar} from 'ts/components/top_bar';
-import {Badge} from 'ts/components/ui/badge';
-import {Comment} from 'ts/pages/documentation/comment';
-import {DocsInfo} from 'ts/pages/documentation/docs_info';
-import {EventDefinition} from 'ts/pages/documentation/event_definition';
-import {MethodBlock} from 'ts/pages/documentation/method_block';
-import {SourceLink} from 'ts/pages/documentation/source_link';
-import {Type} from 'ts/pages/documentation/type';
-import {TypeDefinition} from 'ts/pages/documentation/type_definition';
-import {MarkdownSection} from 'ts/pages/shared/markdown_section';
-import {NestedSidebarMenu} from 'ts/pages/shared/nested_sidebar_menu';
-import {SectionHeader} from 'ts/pages/shared/section_header';
-import {Dispatcher} from 'ts/redux/dispatcher';
+import { TopBar } from 'ts/components/top_bar';
+import { Badge } from 'ts/components/ui/badge';
+import { Comment } from 'ts/pages/documentation/comment';
+import { DocsInfo } from 'ts/pages/documentation/docs_info';
+import { EventDefinition } from 'ts/pages/documentation/event_definition';
+import { MethodBlock } from 'ts/pages/documentation/method_block';
+import { SourceLink } from 'ts/pages/documentation/source_link';
+import { Type } from 'ts/pages/documentation/type';
+import { TypeDefinition } from 'ts/pages/documentation/type_definition';
+import { MarkdownSection } from 'ts/pages/shared/markdown_section';
+import { NestedSidebarMenu } from 'ts/pages/shared/nested_sidebar_menu';
+import { SectionHeader } from 'ts/pages/shared/section_header';
+import { Dispatcher } from 'ts/redux/dispatcher';
import {
AddressByContractName,
DocAgnosticFormat,
@@ -33,15 +31,15 @@ import {
TypeDefinitionByName,
TypescriptMethod,
} from 'ts/types';
-import {colors} from 'ts/utils/colors';
-import {configs} from 'ts/utils/configs';
-import {constants} from 'ts/utils/constants';
-import {docUtils} from 'ts/utils/doc_utils';
-import {utils} from 'ts/utils/utils';
+import { colors } from 'ts/utils/colors';
+import { configs } from 'ts/utils/configs';
+import { constants } from 'ts/utils/constants';
+import { docUtils } from 'ts/utils/doc_utils';
+import { utils } from 'ts/utils/utils';
const SCROLL_TOP_ID = 'docsScrollTop';
-const networkNameToColor: {[network: string]: string} = {
+const networkNameToColor: { [network: string]: string } = {
[Networks.kovan]: colors.purple,
[Networks.ropsten]: colors.red,
[Networks.mainnet]: colors.turquois,
@@ -79,8 +77,7 @@ const styles: Styles = {
},
};
-export class Documentation extends
- React.Component<DocumentationAllProps, DocumentationState> {
+export class Documentation extends React.Component<DocumentationAllProps, DocumentationState> {
constructor(props: DocumentationAllProps) {
super(props);
this.state = {
@@ -96,12 +93,12 @@ export class Documentation extends
this._fetchJSONDocsFireAndForgetAsync(preferredVersionIfExists);
}
public render() {
- const menuSubsectionsBySection = _.isUndefined(this.state.docAgnosticFormat) ?
- {} :
- this.props.docsInfo.getMenuSubsectionsBySection(this.state.docAgnosticFormat);
+ const menuSubsectionsBySection = _.isUndefined(this.state.docAgnosticFormat)
+ ? {}
+ : this.props.docsInfo.getMenuSubsectionsBySection(this.state.docAgnosticFormat);
return (
<div>
- <DocumentTitle title={`${this.props.docsInfo.displayName} Documentation`}/>
+ <DocumentTitle title={`${this.props.docsInfo.displayName} Documentation`} />
<TopBar
blockchainIsLoaded={false}
location={this.props.location}
@@ -112,29 +109,26 @@ export class Documentation extends
shouldFullWidth={true}
docsInfo={this.props.docsInfo}
/>
- {_.isUndefined(this.state.docAgnosticFormat) ?
- <div
- className="col col-12"
- style={styles.mainContainers}
- >
+ {_.isUndefined(this.state.docAgnosticFormat) ? (
+ <div className="col col-12" style={styles.mainContainers}>
<div
className="relative sm-px2 sm-pt2 sm-m1"
- style={{height: 122, top: '50%', transform: 'translateY(-50%)'}}
+ style={{ height: 122, top: '50%', transform: 'translateY(-50%)' }}
>
<div className="center pb2">
<CircularProgress size={40} thickness={5} />
</div>
- <div className="center pt2" style={{paddingBottom: 11}}>Loading documentation...</div>
+ <div className="center pt2" style={{ paddingBottom: 11 }}>
+ Loading documentation...
+ </div>
</div>
- </div> :
- <div
- className="mx-auto flex"
- style={{color: colors.grey800, height: 43}}
- >
+ </div>
+ ) : (
+ <div className="mx-auto flex" style={{ color: colors.grey800, height: 43 }}>
<div className="relative col md-col-3 lg-col-3 lg-pl0 md-pl1 sm-hide xs-hide">
<div
className="border-right absolute"
- style={{...styles.menuContainer, ...styles.mainContainers}}
+ style={{ ...styles.menuContainer, ...styles.mainContainers }}
>
<NestedSidebarMenu
selectedVersion={this.props.docsVersion}
@@ -146,11 +140,7 @@ export class Documentation extends
</div>
</div>
<div className="relative col lg-col-9 md-col-9 sm-col-12 col-12">
- <div
- id="documentation"
- style={styles.mainContainers}
- className="absolute"
- >
+ <div id="documentation" style={styles.mainContainers} className="absolute">
<div id={SCROLL_TOP_ID} />
<h1 className="md-pl2 sm-pl3">
<a href={this.props.docsInfo.packageUrl} target="_blank">
@@ -161,7 +151,7 @@ export class Documentation extends
</div>
</div>
</div>
- }
+ )}
</div>
);
}
@@ -224,136 +214,120 @@ export class Documentation extends
);
});
return (
- <div
- key={`section-${sectionName}`}
- className="py2 pr3 md-pl2 sm-pl3"
- >
+ <div key={`section-${sectionName}`} className="py2 pr3 md-pl2 sm-pl3">
<div className="flex">
- <div style={{marginRight: 7}}>
- <SectionHeader sectionName={sectionName} />
- </div>
- {this._renderNetworkBadgesIfExists(sectionName)}
+ <div style={{ marginRight: 7 }}>
+ <SectionHeader sectionName={sectionName} />
+ </div>
+ {this._renderNetworkBadgesIfExists(sectionName)}
</div>
- {docSection.comment &&
- <Comment
- comment={docSection.comment}
- />
- }
+ {docSection.comment && <Comment comment={docSection.comment} />}
{docSection.constructors.length > 0 &&
- this.props.docsInfo.isVisibleConstructor(sectionName) &&
- <div>
- <h2 className="thin">Constructor</h2>
- {this._renderConstructors(docSection.constructors, sectionName, typeDefinitionByName)}
- </div>
- }
- {docSection.properties.length > 0 &&
+ this.props.docsInfo.isVisibleConstructor(sectionName) && (
+ <div>
+ <h2 className="thin">Constructor</h2>
+ {this._renderConstructors(docSection.constructors, sectionName, typeDefinitionByName)}
+ </div>
+ )}
+ {docSection.properties.length > 0 && (
<div>
<h2 className="thin">Properties</h2>
<div>{propertyDefs}</div>
</div>
- }
- {docSection.methods.length > 0 &&
+ )}
+ {docSection.methods.length > 0 && (
<div>
<h2 className="thin">Methods</h2>
<div>{methodDefs}</div>
</div>
- }
- {!_.isUndefined(docSection.events) && docSection.events.length > 0 &&
- <div>
- <h2 className="thin">Events</h2>
- <div>{eventDefs}</div>
- </div>
- }
- {!_.isUndefined(typeDefs) && typeDefs.length > 0 &&
- <div>
- <div>{typeDefs}</div>
- </div>
- }
+ )}
+ {!_.isUndefined(docSection.events) &&
+ docSection.events.length > 0 && (
+ <div>
+ <h2 className="thin">Events</h2>
+ <div>{eventDefs}</div>
+ </div>
+ )}
+ {!_.isUndefined(typeDefs) &&
+ typeDefs.length > 0 && (
+ <div>
+ <div>{typeDefs}</div>
+ </div>
+ )}
</div>
);
}
private _renderNetworkBadgesIfExists(sectionName: string) {
const networkToAddressByContractName = configs.CONTRACT_ADDRESS[this.props.docsVersion];
- const badges = _.map(networkToAddressByContractName,
+ const badges = _.map(
+ networkToAddressByContractName,
(addressByContractName: AddressByContractName, networkName: string) => {
const contractAddress = addressByContractName[sectionName];
if (_.isUndefined(contractAddress)) {
return null;
}
const linkIfExists = utils.getEtherScanLinkIfExists(
- contractAddress, constants.NETWORK_ID_BY_NAME[networkName], EtherscanLinkSuffixes.Address,
+ contractAddress,
+ constants.NETWORK_ID_BY_NAME[networkName],
+ EtherscanLinkSuffixes.Address,
);
return (
<a
key={`badge-${networkName}-${sectionName}`}
href={linkIfExists}
target="_blank"
- style={{color: colors.white, textDecoration: 'none'}}
+ style={{ color: colors.white, textDecoration: 'none' }}
>
- <Badge
- title={networkName}
- backgroundColor={networkNameToColor[networkName]}
- />
+ <Badge title={networkName} backgroundColor={networkNameToColor[networkName]} />
</a>
);
- });
+ },
+ );
return badges;
}
- private _renderConstructors(constructors: SolidityMethod[]|TypescriptMethod[],
- sectionName: string,
- typeDefinitionByName: TypeDefinitionByName): React.ReactNode {
+ private _renderConstructors(
+ constructors: SolidityMethod[] | TypescriptMethod[],
+ sectionName: string,
+ typeDefinitionByName: TypeDefinitionByName,
+ ): React.ReactNode {
const constructorDefs = _.map(constructors, constructor => {
- return this._renderMethodBlocks(
- constructor, sectionName, constructor.isConstructor, typeDefinitionByName,
- );
+ return this._renderMethodBlocks(constructor, sectionName, constructor.isConstructor, typeDefinitionByName);
});
- return (
- <div>
- {constructorDefs}
- </div>
- );
+ return <div>{constructorDefs}</div>;
}
private _renderProperty(sectionName: string, property: Property): React.ReactNode {
return (
- <div
- key={`property-${property.name}-${property.type.name}`}
- className="pb3"
- >
+ <div key={`property-${property.name}-${property.type.name}`} className="pb3">
<code className="hljs">
{property.name}:
- <Type
- type={property.type}
- sectionName={sectionName}
- docsInfo={this.props.docsInfo}
- />
+ <Type type={property.type} sectionName={sectionName} docsInfo={this.props.docsInfo} />
</code>
- {property.source &&
+ {property.source && (
<SourceLink
version={this.props.docsVersion}
source={property.source}
baseUrl={this.props.docsInfo.packageUrl}
subPackageName={this.props.docsInfo.subPackageName}
/>
- }
- {property.comment &&
- <Comment
- comment={property.comment}
- className="py2"
- />
- }
+ )}
+ {property.comment && <Comment comment={property.comment} className="py2" />}
</div>
);
}
- private _renderMethodBlocks(method: SolidityMethod|TypescriptMethod, sectionName: string,
- isConstructor: boolean, typeDefinitionByName: TypeDefinitionByName): React.ReactNode {
+ private _renderMethodBlocks(
+ method: SolidityMethod | TypescriptMethod,
+ sectionName: string,
+ isConstructor: boolean,
+ typeDefinitionByName: TypeDefinitionByName,
+ ): React.ReactNode {
return (
<MethodBlock
- key={`method-${method.name}-${sectionName}`}
- sectionName={sectionName}
- method={method}
- typeDefinitionByName={typeDefinitionByName}
- libraryVersion={this.props.docsVersion}
- docsInfo={this.props.docsInfo}
+ key={`method-${method.name}-${sectionName}`}
+ sectionName={sectionName}
+ method={method}
+ typeDefinitionByName={typeDefinitionByName}
+ libraryVersion={this.props.docsVersion}
+ docsInfo={this.props.docsInfo}
/>
);
}
@@ -364,7 +338,11 @@ export class Documentation extends
hash = SCROLL_TOP_ID; // scroll to the top
}
- scroller.scrollTo(hash, {duration: 0, offset: 0, containerId: 'documentation'});
+ scroller.scrollTo(hash, {
+ duration: 0,
+ offset: 0,
+ containerId: 'documentation',
+ });
}
private async _fetchJSONDocsFireAndForgetAsync(preferredVersionIfExists?: string): Promise<void> {
const versionToFileName = await docUtils.getVersionToFileNameAsync(this.props.docsInfo.docsJsonRoot);
@@ -384,14 +362,18 @@ export class Documentation extends
const versionFileNameToFetch = versionToFileName[versionToFetch];
const versionDocObj = await docUtils.getJSONDocFileAsync(
- versionFileNameToFetch, this.props.docsInfo.docsJsonRoot,
+ versionFileNameToFetch,
+ this.props.docsInfo.docsJsonRoot,
);
const docAgnosticFormat = this.props.docsInfo.convertToDocAgnosticFormat(versionDocObj as DoxityDocObj);
- this.setState({
- docAgnosticFormat,
- }, () => {
- this._scrollToHash();
- });
+ this.setState(
+ {
+ docAgnosticFormat,
+ },
+ () => {
+ this._scrollToHash();
+ },
+ );
}
}
reebsd-ports-gnome/commit/graphics/Makefile?h=mate-1.20&id=51a958710888f2e908f5c5308fc62fe1c53d9636'>Add pornview, an Image Viewerarved2002-11-241-0/+1 * RPM of ungif libmaho2002-11-241-0/+1 * Repo-move graphics/xmms-avi to multimedia/xmms-avi.knu2002-11-221-2/+1 * add libwpcg 0.9.0ijliao2002-11-191-0/+1 * Remove the linux_mesa port per maintainer's request. It is broken, unusedkris2002-11-181-1/+0 * Add gtkam, GTK frontend for gphoto2.anders2002-11-181-0/+1 * Note the move of xmms-gdancer from audio to graphics in the Makefiles.tom2002-11-081-0/+1 * Add png2ico 2002.09.03, a program that converts PNG files to Windowswill2002-10-261-0/+1 * add tosvcd 0.7ijliao2002-10-251-0/+1 * Add graphics/kalleryadamw2002-10-251-0/+1 * add jpgraph 1.8ijliao2002-10-211-0/+1 * New port ogmtools version 0.9.51: Tools to extract from/get infolioux2002-10-201-0/+1 * add pixelize 0.9.2ijliao2002-10-201-0/+1 * add multivideo 0.1.0ijliao2002-10-191-0/+1 * Add totem, a xine-based video player for the GNOME 2 desktop.marcus2002-10-181-0/+1 * add xmedcon 0.8.1ijliao2002-10-141-0/+1 * Add ruby-libexif, a Ruby extension library for libexif.knu2002-10-111-0/+1 * New port xmms-nebulus version 0.3.0: A XMMS visualization pluginlioux2002-10-061-0/+1 * Add duhdraw 2.6.96kris2002-09-211-0/+1 * New port figurine version 1.0.5: A drawing program for X11lioux2002-09-201-0/+1 * add Coin 1.0.2ijliao2002-09-191-0/+1 * add imageindex 1.0ijliao2002-09-191-0/+1 * add simape 1.2.2ijliao2002-09-181-0/+1 * KDE3 version part of KDE3. This version is history.alane2002-09-141-1/+0 * Add frontline 0.5.1, an autotrace GUI FRONTend like streamLINE(TM).sobomax2002-09-141-0/+1 * lablgl -> ocaml-lablglobraun2002-09-141-1/+1 * add exiftags 0.93ijliao2002-09-131-0/+1 * add aqsis 0.6.6ijliao2002-09-131-0/+1 * kde2 cleanup.alane2002-09-101-1/+0 * Lodju provides a graphical interface to a database for managing largedinoex2002-09-101-0/+1 * add p5-GraphViz-Data-Structure 0.07ijliao2002-09-061-0/+1 * add epix 0.8.6ijliao2002-09-051-0/+1 * add qtutils 0.0.6ijliao2002-09-051-0/+1 * Add prefix `hs-' for Haskell related ports after repo copy.obraun2002-09-051-1/+1 * New port xmms-finespectrum version 1.0.1.a: Fine grain Spectrumlioux2002-09-031-0/+1 * Add ruby-libart, a Ruby binding for libart.knu2002-09-011-0/+1 * New port quat-gui version 1.11: A Three-dimensional fractal creatorlioux2002-08-301-0/+1 * New port quat version 1.11: A Three-dimensional fractal creatorlioux2002-08-301-0/+1 * add avidemux 0.9.0.12ijliao2002-08-281-0/+1 * add imlib3d 0.8.0ijliao2002-08-281-0/+1 * dri-devel port provides development DRI libraries and X Server.anholt2002-08-221-0/+1 * New port xmms-blursk version 1.3: A XMMS plugin inspired by "Blurlioux2002-08-211-0/+1 * Add gthumb2.marcus2002-08-191-0/+1 * re-add IPA 1.00ijliao2002-08-141-0/+1 * remove ipaijliao2002-08-141-1/+0 * add ipa 1.00ijliao2002-08-141-0/+1 * Send mpeg-lib to its grave. This software whasn't been updated in threemarcus2002-08-131-1/+0 * add deep_zoom 0.3ijliao2002-08-121-0/+1 * add libdvbpsi 0.1.1ijliao2002-08-081-0/+1 * add springgraph 0.79ijliao2002-08-071-0/+1 * add py-chart 1.22ijliao2002-08-041-0/+1 * Add MrSID viewer for viewing the proprietary MrSID image format.jedgar2002-08-011-0/+1 * Yet another PS -> EPSI converter that is compatible with Tgif.mita2002-07-261-0/+1 * Add zphoto (zooming photo album generator)vanilla2002-07-211-0/+1 * add libquicktime 0.9.1ijliao2002-07-181-0/+1 * New port gstreamer-player version 0.4.0: Simple yet functionallioux2002-07-161-0/+1 * New port gstreamer-plugins version 0.4.0: GStreamer written collectionlioux2002-07-161-0/+1 * o New port gstreamer version 0.4.0: Development framework forlioux2002-07-161-0/+1 * New port okle version 0.2.2: oKle is a KDE frontend to the Ogle DVDlioux2002-07-161-0/+1 * add GOPchop 0.6ijliao2002-07-101-0/+1 * Add xnview 1.25, xnView an easy graphics viewer / converter.sobomax2002-07-101-0/+1 * Add ruby-evas (Ruby/Evas version 1.0), Ruby bindings for Evas.knu2002-07-081-0/+1 * Add ruby-svg, a Ruby library for generating SVG files.knu2002-07-081-0/+1 * add HDF5 1.4.4ijliao2002-07-071-0/+1 * add libv3d 0.1.7ijliao2002-07-031-0/+1 * Add lablgl 0.97, OpenGL interface for Objective Caml.perky2002-06-271-0/+1 * remove ports/graphics/miniscribijliao2002-06-251-1/+0 * add gts 0.6.0ijliao2002-06-231-0/+1 * New port aoi version 1.1: Art Of Illusion, An open source Javalioux2002-06-221-0/+1 * add jpegpixi 0.3ijliao2002-06-201-0/+1 * add libexif-gtk 0.3.0ijliao2002-06-181-0/+1 * Initial checking of the 'crw' port. This program converts the RAW Canondillon2002-06-171-0/+1 * add xtheater 1.0.0p1ijliao2002-06-081-0/+1 * New port mpeg4ip version 0.9.4.1: Standards-based system to encode,lioux2002-06-061-0/+1 * o New port mjpegtools version 1.6.0: Set of tools to record/playback/editlioux2002-06-011-0/+1 * add g3dviewer 0.0.3ijliao2002-05-301-0/+1 * Add hgl-2.0.4kris2002-05-251-0/+1 * add metapixel 0.7ijliao2002-05-241-0/+1 * Add eog2 after repo copy from eog. Eog is the "Eye of GNOME" image viewermarcus2002-05-231-0/+1 * Remove xine_mms_plugin.nobutaka2002-05-211-1/+0 * Update gimp-devel (unstable development version of the GIMP) to 1.3.3 aftersobomax2002-05-211-0/+1 * Add libdvdnav. The library for the xine-dvdnav plugin.nobutaka2002-05-211-0/+1 * Update librsvg2 to 1.1.6 after a repo-copy from ports/graphics/librsvg andsobomax2002-05-211-0/+1 * o New port divxplayer version 2.0 alpha: DivX(TM) Video Player forlioux2002-05-201-0/+1 * Add ruby-image_size version 20020105, a Ruby library to measure theknu2002-05-131-0/+1 * add kludge3d 20020301ijliao2002-05-081-0/+1 * add imc 4.1ijliao2002-04-301-0/+1 * Add xmms-paranormal 0.2.0, an adaptation of the "OpenGL Spectrumcy2002-04-281-0/+1 * Add new port xmms-iris - Really pretty 3D circular spectrum analyzer withpat2002-04-261-0/+1 * add SDL_gfx 2.0.3ijliao2002-04-261-0/+1 * Enable divx4linux4lioux2002-04-231-0/+1 * Please welcome Qt3/KDE3 to our ports tree. This includes work since thewill2002-04-221-0/+1 * New port dvdrip version 0.39.05: This is dvd::rip, a Perl Gtk+ basedlioux2002-04-211-0/+1 * Say goodbye to Qt 1.x and all of its dependents. The one port I foundwill2002-04-191-2/+0 * add showimg 0.7ijliao2002-04-141-0/+1 * add white_dune 0.19b31ijliao2002-04-121-0/+1 * New port xvid snapshot release 20020404: An opensource MPEG-4 codec,lioux2002-04-091-0/+1 * Add ruby-imlib2 0.2.0, Imlib2 bindings for Ruby.knu2002-04-071-0/+1 * add pngquant 0.95ijliao2002-04-031-0/+1 * Add libexif 0.5.0, which allows digital camera metadata to be read.dannyboy2002-03-311-0/+1 * transcode is a console based utility for video conversion. It supportsdinoex2002-03-301-0/+1 * add ivtools 1.0.3ijliao2002-03-281-0/+1 * add recmpeg 1.0.4ijliao2002-03-251-0/+1 * Remove the aero port, which depends on the FWF port, which has beenkris2002-03-251-1/+0 * Add Infinity, a XMMS visualization plugin that generates full-screenanders2002-03-251-0/+1 * Add JESS, a XMMS visualization plugin that uses SDL.anders2002-03-251-0/+1 * add libfame 0.8.9ijliao2002-03-251-0/+1 * add divxcalc 0.2ijliao2002-03-201-0/+1 * Add py-graphviz 0.1, python interface to GraphViz agraph.petef2002-03-191-0/+1 * Add miniscrib, a tiny drawing program suitable for use on handheld computers.ade2002-03-131-0/+1 * Add djvulibre, which was repo-copied, upgraded, but never added to themi2002-03-131-0/+1 * add truevision 0.3.10ijliao2002-03-121-0/+1 * add gsubedit 0.3ijliao2002-03-121-0/+1 * - Repocopy and move graphics/gphoto to graphics/gphoto2pat2002-03-081-1/+1 * New port graphics/mmsclient - A client to let you download internetpat2002-03-071-0/+1 * add flip 2.2.0ijliao2002-03-051-0/+1 * Add xmms-fishmatic 0.0.1, an XMMS non-static OpenGL stereogrampetef2002-03-031-0/+1 * Add xine_dvdnav_plugin, a dvd input plugin for xine.nobutaka2002-03-021-0/+1 * Add xine_d5d_plugin, a dvd input plugin for xine with menu support.nobutaka2002-03-021-0/+1 * Add xine_mms_plugin, a Windows Media Player input plugin for xine.nobutaka2002-03-021-0/+1 * Add new port graphics/gimageview - a GTK+ based image viewer.pat2002-02-211-0/+1 * Add port graphics/bbrb - a gtk-based background manager for blackboxpat2002-02-211-0/+1 * Compface port removed. The same utilities can be found in mail/faces.markp2002-02-18