aboutsummaryrefslogtreecommitdiffstats
path: root/packages/website
diff options
context:
space:
mode:
authorFabio Berger <me@fabioberger.com>2018-10-04 22:47:43 +0800
committerFabio Berger <me@fabioberger.com>2018-10-04 22:47:43 +0800
commitc613b6741d7eff069c93ef1a800b67ddfb618c51 (patch)
treeb5ec60c76250be6fb43b22aae028454a0c89fc4e /packages/website
parentf7917cfa659452981df8233248283ca760d870a1 (diff)
downloaddexon-sol-tools-c613b6741d7eff069c93ef1a800b67ddfb618c51.tar.gz
dexon-sol-tools-c613b6741d7eff069c93ef1a800b67ddfb618c51.tar.zst
dexon-sol-tools-c613b6741d7eff069c93ef1a800b67ddfb618c51.zip
Upgrade webpack
Diffstat (limited to 'packages/website')
-rw-r--r--packages/website/package.json28
-rw-r--r--packages/website/ts/index.tsx30
-rw-r--r--packages/website/ts/lazy_component.tsx2
-rw-r--r--packages/website/webpack.config.js95
4 files changed, 79 insertions, 76 deletions
diff --git a/packages/website/package.json b/packages/website/package.json
index 8c115d8a0..530f71677 100644
--- a/packages/website/package.json
+++ b/packages/website/package.json
@@ -7,11 +7,12 @@
"private": true,
"description": "Website and 0x portal dapp",
"scripts": {
- "build": "NODE_ENV=production node --max_old_space_size=8192 ../../node_modules/.bin/webpack",
+ "build": "node --max_old_space_size=8192 ../../node_modules/.bin/webpack --mode production",
+ "build:dev": "../../node_modules/.bin/webpack --mode development",
"build:ci": "yarn build",
"clean": "shx rm -f public/bundle*",
"lint": "tslint --project . 'ts/**/*.ts' 'ts/**/*.tsx'",
- "watch_without_deps": "webpack-dev-server --content-base public --https",
+ "dev": "webpack-dev-server --mode development --content-base public --https",
"deploy_dogfood": "npm run build; aws s3 sync ./public/. s3://dogfood.0xproject.com --profile 0xproject --region us-east-1 --grants read=uri=http://acs.amazonaws.com/groups/global/AllUsers",
"deploy_staging": "npm run build; aws s3 sync ./public/. s3://staging-0xproject --profile 0xproject --region us-east-1 --grants read=uri=http://acs.amazonaws.com/groups/global/AllUsers",
"deploy_live": "DEPLOY_ROLLBAR_SOURCEMAPS=true npm run build; aws s3 sync ./public/. s3://0xproject.com --profile 0xproject --region us-east-1 --grants read=uri=http://acs.amazonaws.com/groups/global/AllUsers --exclude *.map.js"
@@ -87,26 +88,23 @@
"@types/react-tap-event-plugin": "0.0.30",
"@types/redux": "^3.6.0",
"@types/web3-provider-engine": "^14.0.0",
- "awesome-typescript-loader": "^3.1.3",
- "copy-webpack-plugin": "^4.0.1",
+ "awesome-typescript-loader": "^5.2.1",
"copyfiles": "^2.0.0",
"css-loader": "0.23.x",
- "exports-loader": "0.6.x",
- "imports-loader": "0.6.x",
- "json-loader": "^0.5.4",
- "less-loader": "^2.2.3",
+ "less-loader": "^4.1.0",
"make-promises-safe": "^1.1.0",
"raw-loader": "^0.5.1",
- "rollbar-sourcemap-webpack-plugin": "^2.3.0",
+ "rollbar-sourcemap-webpack-plugin": "^2.4.0",
"shx": "^0.2.2",
- "source-map-loader": "^0.1.6",
- "style-loader": "0.13.x",
+ "source-map-loader": "^0.2.4",
+ "style-loader": "0.23.x",
+ "terser-webpack-plugin": "^1.1.0",
"tslint": "5.11.0",
"tslint-config-0xproject": "^0.0.2",
"typescript": "3.0.1",
- "uglifyjs-webpack-plugin": "^1.2.5",
- "webpack": "^3.1.0",
- "webpack-dev-middleware": "^1.10.0",
- "webpack-dev-server": "^2.5.0"
+ "uglifyjs-webpack-plugin": "^2.0.1",
+ "webpack": "^4.20.2",
+ "webpack-cli": "3.1.2",
+ "webpack-dev-server": "^3.1.9"
}
}
diff --git a/packages/website/ts/index.tsx b/packages/website/ts/index.tsx
index 9e59b00ac..d4a79cc4f 100644
--- a/packages/website/ts/index.tsx
+++ b/packages/website/ts/index.tsx
@@ -26,47 +26,47 @@ import 'less/all.less';
// We pass modulePromise returning lambda instead of module promise,
// cause we only want to import the module when the user navigates to the page.
-// At the same time webpack statically parses for System.import() to determine bundle chunk split points
-// so each lazy import needs it's own `System.import()` declaration.
+// At the same time webpack statically parses for import() to determine bundle chunk split points
+// so each lazy import needs it's own `import()` declaration.
const LazyPortal = createLazyComponent('Portal', async () =>
- System.import<any>(/* webpackChunkName: "portal" */ 'ts/containers/portal'),
+ import(/* webpackChunkName: "portal" */ 'ts/containers/portal'),
);
const LazyZeroExJSDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "zeroExDocs" */ 'ts/containers/zero_ex_js_documentation'),
+ import(/* webpackChunkName: "zeroExDocs" */ 'ts/containers/zero_ex_js_documentation'),
);
const LazyContractWrappersDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "contractWrapperDocs" */ 'ts/containers/contract_wrappers_documentation'),
+ import(/* webpackChunkName: "contractWrapperDocs" */ 'ts/containers/contract_wrappers_documentation'),
);
const LazyOrderWatcherDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "orderWatcherDocs" */ 'ts/containers/order_watcher_documentation'),
+ import(/* webpackChunkName: "orderWatcherDocs" */ 'ts/containers/order_watcher_documentation'),
);
const LazySmartContractsDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "smartContractDocs" */ 'ts/containers/smart_contracts_documentation'),
+ import(/* webpackChunkName: "smartContractDocs" */ 'ts/containers/smart_contracts_documentation'),
);
const LazyConnectDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "connectDocs" */ 'ts/containers/connect_documentation'),
+ import(/* webpackChunkName: "connectDocs" */ 'ts/containers/connect_documentation'),
);
const LazyWeb3WrapperDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "web3WrapperDocs" */ 'ts/containers/web3_wrapper_documentation'),
+ import(/* webpackChunkName: "web3WrapperDocs" */ 'ts/containers/web3_wrapper_documentation'),
);
const LazySolCompilerDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "solCompilerDocs" */ 'ts/containers/sol_compiler_documentation'),
+ import(/* webpackChunkName: "solCompilerDocs" */ 'ts/containers/sol_compiler_documentation'),
);
const LazyJSONSchemasDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "jsonSchemasDocs" */ 'ts/containers/json_schemas_documentation'),
+ import(/* webpackChunkName: "jsonSchemasDocs" */ 'ts/containers/json_schemas_documentation'),
);
const LazySolCovDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "solCovDocs" */ 'ts/containers/sol_cov_documentation'),
+ import(/* webpackChunkName: "solCovDocs" */ 'ts/containers/sol_cov_documentation'),
);
const LazySubprovidersDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "subproviderDocs" */ 'ts/containers/subproviders_documentation'),
+ import(/* webpackChunkName: "subproviderDocs" */ 'ts/containers/subproviders_documentation'),
);
const LazyOrderUtilsDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "orderUtilsDocs" */ 'ts/containers/order_utils_documentation'),
+ import(/* webpackChunkName: "orderUtilsDocs" */ 'ts/containers/order_utils_documentation'),
);
const LazyEthereumTypesDocumentation = createLazyComponent('Documentation', async () =>
- System.import<any>(/* webpackChunkName: "ethereumTypesDocs" */ 'ts/containers/ethereum_types_documentation'),
+ import(/* webpackChunkName: "ethereumTypesDocs" */ 'ts/containers/ethereum_types_documentation'),
);
const DOCUMENT_TITLE = '0x: The Protocol for Trading Tokens';
diff --git a/packages/website/ts/lazy_component.tsx b/packages/website/ts/lazy_component.tsx
index dce06ed8d..9d3b9944a 100644
--- a/packages/website/ts/lazy_component.tsx
+++ b/packages/website/ts/lazy_component.tsx
@@ -49,7 +49,7 @@ export class LazyComponent extends React.Component<LazyComponentProps, LazyCompo
* @param componentName name of exported component
* @param lazyImport lambda returning module promise
* we pass a lambda because we only want to require a module if it's used
- * @example `const LazyPortal = createLazyComponent('Portal', () => System.import<any>('ts/containers/portal'));``
+ * @example `const LazyPortal = createLazyComponent('Portal', () => import<any>('ts/containers/portal'));``
*/
export const createLazyComponent = (componentName: string, lazyImport: () => Promise<any>) => {
return (props: any) => {
diff --git a/packages/website/webpack.config.js b/packages/website/webpack.config.js
index 8653196a6..1b213b339 100644
--- a/packages/website/webpack.config.js
+++ b/packages/website/webpack.config.js
@@ -1,6 +1,6 @@
const path = require('path');
const webpack = require('webpack');
-const UglifyJsPlugin = require('uglifyjs-webpack-plugin');
+const TerserPlugin = require('terser-webpack-plugin');
const RollbarSourceMapPlugin = require('rollbar-sourcemap-webpack-plugin');
const childProcess = require('child_process');
@@ -9,44 +9,7 @@ const GIT_SHA = childProcess
.toString()
.trim();
-const generatePlugins = () => {
- let plugins = [];
- if (process.env.NODE_ENV === 'production') {
- plugins = plugins.concat([
- // Since we do not use moment's locale feature, we exclude them from the bundle.
- // This reduces the bundle size by 0.4MB.
- new webpack.IgnorePlugin(/^\.\/locale$/, /moment$/),
- new webpack.DefinePlugin({
- 'process.env': {
- NODE_ENV: JSON.stringify(process.env.NODE_ENV),
- GIT_SHA: JSON.stringify(GIT_SHA),
- },
- }),
- // TODO: Revert to webpack bundled version with webpack v4.
- // The v3 series bundled version does not support ES6 and
- // fails to build.
- new UglifyJsPlugin({
- sourceMap: true,
- uglifyOptions: {
- mangle: {
- reserved: ['BigNumber'],
- },
- },
- }),
- ]);
- if (process.env.DEPLOY_ROLLBAR_SOURCEMAPS === 'true') {
- plugins = plugins.concat([
- new RollbarSourceMapPlugin({
- accessToken: '32c39bfa4bb6440faedc1612a9c13d28',
- version: GIT_SHA,
- publicPath: 'https://0xproject.com/',
- }),
- ]);
- }
- }
- return plugins;
-};
-module.exports = {
+const config = {
entry: ['./ts/index.tsx'],
output: {
path: path.join(__dirname, '/public'),
@@ -54,7 +17,6 @@ module.exports = {
chunkFilename: 'bundle-[name].js',
publicPath: '/',
},
- devtool: 'source-map',
resolve: {
modules: [path.join(__dirname, '/ts'), 'node_modules'],
extensions: ['.ts', '.tsx', '.js', '.jsx', '.json', '.md'],
@@ -92,10 +54,18 @@ module.exports = {
test: /\.css$/,
loaders: ['style-loader', 'css-loader'],
},
- {
- test: /\.json$/,
- loader: 'json-loader',
- },
+ ],
+ },
+ optimization: {
+ minimizer: [
+ new TerserPlugin({
+ sourceMap: true,
+ terserOptions: {
+ mangle: {
+ reserved: ['BigNumber'],
+ },
+ },
+ }),
],
},
devServer: {
@@ -115,5 +85,40 @@ module.exports = {
},
disableHostCheck: true,
},
- plugins: generatePlugins(),
+};
+
+module.exports = (_env, argv) => {
+ let plugins = [];
+ if (argv.mode === 'development') {
+ config.devtool = 'source-map';
+ config.mode = 'development';
+ } else {
+ config.mode = 'production';
+ plugins = plugins.concat([
+ // Since we do not use moment's locale feature, we exclude them from the bundle.
+ // This reduces the bundle size by 0.4MB.
+ new webpack.IgnorePlugin(/^\.\/locale$/, /moment$/),
+ new webpack.DefinePlugin({
+ 'process.env': {
+ NODE_ENV: JSON.stringify(process.env.NODE_ENV),
+ GIT_SHA: JSON.stringify(GIT_SHA),
+ },
+ }),
+ ]);
+ if (process.env.DEPLOY_ROLLBAR_SOURCEMAPS === 'true') {
+ plugins = plugins.concat([
+ new RollbarSourceMapPlugin({
+ accessToken: '32c39bfa4bb6440faedc1612a9c13d28',
+ version: GIT_SHA,
+ publicPath: 'https://0xproject.com/',
+ }),
+ ]);
+ }
+ }
+ console.log('i 「atl」: Mode: ', config.mode);
+
+ config.plugins = plugins;
+ console.log('i 「atl」: Plugin Count: ', config.plugins.length);
+
+ return config;
};
>* Removed addressbook.db since this is now handled by the pas.Christopher James Lahey2000-05-093-2/+6 * Added a default card to all new file backends.Christopher James Lahey2000-05-092-18/+68 * o Undid changes to camel-internet-address.[c,h] o FixedEDT 2000 Jeffrey Stedfast2000-05-094-32/+42 * o Moved struct_address from camel-internet-address.c toEDT 2000 Jeffrey Stedfast2000-05-094-12/+44 * Listed myself as the author of the shell.Ettore Perazzoli2000-05-091-0/+1 * Rearranged order of things getting destroyed.Christopher James Lahey2000-05-0912-26/+77 * Remove reflow idle when being destroyed.Christopher James Lahey2000-05-093-0/+26 * Fixed some indentation.Christopher James Lahey2000-05-098-161/+441 * Fixed the string duplication problem. Fixed the business/home addressChristopher James Lahey2000-05-093-6/+25 * make this a little less kludgy. Use gnome_error_dialog rather than printfDan Winship2000-05-094-44/+50 * one more refcounting fix I missed before.Dan Winship2000-05-092-3/+6 * o updated to use CamelException (as needed by new camel-stream.c) o noEDT 2000 Jeffrey Stedfast2000-05-092-30/+37 * Actually quit when the shell is destroyed.Ettore Perazzoli2000-05-092-0/+13 * Fix compilation with builddir != srcdir. Boy I love this.Ettore Perazzoli2000-05-093-2/+10 * update for camelstream changesDan Winship2000-05-093-16/+22 * Update for CamelStream CamelException changes.Dan Winship2000-05-093-15/+37 * Use CamelException to signal failure. (camel_stream_write_strings):Dan Winship2000-05-0930-812/+920 * Removed unused shortcuts which point to unimplemented folders.Matthew Loper2000-05-092-3/+10 * call e_day_view_stop_editing_event here to avoid a divide by zero a bitSeth Alves2000-05-092-0/+12 * CalBackendClass now is just an interface for calendar backends; this is anFederico Mena Quintero2000-05-0916-1117/+1570 * don't set the ico->uid to NULL or we won't find any other occurrences ofDamon Chaplin2000-05-095-10/+25 * New update.sh script from KennethAndreas Hydén2000-05-082-4/+37 * Updated Swedish translationAndreas Hydén2000-05-082-237/+211 * *** empty log message ***Hector Garcia2000-05-081-0/+4 * Fix const warning.Ettore Perazzoli2000-05-082-2/+6 * Adding es.poHector Garcia2000-05-081-0/+586 * make it really work with oaf. I need to recompile everyhting now.. shitMathieu Lacage2000-05-081-1/+1 * uhMathieu Lacage2000-05-081-1/+1 * make the composer work with oafMathieu Lacage2000-05-082-3/+14 * Make multi-line texts display properly. Fixed some mem leaks.Christopher James Lahey2000-05-083-20/+17 * Fixed this up a bit. Syncing should work better now.Christopher James Lahey2000-05-082-0/+7 * Install `addressbook.db'.Christopher James Lahey2000-05-083-1/+7 * Format From and Reply-To to at least a decoded string. Should probablyNotZed2000-05-082-4/+24 * blahMichael Zucci2000-05-081-1/+1 * Merged NEW_SUMMARY branch back to trunk, and resolved conflicts.NotZed2000-05-0817-1626/+1580 * Size moved to message info, rather than content info structure.NotZed2000-05-082-5/+6 * Made a minimal number of things be destroyed and recreated when updating aChristopher James Lahey2000-05-0811-160/+309 * xmlFree the return value of xmlGetProp.Larry Ewing2000-05-082-0/+7 * remove the no longer needed flatened_alpha member.Larry Ewing2000-05-084-10/+35 * fix some bugsDan Winship2000-05-082-14/+12 * make sure to free the return value of e_card_simple_get.Chris Toshok2000-05-084-4/+24 * free cell.starting_text here to avoid a memory leak.Chris Toshok2000-05-083-0/+7 * call finiLex in error case to avoid a memleak.Chris Toshok2000-05-081-1/+3 * comment function, and fix an ABR.Chris Toshok2000-05-083-6/+17 * comment function, and fix an ABR.Chris Toshok2000-05-083-12/+31 * Add a horizontal scrollbar.Christopher James Lahey2000-05-083-2/+6 * Added saving in minicard view.Christopher James Lahey2000-05-083-0/+94 * Added an activate signal.Christopher James Lahey2000-05-085-0/+29 * Fixed an off by 2 error.Christopher James Lahey2000-05-082-1/+8 * (addressbook_factory): create the ebook once.Chris Toshok2000-05-082-3/+5 * syncDan Winship2000-05-084-40/+72 * don't create a new ebook. instead, unload the current uri (if there isChris Toshok2000-05-082-10/+12 * unref content, etc. after attaching it to message.Dan Winship2000-05-083-0/+13 * unref the message after displaying it.Dan Winship2000-05-083-4/+15 * Make camel not leak like a sieve.Dan Winship2000-05-0869-240/+320 * Replaced some model_changed calls with row_inserted calls.Christopher James Lahey2000-05-083-4/+9 * Changed a toolbar button from saying "New mail" (which suggests you mightMatthew Loper2000-05-082-1/+7 * Handle row_inserted and row_deleted signals properly.Christopher James Lahey2000-05-0817-74/+263 * show the EText item, just in case it hasn't moved, otherwise it won'tDamon Chaplin2000-05-083-3/+24 * Fix off by one error.Vadim Strizhevsky2000-05-081-1/+1 * Removed some code that was notifying too many clients at the wrong times.Christopher James Lahey2000-05-084-52/+22 * Added da to the language stringKenneth Christiansen2000-05-081-1/+1 * Updated da.po to reflect ettore's changes. Made a backup file, if some of theKenneth Christiansen2000-05-072-218/+194 * Fix incorrect casting.Ettore Perazzoli2000-05-072-1/+6 * Updated Norwegian translation.Kjartan Maraas2000-05-072-213/+76 * Added new Directories section for the default_user.Chris Toshok2000-05-072-0/+8 * add Internet Directories (LDAP servers) sectionChris Toshok2000-05-0714-1/+51 * New function, only write out the ibex if it has changed.NotZed2000-05-073-0/+24 * Fix brainos so that the application quits after closing all theEttore Perazzoli2000-05-073-6/+11 * Remove `e-shell-shortcut.c' from `POTFILES.in'.Ettore Perazzoli2000-05-072-1/+4 * Machinery for quitting and handling the relationship between a shellEttore Perazzoli2000-05-078-10/+169 * Make the addressbook create the correct file uri. Added a default query.Christopher James Lahey2000-05-076-7/+31 * Also close the fd after we're done.72000-05-072-2/+11 * only to set_value_at if the value is indeed different. (ect_stop_editing):Chris Toshok2000-05-073-6/+26 * Remove unused files.Ettore Perazzoli2000-05-072-327/+0 * New function to find out if a file is indexed.NotZed2000-05-073-0/+25 * remove the separator and toggle view items as well. (toggle_view_as_cb):Chris Toshok2000-05-072-74/+240 * Don't hardcode "inbox" here.Dan Winship2000-05-077-84/+58 * + * gui/evolution-calendar-control.c (PROPERTY_CALENDAR_URI):Matthew Loper2000-05-072-2/+13 * Install the sample `mbox' file.Ettore Perazzoli2000-05-072-1/+7 * Portability fix (use `readdir()', not `readdir_r()'). Also, be saferEttore Perazzoli2000-05-075-20/+34 * Fix non-OAF compilation.Ettore Perazzoli2000-05-072-1/+6 * Big shell reorganization.Ettore Perazzoli2000-05-0731-1272/+4474 * Updated configuration script to match the new layout of theEttore Perazzoli2000-05-072-0/+12 * New default user setup.Ettore Perazzoli2000-05-0725-22/+80 * Made a NULL callback just mean to not call back.Christopher James Lahey2000-05-075-0/+802 * Made a NULL callback just mean to not call back.Christopher James Lahey2000-05-077-109/+268 * A machine which serves neither POP nor KPOP is not a POP server.Dan Winship2000-05-073-1/+17 * New code to configure identity, mail source, and mail transport.Dan Winship2000-05-076-42/+1149 * changed these so they just do a simple localtime(), update the struct tm,Damon Chaplin2000-05-072-0/+60 * check for purify.Chris Toshok2000-05-072-2/+7 * Mostly finished ECardSimple.Christopher James Lahey2000-05-0710-266/+486 * Turned off focus in the To, Cc, and Bcc buttons.Christopher James Lahey2000-05-072-0/+6 * Added a "changed" signal that gets sent whenever the text changes.Christopher James Lahey2000-05-075-14/+19 * Killed some warnings.Christopher James Lahey2000-05-075-6/+4 * ignore evolution-addressbook.pureChris Toshok2000-05-073-0/+19 * ignore evolution-calendar.pureChris Toshok2000-05-073-0/+18 * ignore wombat.pureChris Toshok2000-05-073-0/+18 * ignore evolution-mail.pureChris Toshok2000-05-073-0/+18 * if a port isn't specified in the uri default to 389.Chris Toshok2000-05-072-0/+8 * consolidate mail-format.h, mail-identify.h, mail-ops.h, main.h andDan Winship2000-05-0715-78/+43 * Made the component take a uri through its property bag.Christopher James Lahey2000-05-072-3/+108 * Got rid of some warnings.Christopher James Lahey2000-05-076-2/+115 * finish editing event when user hits Return key.Damon Chaplin2000-05-076-80/+117 * removed.Damon Chaplin2000-05-063-163/+4 * removed old calendar view files.Damon Chaplin2000-05-0613-4075/+9 * CorrectionKjartan Maraas2000-05-061-2/+0 * added guint ref_count to iCalObject struct, and ical_object_ref/unref()Damon Chaplin2000-05-0612-90/+292 * Updated Galician translation.Jesus Bravo Alvarez2000-05-062-10/+12 * ja.po: Update from Japanese GNOME Users Group(translation@gnome.gr.jp).Yukihiro Nakai2000-05-061-91/+66 * And same here ... (camel_folder_summary_encode_fixed_int32): Ugh, fwriteNotZed2000-05-062-7/+20 * Use the OAFIID when using an OAF-enabled build of bonobo.Anders Carlsson2000-05-062-1/+16 * Added option `--enable-purify' and correspondent Automake conditional.Ettore Perazzoli2000-05-062-0/+12 * ignore .pure directoryChris Toshok2000-05-051-0/+1 * Added e-card-simple.c and e-card-simple.h.Christopher James Lahey2000-05-058-582/+972 * add support for building purified evolution.Chris Toshok2000-05-053-0/+16 * ignore the .pure directoryChris Toshok2000-05-0521-6/+46 * And same here ...NotZed2000-05-057-45/+77 * Plug a memory leak. (header_decode_text): Fixed memory leaks with52000-05-054-39/+68 * use rows here instead of E_TABLE_SUBSET(etsv)->n_map, since the table canChris Toshok2000-05-053-2/+9 * Maxcount is minimum of the max and the requested count, not the maximum :)NotZed2000-05-057-46/+362 * Requires a camel-patch, about to come through ...NotZed2000-05-053-24/+60 * Add an e_table_group_add_all function and implement it in the differentChristopher James Lahey2000-05-0519-30/+251 * Updated Galician translationJesus Bravo Alvarez2000-05-051-3/+3 * Updated Galician translationJesus Bravo Alvarez2000-05-052-108/+169 * Sped up e_cell_text's get_height function.Christopher James Lahey2000-05-053-32/+42 * for the long events pass E_DAY_VIEW_LONG_EVENT as the day. Fixes SEGV.Damon Chaplin2000-05-0510-92/+266 * turned the notebook border off. The calendar looks better without it. IfDamon Chaplin2000-05-052-0/+9 * Make this compile again in the !KRB4 caseDan Winship2000-05-051-1/+1 * Oops. The Kerberos check was succeeding when it shouldn't have (and thusDan Winship2000-05-052-2/+8 * Don't fall back to plaintext passwords if APOP fails, since it should alsoDan Winship2000-05-052-18/+20 * New function to replace camel_provider_scan. Returns a list of either (a)Dan Winship2000-05-0410-31/+265 * Updated the Turkish translationFatih Demir2000-05-042-110/+105 * Define `E_TYPE_SHORTCUT_BAR'.Ettore Perazzoli2000-05-042-0/+6 * Added a height_cache idle loop so that the height_cache will be validatedChristopher James Lahey2000-05-045-4/+85 * Load all the data to be sorted by before actually doing the sort.Christopher James Lahey2000-05-043-34/+99 * EIconBar/EShortcutBar constification.Ettore Perazzoli2000-05-046-11/+26 * Fix author information.Christopher James Lahey2000-05-049-32/+97 * Fixed EShortcutBar API: the icon callback function now gets a `constEttore Perazzoli2000-05-046-12/+47 * No, we're not going to have g_strcasecmp for no good reason,NotZed2000-05-0415-47/+1597 * Add back in main loop calls during sorting.Christopher James Lahey2000-05-043-0/+9 * Translations from KeldKenneth Christiansen2000-05-041-26/+14 * Replace insert sort completely with a qsort.Christopher James Lahey2000-05-045-155/+132 * Some small build fixes:Jacob Leach2000-05-044-1/+13 * Changed the insert sort to be binary instead of linear.Christopher James Lahey2000-05-043-58/+109 * Make the "Cc:" field optional again. (Before, we could check ifDan Winship2000-05-042-7/+16 * Make it easier for us allKjartan Maraas2000-05-041-0/+8 * Updated Norwegian translation.Kjartan Maraas2000-05-042-66/+58 * ShhKjartan Maraas2000-05-041-1/+5 * Updated russian translation.Valek Frob2000-05-042-26/+18 * fix configure for old libxmls.Michael Meeks2000-05-042-1/+5 * #ifdef HAVE_LDAP the ldap specific stuff. (null_cb): same.Chris Toshok2000-05-032-3/+15 * s/strcasecmp/g_strcasecamp/ everywhere except intl/, per michael'sJacob Leach2000-05-039-53/+57 * comment out the changed signal for now.Larry Ewing2000-05-032-1/+6 * If the iconv handle is -1, then dont try and convert (crashesNotZed2000-05-032-10/+27 * Eeek. I committed the wrong version of the file.Ettore Perazzoli2000-05-031-1/+0 * New function to free a list of referenced objects.Ettore Perazzoli2000-05-035-6/+46 * fix typo when dereferencing saveoffset.Larry Ewing2000-05-032-1/+6 * Remove unused file.Ettore Perazzoli2000-05-031-10/+0 * Don't generate `doc/Makefile' in `configure' because there is nothingEttore Perazzoli2000-05-032-1/+6 * Updated for removed files.Ettore Perazzoli2000-05-032-1/+4 * Fix builddir != srcdir build once again.Ettore Perazzoli2000-05-032-0/+6 * Removing more cruft.Ettore Perazzoli2000-05-036-69/+16 * add some minimal Kerberos checking. This isn't intended to be genericallyDan Winship2000-05-033-20/+56 * Get rid of crufty `e-service' modules.Ettore Perazzoli2000-05-035-388/+8 * Missed these ...Michael Zucci2000-05-033-0/+549 * REmove gmime-utils.h from here.NotZed2000-05-038-374/+47 * And here too.NotZed2000-05-035-5/+17 * Translations from KeldKenneth Christiansen2000-05-031-52/+52 * set the active radio button here. Oops - it wasn't a Bonobo problem afterDamon Chaplin2000-05-03