aboutsummaryrefslogtreecommitdiffstats
path: root/python-packages/order_utils/setup.py
diff options
context:
space:
mode:
authorfragosti <francesco.agosti93@gmail.com>2018-11-15 06:39:23 +0800
committerfragosti <francesco.agosti93@gmail.com>2018-11-15 06:39:23 +0800
commit1aae112d0e2c2b6c7ac16b491aa8345fe2aff486 (patch)
tree25457b39e170451ecbc56fe03918ef6e10b43d5c /python-packages/order_utils/setup.py
parent80e7e84a06319a79a757406b58df318cce3dfa08 (diff)
parent504f4d9eb99589b4d9071a6f13cea9dcc11f226d (diff)
downloaddexon-sol-tools-1aae112d0e2c2b6c7ac16b491aa8345fe2aff486.tar.gz
dexon-sol-tools-1aae112d0e2c2b6c7ac16b491aa8345fe2aff486.tar.zst
dexon-sol-tools-1aae112d0e2c2b6c7ac16b491aa8345fe2aff486.zip
Merge branch 'development' of https://github.com/0xProject/0x-monorepo into feature/instant/different-install-wallet-copy-for-mobile
Diffstat (limited to 'python-packages/order_utils/setup.py')
-rwxr-xr-xpython-packages/order_utils/setup.py7
1 files changed, 2 insertions, 5 deletions
diff --git a/python-packages/order_utils/setup.py b/python-packages/order_utils/setup.py
index 7f1da2f34..679bfb4b2 100755
--- a/python-packages/order_utils/setup.py
+++ b/python-packages/order_utils/setup.py
@@ -24,7 +24,6 @@ class TestCommandExtension(TestCommand):
exit(pytest.main())
-# pylint: disable=too-many-ancestors
class LintCommand(distutils.command.build_py.build_py):
"""Custom setuptools command class for running linters."""
@@ -90,7 +89,6 @@ class CleanCommandExtension(clean):
rmtree("src/0x_order_utils.egg-info", ignore_errors=True)
-# pylint: disable=too-many-ancestors
class TestPublishCommand(distutils.command.build_py.build_py):
"""Custom command to publish to test.pypi.org."""
@@ -108,7 +106,6 @@ class TestPublishCommand(distutils.command.build_py.build_py):
)
-# pylint: disable=too-many-ancestors
class PublishCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -119,7 +116,6 @@ class PublishCommand(distutils.command.build_py.build_py):
subprocess.check_call("twine upload dist/*".split()) # nosec
-# pylint: disable=too-many-ancestors
class GanacheCommand(distutils.command.build_py.build_py):
"""Custom command to publish to pypi.org."""
@@ -163,7 +159,7 @@ setup(
install_requires=[
"eth-abi",
"eth_utils",
- "ethereum",
+ "jsonschema",
"mypy_extensions",
"web3",
],
@@ -188,6 +184,7 @@ setup(
package_data={
"zero_ex.order_utils": ["py.typed"],
"zero_ex.contract_artifacts": ["artifacts/*"],
+ "zero_ex.json_schemas": ["schemas/*"],
},
package_dir={"": "src"},
license="Apache 2.0",