aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorchriseth <chris@ethereum.org>2017-06-14 20:17:53 +0800
committerchriseth <chris@ethereum.org>2017-06-14 20:17:53 +0800
commit1ce949519dabd252c553bf958cb3d7a2cf3ecb26 (patch)
tree2602648809985ccd004d153263495ff463d5471d /CMakeLists.txt
parent1d79059897ae35cc5af87a3afb0d5c05949ab2b3 (diff)
downloaddexon-solidity-1ce949519dabd252c553bf958cb3d7a2cf3ecb26.tar.gz
dexon-solidity-1ce949519dabd252c553bf958cb3d7a2cf3ecb26.tar.zst
dexon-solidity-1ce949519dabd252c553bf958cb3d7a2cf3ecb26.zip
Move 0x to cmake file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0eef4d2..d6ed6643 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,7 +28,8 @@ include(EthUtils)
# Converting to char array is required due to MSVC's string size limit.
file(READ ${CMAKE_SOURCE_DIR}/LICENSE.txt LICENSE_TEXT HEX)
string(REGEX MATCHALL ".." LICENSE_TEXT "${LICENSE_TEXT}")
-string(REGEX REPLACE ";" ",\t0x" LICENSE_TEXT "${LICENSE_TEXT}")
+string(REGEX REPLACE ";" ",\n\t0x" LICENSE_TEXT "${LICENSE_TEXT}")
+set(LICENSE_TEXT "0x${LICENSE_TEXT}")
configure_file("${CMAKE_SOURCE_DIR}/cmake/templates/license.h.in" "license.h")