aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsubtly <subtly@users.noreply.github.com>2015-06-26 19:41:42 +0800
committersubtly <subtly@users.noreply.github.com>2015-06-26 19:41:42 +0800
commit1ed7bc1562cc0b4ac02e89fb566c9f0787a06c3c (patch)
treeb516cc071a31c8779065a59a352e9163fa0569d1 /CMakeLists.txt
parent88f8eb6ad24c88814d411a1a1acb1890b0eddf0a (diff)
downloaddexon-solidity-1ed7bc1562cc0b4ac02e89fb566c9f0787a06c3c.tar.gz
dexon-solidity-1ed7bc1562cc0b4ac02e89fb566c9f0787a06c3c.tar.zst
dexon-solidity-1ed7bc1562cc0b4ac02e89fb566c9f0787a06c3c.zip
Don't link secp256k1 on windows.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d39a5cca..952b1674 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,7 +74,9 @@ target_link_libraries(testeth ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
target_link_libraries(testeth ${CURL_LIBRARIES})
target_link_libraries(testeth ethereum)
target_link_libraries(testeth ethcore)
-target_link_libraries(testeth secp256k1)
+if (NOT WIN32)
+ target_link_libraries(testeth secp256k1)
+endif()
if (JSCONSOLE)
target_link_libraries(testeth jsengine)