aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Beregszaszi <alex@rtfs.hu>2017-08-23 19:36:24 +0800
committerGitHub <noreply@github.com>2017-08-23 19:36:24 +0800
commit3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905 (patch)
tree3af9644b27a6fd453610d26ffe65bf4ca98d9aa9 /CMakeLists.txt
parentc5f11d938f6670d9dbe0d7212097089c757fd91a (diff)
parent09628dee8c86e71119884204eb729fe439fb3bad (diff)
downloaddexon-solidity-3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905.tar.gz
dexon-solidity-3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905.tar.zst
dexon-solidity-3b07c4d38e40c52ee8a4d16e56e2afa1a0f27905.zip
Merge pull request #2757 from ethereum/cmake
Static linking
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a11c56ee..da14ddb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,10 +11,14 @@ eth_policy()
set(PROJECT_VERSION "0.4.16")
project(solidity VERSION ${PROJECT_VERSION})
+option(SOLC_LINK_STATIC "Link solc executable statically on supported platforms" OFF)
+
# Let's find our dependencies
include(EthDependencies)
include(deps/jsoncpp.cmake)
+find_package(Threads)
+
# Figure out what compiler and system are we using
include(EthCompilerSettings)