aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristoph Jentzsch <jentzsch.software@gmail.com>2014-11-03 23:34:40 +0800
committerChristoph Jentzsch <jentzsch.software@gmail.com>2014-11-03 23:34:40 +0800
commit72c7132a3af9836c34b350fa295e34959bacce87 (patch)
treec3edbcc8931981a11a7e4dace0b2955b5ec52dd2 /CMakeLists.txt
parent6eeef2762c0e784bf0c44793376a70430575d34d (diff)
parent07d08e3af3afb99014cec91d39ce0ca36d710517 (diff)
downloaddexon-solidity-72c7132a3af9836c34b350fa295e34959bacce87.tar.gz
dexon-solidity-72c7132a3af9836c34b350fa295e34959bacce87.tar.zst
dexon-solidity-72c7132a3af9836c34b350fa295e34959bacce87.zip
Merge remote-tracking branch 'upstream/develop' into stateTests
Conflicts: test/vmBitwiseLogicOperationTestFiller.json
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8769117..f292361d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,8 +4,6 @@ aux_source_directory(. SRC_LIST)
list(REMOVE_ITEM SRC_LIST "./createRandomTest.cpp")
include_directories(..)
-link_directories(../libethcore)
-link_directories(../libethereum)
file(GLOB HEADERS "*.h")
add_executable(testeth ${SRC_LIST} ${HEADERS})
@@ -17,6 +15,10 @@ target_link_libraries(testeth secp256k1)
target_link_libraries(testeth gmp)
target_link_libraries(testeth solidity)
target_link_libraries(testeth ${CRYPTOPP_LS})
+target_link_libraries(testeth webthree)
+if(JSONRPC_LS)
+target_link_libraries(testeth web3jsonrpc)
+endif()
target_link_libraries(createRandomTest ethereum)
target_link_libraries(createRandomTest ethcore)