aboutsummaryrefslogtreecommitdiffstats
path: root/liblll/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Parpart <christian@ethereum.org>2018-11-23 21:21:17 +0800
committerChristian Parpart <christian@ethereum.org>2018-11-26 21:39:24 +0800
commitcdd8c72c9d38a6638cd23db58079251b6a632e3b (patch)
tree62396cc259a8e34296963df6c6b20474a752b51b /liblll/CMakeLists.txt
parent96333f303373e073ef58a676983ed368fcd4b9f4 (diff)
downloaddexon-solidity-cdd8c72c9d38a6638cd23db58079251b6a632e3b.tar.gz
dexon-solidity-cdd8c72c9d38a6638cd23db58079251b6a632e3b.tar.zst
dexon-solidity-cdd8c72c9d38a6638cd23db58079251b6a632e3b.zip
CMake: Explicitly state which files to compile instead of relying on globbing.
Also remove header file lists, as there is no need to add them to add_library() or add_executable(), which should lower maintenance of the cmake files.
Diffstat (limited to 'liblll/CMakeLists.txt')
-rw-r--r--liblll/CMakeLists.txt10
1 files changed, 7 insertions, 3 deletions
diff --git a/liblll/CMakeLists.txt b/liblll/CMakeLists.txt
index 4cdc073a..9566c62f 100644
--- a/liblll/CMakeLists.txt
+++ b/liblll/CMakeLists.txt
@@ -1,5 +1,9 @@
-file(GLOB sources "*.cpp")
-file(GLOB headers "*.h")
+set(sources
+ CodeFragment.cpp
+ Compiler.cpp
+ CompilerState.cpp
+ Parser.cpp
+)
-add_library(lll ${sources} ${headers})
+add_library(lll ${sources})
target_link_libraries(lll PUBLIC evmasm devcore)