aboutsummaryrefslogtreecommitdiffstats
path: root/libsolidity/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Beregszaszi <alex@rtfs.hu>2018-08-09 00:58:01 +0800
committerGitHub <noreply@github.com>2018-08-09 00:58:01 +0800
commit551343ae3eb1b3f1575d91a4f7021c0f9529d5bd (patch)
tree066883d643a962b7648d6dd642bd00cdc1b290d8 /libsolidity/CMakeLists.txt
parent9d782cc39c7a42bae17565d419adfc8398a6ab9a (diff)
parent4b20708c497cfbbb8a489339b91e26f05d0bd7a2 (diff)
downloaddexon-solidity-551343ae3eb1b3f1575d91a4f7021c0f9529d5bd.tar.gz
dexon-solidity-551343ae3eb1b3f1575d91a4f7021c0f9529d5bd.tar.zst
dexon-solidity-551343ae3eb1b3f1575d91a4f7021c0f9529d5bd.zip
Merge pull request #4665 from mattaereal/cmake-patch-solver
cmake option added to make solvers optional
Diffstat (limited to 'libsolidity/CMakeLists.txt')
-rw-r--r--libsolidity/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libsolidity/CMakeLists.txt b/libsolidity/CMakeLists.txt
index 706b3b08..49095fff 100644
--- a/libsolidity/CMakeLists.txt
+++ b/libsolidity/CMakeLists.txt
@@ -27,7 +27,8 @@ else()
endif()
if (NOT (${Z3_FOUND} OR ${CVC4_FOUND}))
- message("No SMT solver found. Optional SMT checking will not be available. Please install Z3 or CVC4 if it is desired.")
+ message("No SMT solver found (or it has been forcefully disabled). Optional SMT checking will not be available.\
+ \nPlease install Z3 or CVC4 or remove the option disabling them (USE_Z3, USE_CVC4).")
endif()
add_library(solidity ${sources} ${headers})