aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPaweł Bylica <chfast@gmail.com>2017-08-18 19:31:31 +0800
committerPaweł Bylica <chfast@gmail.com>2017-08-18 19:32:35 +0800
commitd1f4d110fb5c2ed09ef0111ecd3789f52be1200c (patch)
treea583a23950da8c300cdf3b012019cf96c1e20120 /test/CMakeLists.txt
parent2a1b6b2e92edc1665eb1644f2ccf06c44e68448a (diff)
downloaddexon-solidity-d1f4d110fb5c2ed09ef0111ecd3789f52be1200c.tar.gz
dexon-solidity-d1f4d110fb5c2ed09ef0111ecd3789f52be1200c.tar.zst
dexon-solidity-d1f4d110fb5c2ed09ef0111ecd3789f52be1200c.zip
CMake: Build static libs by default
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8e7b8916..6b114239 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -20,7 +20,7 @@ eth_simple_add_executable(${EXECUTABLE} ${SRC_LIST} ${HEADERS})
eth_use(${EXECUTABLE} REQUIRED Solidity::solidity Solidity::lll)
include_directories(BEFORE ..)
-target_link_libraries(${EXECUTABLE} soljson ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
+target_link_libraries(${EXECUTABLE} soljson devcore ${Boost_UNIT_TEST_FRAMEWORK_LIBRARIES})
add_executable(solfuzzer fuzzer.cpp)
target_link_libraries(solfuzzer soljson ${Boost_PROGRAM_OPTIONS_LIBRARIES})