aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a11c56ee..da14ddb7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,10 +11,14 @@ eth_policy()
set(PROJECT_VERSION "0.4.16")
project(solidity VERSION ${PROJECT_VERSION})
+option(SOLC_LINK_STATIC "Link solc executable statically on supported platforms" OFF)
+
# Let's find our dependencies
include(EthDependencies)
include(deps/jsoncpp.cmake)
+find_package(Threads)
+
# Figure out what compiler and system are we using
include(EthCompilerSettings)