aboutsummaryrefslogtreecommitdiffstats
path: root/liblangutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'liblangutil/CMakeLists.txt')
-rw-r--r--liblangutil/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/liblangutil/CMakeLists.txt b/liblangutil/CMakeLists.txt
index 5a82f3ff..b172108b 100644
--- a/liblangutil/CMakeLists.txt
+++ b/liblangutil/CMakeLists.txt
@@ -1,13 +1,24 @@
# Solidity Commons Library (Solidity related sharing bits between libsolidity and libyul)
set(sources
CharStream.cpp
+ CharStream.h
ErrorReporter.cpp
+ ErrorReporter.h
+ EVMVersion.h
Exceptions.cpp
+ Exceptions.h
ParserBase.cpp
+ ParserBase.h
Scanner.cpp
+ Scanner.h
+ SourceLocation.h
SourceReferenceExtractor.cpp
+ SourceReferenceExtractor.h
SourceReferenceFormatter.cpp
+ SourceReferenceFormatter.h
Token.cpp
+ Token.h
+ UndefMacros.h
)
add_library(langutil ${sources})