aboutsummaryrefslogtreecommitdiffstats
path: root/liblangutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'liblangutil/CMakeLists.txt')
-rw-r--r--liblangutil/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/liblangutil/CMakeLists.txt b/liblangutil/CMakeLists.txt
new file mode 100644
index 00000000..3d8bd37a
--- /dev/null
+++ b/liblangutil/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Solidity Commons Library (Solidity related sharing bits between libsolidity and libyul)
+set(sources
+ CharStream.cpp
+ ErrorReporter.cpp
+ Exceptions.cpp
+ ParserBase.cpp
+ Scanner.cpp
+ Token.cpp
+)
+
+add_library(langutil ${sources})
+target_link_libraries(langutil PUBLIC devcore)