aboutsummaryrefslogtreecommitdiffstats
path: root/solc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'solc/CMakeLists.txt')
-rw-r--r--solc/CMakeLists.txt14
1 files changed, 13 insertions, 1 deletions
diff --git a/solc/CMakeLists.txt b/solc/CMakeLists.txt
index 0563fe2a..656b27c3 100644
--- a/solc/CMakeLists.txt
+++ b/solc/CMakeLists.txt
@@ -16,4 +16,16 @@ if (EMSCRIPTEN)
else()
add_library(soljson jsonCompiler.cpp)
endif()
-target_link_libraries(soljson PRIVATE solidity) \ No newline at end of file
+target_link_libraries(soljson PRIVATE solidity)
+
+if(SOLC_LINK_STATIC AND UNIX AND NOT APPLE)
+ # Produce solc as statically linked binary (includes C/C++ standard libraries)
+ # This is not supported on macOS, see
+ # https://developer.apple.com/library/content/qa/qa1118/_index.html.
+ set_target_properties(
+ solc PROPERTIES
+ LINK_FLAGS -static
+ LINK_SEARCH_START_STATIC ON
+ LINK_SEARCH_END_STATIC ON
+ )
+endif() \ No newline at end of file