aboutsummaryrefslogtreecommitdiffstats
path: root/cad
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
committerrene <rene@FreeBSD.org>2018-11-02 21:32:34 +0800
commitabe85598b76e65884f63f5d35b14a7a5837c77ee (patch)
tree2c2c3d0def8d9d1ad349013f7b532f0065f57789 /cad
parenta6ebb885ab3952f319e4a2e650eba1580d82a26e (diff)
downloadfreebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.gz
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.tar.zst
freebsd-ports-gnome-abe85598b76e65884f63f5d35b14a7a5837c77ee.zip
Remove compatibility code for FreeBSD < 11.2 from all ports.
Simplify some ports where DragonFlyBSD no longer needs to be special-cased. Submitted by: rene Reviewed by: bapt, jbeich Differential Revision: https://reviews.freebsd.org/D17724
Diffstat (limited to 'cad')
-rw-r--r--cad/calculix/Makefile1
-rw-r--r--cad/linuxcnc-devel/Makefile2
-rw-r--r--cad/openscad/Makefile2
-rw-r--r--cad/sumo/Makefile10
4 files changed, 2 insertions, 13 deletions
diff --git a/cad/calculix/Makefile b/cad/calculix/Makefile
index 60598a861134..831181eb292e 100644
--- a/cad/calculix/Makefile
+++ b/cad/calculix/Makefile
@@ -16,7 +16,6 @@ COMMENT= Three-Dimensional Structural Finite Element Program
LICENSE= GPLv2
BROKEN= checksum and size mismatch
-BROKEN_FreeBSD_10= Does not build with clang on FreeBSD 10, causes segfaults when built with gcc
BROKEN_aarch64= fails to link: shapeFunctions.c:(function attach_new): relocation R_AARCH64_CALL26 out of range
RUN_DEPENDS= ccx:cad/calculix-ccx
diff --git a/cad/linuxcnc-devel/Makefile b/cad/linuxcnc-devel/Makefile
index 905394872393..850910812726 100644
--- a/cad/linuxcnc-devel/Makefile
+++ b/cad/linuxcnc-devel/Makefile
@@ -12,8 +12,6 @@ COMMENT= Open Source CNC machine controller
LICENSE= GPLv2
-BROKEN_FreeBSD_10= use of undeclared identifier '__builtin_ia32_rdtsc'
-
LIB_DEPENDS= libBLT25.so:x11-toolkits/blt \
${PY_BOOST} \
libfontconfig.so:x11-fonts/fontconfig \
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 3e8581aa9f69..0172e8a4f4dc 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -43,7 +43,7 @@ post-patch:
#.include <bsd.port.options.mk>
#
-#.if ${ARCH} == i386 && ${OSVERSION} >= 1100000
+#.if ${ARCH} == i386
#USE_GCC= yes
#.endif
diff --git a/cad/sumo/Makefile b/cad/sumo/Makefile
index fd8133fb3a05..994a746ab9aa 100644
--- a/cad/sumo/Makefile
+++ b/cad/sumo/Makefile
@@ -44,12 +44,4 @@ do-install-DOCS-on:
@cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
@${FIND} ${STAGEDIR}${DOCSDIR} -d -empty -delete
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
-BUILD_DEPENDS+= clang60:devel/llvm60
-CC= clang60
-CXX= clang++60 # fails to build with the default compiler on 10
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>