aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2003-07-03 02:27:41 +0800
committerAde Lovett <ade@FreeBSD.org>2003-07-03 02:27:41 +0800
commitcb51380f0957170d0b6ea9ddc8ebc3b31889ab88 (patch)
tree19672990c86dfe89d040cc8e1775f7783e61c713 /devel
parentaba51095cc77e2ae5dd655d80528e86562ee0439 (diff)
downloadfreebsd-ports-gnome-cb51380f0957170d0b6ea9ddc8ebc3b31889ab88.tar.gz
freebsd-ports-gnome-cb51380f0957170d0b6ea9ddc8ebc3b31889ab88.tar.zst
freebsd-ports-gnome-cb51380f0957170d0b6ea9ddc8ebc3b31889ab88.zip
Fix installation of info files
Remove libltdl specific stuff from libtool14 (now refers to libtool15)
Diffstat (limited to 'devel')
-rw-r--r--devel/libtool13/Makefile13
-rw-r--r--devel/libtool13/files/patch-aa27
-rw-r--r--devel/libtool14/Makefile16
-rw-r--r--devel/libtool14/files/patch-aa30
-rw-r--r--devel/libtool14/pkg-descr.libltdl9
-rw-r--r--devel/libtool14/pkg-plist.libltdl5
6 files changed, 42 insertions, 58 deletions
diff --git a/devel/libtool13/Makefile b/devel/libtool13/Makefile
index 6b7d64ca69c8..6408b5d5ffb8 100644
--- a/devel/libtool13/Makefile
+++ b/devel/libtool13/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libtool
PORTVERSION= 1.3.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
@@ -22,6 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-ltdl-install \
--program-suffix=${BUILD_VERSION}
CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
.if defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
@@ -34,12 +36,13 @@ pre-everything:
@${FALSE}
.endif # defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
-post-extract:
+post-patch:
+ @(cd ${WRKSRC}/doc && \
+ ${RM} -f *.info* && \
+ ${MV} libtool.texi libtool${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(libtool|libtoolize)\),\1${BUILDVERSION}\),g' libtool${BUILD_VERSION}.texi)
@${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool${BUILD_VERSION}.m4
- @${REINPLACE_CMD} -e 's|libtool.m4|libtool${BUILD_VERSION}.m4|g' \
- ${WRKSRC}/Makefile.in
- @${MV} -f ${WRKSRC}/doc/libtool.info ${WRKSRC}/doc/libtool${BUILD_VERSION}.info
- @${MV} -f ${WRKSRC}/doc/libtool.texi ${WRKSRC}/doc/libtool${BUILD_VERSION}.texi
+ @${REINPLACE_CMD} -e 's|libtool.m4|libtool${BUILD_VERSION}.m4|g' ${WRKSRC}/Makefile.in
post-install:
@-${RM} -fr ${PREFIX}/libexec/libtool${BUILD_VERSION}
diff --git a/devel/libtool13/files/patch-aa b/devel/libtool13/files/patch-aa
index 95c4f56b1de3..a9f85b6070ab 100644
--- a/devel/libtool13/files/patch-aa
+++ b/devel/libtool13/files/patch-aa
@@ -1,28 +1,19 @@
---- doc/libtool13.texi.orig Tue Nov 2 07:36:23 1999
-+++ doc/libtool13.texi Sat Dec 14 00:11:27 2002
-@@ -1,6 +1,6 @@
- \input texinfo @c -*-texinfo-*-
+--- doc/libtool.texi.orig Tue Nov 2 12:36:23 1999
++++ doc/libtool.texi Wed Jul 2 18:18:37 2003
+@@ -2,4 +2,4 @@
@c %**start of header
-@setfilename libtool.info
+-@settitle Libtool
+@setfilename libtool13.info
- @settitle Libtool
++@settitle Libtool13
@c For double-sided printing, uncomment:
- @c @setchapternewpage odd
-@@ -11,14 +11,14 @@
- @set MAILLIST the libtool mailing list @email{libtool@@gnu.org}
- @set objdir .libs
-
--@dircategory GNU programming tools
-+@dircategory Programming & development tools
+@@ -15,3 +15,3 @@
@direntry
-* Libtool: (libtool). Generic shared library support script.
-+* Libtool: (libtool13). Generic shared library support script.
++* Libtool13: (libtool13). Generic shared library support script.
@end direntry
-
- @dircategory Individual utilities
+@@ -20,3 +20,3 @@
@direntry
-* libtoolize: (libtool)Invoking libtoolize. Adding libtool support.
-+* libtoolize: (libtool13)Invoking libtoolize. Adding libtool support.
++* libtoolize13: (libtool13)Invoking libtoolize. Adding libtool support.
@end direntry
-
- @ifinfo
diff --git a/devel/libtool14/Makefile b/devel/libtool14/Makefile
index d695e994da67..96a310e49e9a 100644
--- a/devel/libtool14/Makefile
+++ b/devel/libtool14/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= libtool
PORTVERSION= 1.4.3
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= libtool
@@ -22,8 +22,8 @@ PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS?= --disable-ltdl-install
CONFIGURE_ARGS+= --program-suffix=${BUILD_VERSION}
-INSTALLS_SHLIB= yes
CONFIGURE_ENV= PREFIX=${PREFIX} PACKAGE=libtool${BUILD_VERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_REINPLACE= yes
.if defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
@@ -36,24 +36,24 @@ pre-everything:
@${FALSE}
.endif # defined(USE_LIBTOOL) || defined(USE_LIBTOOL_VER)
-post-extract:
+post-patch:
+ @(cd ${WRKSRC}/doc && \
+ ${RM} -f *.info* && \
+ ${MV} libtool.texi libtool${BUILD_VERSION}.texi && \
+ ${REINPLACE_CMD} -E 's,(libtool|libtoolize)\),\1${BUILDVERSION}\),g' libtool${BUILD_VERSION}.texi)
@${MV} -f ${WRKSRC}/libtool.m4 ${WRKSRC}/libtool${BUILD_VERSION}.m4
@${MV} -f ${WRKSRC}/ltdl.m4 ${WRKSRC}/ltdl${BUILD_VERSION}.m4
@${REINPLACE_CMD} -e 's|libtool.m4|libtool${BUILD_VERSION}.m4|g' \
-e 's|ltdl.m4|ltdl${BUILD_VERSION}.m4|g' ${WRKSRC}/Makefile.in
- @${MV} -f ${WRKSRC}/doc/libtool.info ${WRKSRC}/doc/libtool${BUILD_VERSION}.info
- @${MV} -f ${WRKSRC}/doc/libtool.texi ${WRKSRC}/doc/libtool${BUILD_VERSION}.texi
-.if ${PORTNAME} == "libtool"
post-install:
@-${RM} -fr ${PREFIX}/libexec/libtool${BUILD_VERSION}
- ${MKDIR} ${PREFIX}/libexec/libtool${BUILD_VERSION}
+ @${MKDIR} ${PREFIX}/libexec/libtool${BUILD_VERSION}
.for i in libtool libtoolize
${LN} -sf ${PREFIX}/bin/${i}${BUILD_VERSION} ${PREFIX}/libexec/libtool${BUILD_VERSION}/${i}
.endfor
.for i in config.guess config.sub
${MV} ${PREFIX}/share/libtool${BUILD_VERSION}/${i}${BUILD_VERSION} ${PREFIX}/share/libtool${BUILD_VERSION}/${i}
.endfor
-.endif
.include <bsd.port.mk>
diff --git a/devel/libtool14/files/patch-aa b/devel/libtool14/files/patch-aa
index 8ba2b3510563..17a1e04b525e 100644
--- a/devel/libtool14/files/patch-aa
+++ b/devel/libtool14/files/patch-aa
@@ -1,15 +1,19 @@
---- doc/libtool14.info.orig Wed Oct 23 02:26:36 2002
-+++ doc/libtool14.info Mon Feb 17 01:46:42 2003
-@@ -3,5 +3,5 @@
-
--INFO-DIR-SECTION GNU programming tools
-+INFO-DIR-SECTION Programming & development tools
- START-INFO-DIR-ENTRY
+--- doc/libtool.texi.orig Mon Jan 14 19:04:40 2002
++++ doc/libtool.texi Wed Jul 2 18:11:10 2003
+@@ -2,4 +2,4 @@
+ @c %**start of header
+-@setfilename libtool.info
+-@settitle Libtool
++@setfilename libtool14.info
++@settitle Libtool14
+ @c For double-sided printing, uncomment:
+@@ -15,3 +15,3 @@
+ @direntry
-* Libtool: (libtool). Generic shared library support script.
-+* Libtool: (libtool14). Generic shared library support script.
- END-INFO-DIR-ENTRY
-@@ -10,3 +10,3 @@
- START-INFO-DIR-ENTRY
++* Libtool14: (libtool14). Generic shared library support script.
+ @end direntry
+@@ -20,3 +20,3 @@
+ @direntry
-* libtoolize: (libtool)Invoking libtoolize. Adding libtool support.
-+* libtoolize: (libtool14)Invoking libtoolize. Adding libtool support.
- END-INFO-DIR-ENTRY
++* libtoolize14: (libtool14)Invoking libtoolize. Adding libtool support.
+ @end direntry
diff --git a/devel/libtool14/pkg-descr.libltdl b/devel/libtool14/pkg-descr.libltdl
deleted file mode 100644
index e57b99f21a5c..000000000000
--- a/devel/libtool14/pkg-descr.libltdl
+++ /dev/null
@@ -1,9 +0,0 @@
-This is GNU libltdl, a system independent dlopen wrapper for GNU libtool.
-
-It supports the following dlopen interfaces:
-* dlopen (Solaris, Linux and various BSD flavors)
-* shl_load (HP-UX)
-* LoadLibrary (Win16 and Win32)
-* load_add_on (BeOS)
-* GNU DLD (emulates dynamic linking for static libraries)
-* libtool's dlpreopen
diff --git a/devel/libtool14/pkg-plist.libltdl b/devel/libtool14/pkg-plist.libltdl
deleted file mode 100644
index 1a8458d1a65c..000000000000
--- a/devel/libtool14/pkg-plist.libltdl
+++ /dev/null
@@ -1,5 +0,0 @@
-@comment $FreeBSD$
-include/ltdl.h
-lib/libltdl.a
-lib/libltdl.so
-lib/libltdl.so.4