aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/7kaa/Makefile27
-rw-r--r--games/7kaa/distinfo6
-rw-r--r--games/7kaa/pkg-descr2
-rw-r--r--games/7kaa/pkg-plist6
4 files changed, 23 insertions, 18 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
index 204e57d21a46..6dc0d048aabf 100644
--- a/games/7kaa/Makefile
+++ b/games/7kaa/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= 7kaa
-PORTVERSION= 2.14.7
-PORTREVISION= 3
+PORTVERSION= 2.15.2
+DISTVERSIONPREFIX= v
CATEGORIES= games
-MASTER_SITES= SF/skfans/7KAA%20${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Seven Kingdoms: Ancient Adversaries
@@ -13,25 +12,25 @@ COMMENT= Seven Kingdoms: Ancient Adversaries
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_armv6= fails to compile: OBULLET.cpp:41:9: constant expression evaluates to -1 which cannot be narrowed to type 'char'
-BROKEN_armv7= fails to compile: OBULLET.cpp:41:9: constant expression evaluates to -1 which cannot be narrowed to type 'char'
-
LIB_DEPENDS= libenet.so:net/enet \
libcurl.so:ftp/curl
-USES= compiler:c++11-lang gmake localbase openal:al pkgconfig tar:xz
-GNU_CONFIGURE= yes
-LLD_UNSAFE= yes
-CONFIGURE_ARGS= --disable-nls # no translations ATM
+USE_GITHUB= yes
+GH_ACCOUNT= the3dfxdude
+
+USES= autoreconf gettext-tools gmake localbase openal:al pkgconfig sdl
USE_SDL= sdl2
-CXXFLAGS+= -Wno-error=narrowing
+GNU_CONFIGURE= yes
+
+CXXFLAGS+= -fPIC
-PLIST_FILES= bin/${PORTNAME} \
- share/pixmaps/${PORTNAME}.ico
PORTDOCS= *
PORTDATA= *
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
DESKTOP_ENTRIES="7KAA" \
"" \
diff --git a/games/7kaa/distinfo b/games/7kaa/distinfo
index 9b120f547f86..8a4ad7ef2666 100644
--- a/games/7kaa/distinfo
+++ b/games/7kaa/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496913552
-SHA256 (7kaa-2.14.7.tar.xz) = 9425cfb7f11a915e82d4696649db35a4d53969a9479a4705b403206df462e543
-SIZE (7kaa-2.14.7.tar.xz) = 31342092
+TIMESTAMP = 1562001580
+SHA256 (the3dfxdude-7kaa-v2.15.2_GH0.tar.gz) = 7575f7bdee979ad45a1e19fca37131072fc745662e5d9959af84b82961599703
+SIZE (the3dfxdude-7kaa-v2.15.2_GH0.tar.gz) = 58529212
diff --git a/games/7kaa/pkg-descr b/games/7kaa/pkg-descr
index 6da7b3bcb349..caee54e4271e 100644
--- a/games/7kaa/pkg-descr
+++ b/games/7kaa/pkg-descr
@@ -5,4 +5,4 @@ game under a free and open source license in 2009. See the file
for making the 7kfans project possible and giving a new chance to
build a community for fans of the game.
-WWW: http://7kfans.com/
+WWW: https://7kfans.com/
diff --git a/games/7kaa/pkg-plist b/games/7kaa/pkg-plist
new file mode 100644
index 000000000000..8ae1c5f3f82f
--- /dev/null
+++ b/games/7kaa/pkg-plist
@@ -0,0 +1,6 @@
+bin/7kaa
+share/pixmaps/7kaa.ico
+%%NLS%%share/locale/de/LC_MESSAGES/7kaa.mo
+%%NLS%%share/locale/es/LC_MESSAGES/7kaa.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/7kaa.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/7kaa.mo