aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/tinyxml2/Makefile10
-rw-r--r--textproc/tinyxml2/distinfo6
-rw-r--r--textproc/tinyxml2/pkg-descr1
-rw-r--r--textproc/tinyxml2/pkg-plist10
4 files changed, 19 insertions, 8 deletions
diff --git a/textproc/tinyxml2/Makefile b/textproc/tinyxml2/Makefile
index abf37b352f9c..3b5643d787fc 100644
--- a/textproc/tinyxml2/Makefile
+++ b/textproc/tinyxml2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tinyxml2
-PORTVERSION= 7.0.1
-PORTREVISION= 2
+PORTVERSION= 7.1.0
PORTEPOCH= 1
CATEGORIES= textproc
@@ -11,20 +10,21 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Small C++ XML Parser
LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-OPTIONS_DEFINE= EXAMPLES
+USES= cmake:insource compiler:c++11-lang dos2unix pathfix
CMAKE_OFF= BUILD_TESTS
CMAKE_ON= BUILD_SHARED_LIBS
-USES= cmake:insource compiler:c++11-lang dos2unix pathfix
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
-PORTEXAMPLES= *
GH_ACCOUNT= leethomason
USE_GITHUB= yes
+OPTIONS_DEFINE= EXAMPLES
+
post-patch:
@${REINPLACE_CMD} -e '/CMAKE_DEBUG_POSTFIX/d' ${WRKSRC}/CMakeLists.txt
diff --git a/textproc/tinyxml2/distinfo b/textproc/tinyxml2/distinfo
index d04057cc5341..c5799b4065f1 100644
--- a/textproc/tinyxml2/distinfo
+++ b/textproc/tinyxml2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1542571957
-SHA256 (leethomason-tinyxml2-7.0.1_GH0.tar.gz) = a381729e32b6c2916a23544c04f342682d38b3f6e6c0cad3c25e900c3a7ef1a6
-SIZE (leethomason-tinyxml2-7.0.1_GH0.tar.gz) = 590384
+TIMESTAMP = 1565627606
+SHA256 (leethomason-tinyxml2-7.1.0_GH0.tar.gz) = 68ebd396a4220d5a9b5a621c6e9c66349c5cfdf5efaea3f16e3bb92e45f4e2a3
+SIZE (leethomason-tinyxml2-7.1.0_GH0.tar.gz) = 592717
diff --git a/textproc/tinyxml2/pkg-descr b/textproc/tinyxml2/pkg-descr
index 8657158d265b..bace36622544 100644
--- a/textproc/tinyxml2/pkg-descr
+++ b/textproc/tinyxml2/pkg-descr
@@ -5,3 +5,4 @@ use DTDs or XSL. It doesn't have the STL support of TinyXML-1, but uses less
memory, has a proper namespace, and is faster.
WWW: http://grinninglizard.com/tinyxml2/index.html
+WWW: https://github.com/leethomason/tinyxml2
diff --git a/textproc/tinyxml2/pkg-plist b/textproc/tinyxml2/pkg-plist
index 2c001c750dc3..6bf8355ac1be 100644
--- a/textproc/tinyxml2/pkg-plist
+++ b/textproc/tinyxml2/pkg-plist
@@ -1,5 +1,6 @@
include/tinyxml2.h
lib/cmake/tinyxml2/tinyxml2Config.cmake
+lib/cmake/tinyxml2/tinyxml2ConfigVersion.cmake
lib/cmake/tinyxml2/tinyxml2Targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/tinyxml2/tinyxml2Targets.cmake
lib/libtinyxml2.a
@@ -7,3 +8,12 @@ lib/libtinyxml2.so
lib/libtinyxml2.so.7
lib/libtinyxml2.so.%%PORTVERSION%%
libdata/pkgconfig/tinyxml2.pc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/dream.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/empty.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/out/readme.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/utf8test.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/utf8testverify.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/xmltest-4636783552757760.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/xmltest-5330.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/xmltest-5662204197076992.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/resources/xmltest-5720541257269248.xml