aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-24 05:41:46 +0800
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-01-24 05:41:46 +0800
commit066d71d8f41a522b54133cb92ae66cc0ae991de2 (patch)
treeb298482d348e5f7a3d41aadf4c9f532d86781914
parentdf01cf7e197b091106363f0f94c86d36d275b2e0 (diff)
downloadfreebsd-ports-066d71d8f41a522b54133cb92ae66cc0ae991de2.tar.gz
freebsd-ports-066d71d8f41a522b54133cb92ae66cc0ae991de2.tar.zst
freebsd-ports-066d71d8f41a522b54133cb92ae66cc0ae991de2.zip
MFH: r340659
Partially fix the build. Sphinx underwent an incompatible change in version 1.2 that removed the sphinx.ext.refcounting module. The module is referenced by shiboken's Sphinx configuration file, and the build fails. Fix it by removing the reference to sphinx.ext.refcounting, as it does not seem to be required and was probably added by default when the configuration file was generated. As mentioned, this is a partial fix: platforms that use libc++ by default are still broken due to other issues, but at least FreeBSD 8 and 9 should have a working package again. While here, also use the new syntax for LIB_DEPENDS. PR: ports/185179 Submitted by: rakuco@ Approved by: maintainer timeout (27 days) Approved by: portmgr (mat)
Notes
Notes: svn path=/branches/2014Q1/; revision=340863
-rw-r--r--devel/shiboken/Makefile4
-rw-r--r--devel/shiboken/files/patch-doc__conf.py.in11
2 files changed, 13 insertions, 2 deletions
diff --git a/devel/shiboken/Makefile b/devel/shiboken/Makefile
index b033a92883ba..f30a1f0185e8 100644
--- a/devel/shiboken/Makefile
+++ b/devel/shiboken/Makefile
@@ -13,8 +13,8 @@ COMMENT= C++ code generator for CPython extensions
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- xslt:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libxslt.so:${PORTSDIR}/textproc/libxslt
PLIST_SUB= PORTVERSION=${PORTVERSION} \
PYTHON_VERSION=${PYTHON_VERSION}
diff --git a/devel/shiboken/files/patch-doc__conf.py.in b/devel/shiboken/files/patch-doc__conf.py.in
new file mode 100644
index 000000000000..5d4d8f5e466e
--- /dev/null
+++ b/devel/shiboken/files/patch-doc__conf.py.in
@@ -0,0 +1,11 @@
+--- doc/conf.py.in.orig 2013-12-25 19:56:52.000000000 +0200
++++ doc/conf.py.in 2013-12-25 19:57:00.000000000 +0200
+@@ -22,7 +22,7 @@
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest', 'sphinx.ext.ifconfig', 'sphinx.ext.refcounting', 'sphinx.ext.coverage']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.doctest', 'sphinx.ext.ifconfig', 'sphinx.ext.coverage']
+
+ rst_epilog = """
+ .. |project| replace:: Shiboken