aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-02-16 22:48:38 +0800
committerKubilay Kocak <koobs@FreeBSD.org>2014-02-16 22:48:38 +0800
commitac629500b0aecc6ef2ca02d5ee585d2305bd1c32 (patch)
tree1380693651314e6f2ffdf1ab8e24f46a6f283c42
parent04d2c7097b19cc47b5235c8c1972b181c5338514 (diff)
downloadfreebsd-ports-ac629500b0aecc6ef2ca02d5ee585d2305bd1c32.tar.gz
freebsd-ports-ac629500b0aecc6ef2ca02d5ee585d2305bd1c32.tar.zst
freebsd-ports-ac629500b0aecc6ef2ca02d5ee585d2305bd1c32.zip
MFH: r344573
Any python package that uses console_scripts in setup.py needs the pkg_resources module from setuptools at run time. This generally means anything that installs a CLI utility. Package-only users do not get setuptools installed when they install the packages of these ports currently, because USE_PYDISTUTILS=yes doesnt set a RUN_DEPENDS on it. This breaks console script invocation, with the following error: Traceback (most recent call last): File "/usr/local/bin/<script-name>", line 5, in <module> from pkg_resources import load_entry_point ImportError: No module named pkg_resources The FreeBSD Python team has recently standardised on a consistent installation pattern for all python software, whether pure-distutils or setuptools based, and this run-time requirement is currently not being satisfied, breaking ports that use that functionality. This commit moves RUN_DEPENDS+=setuptools from the =easy_install *only* case, to the default case. This does mean that py27-setuptools and py33-setuptools cannot be installed concurrently, precluding dual stack Python installations. The FreeBSD Python team is working hard towards a future where multiple python and packages versions *can* be installed concurrently, but it is not explicitly supported in the current state. Improvements to FreeBSD's ports and package frameworks will help achieve that goal. [1] http://lists.freebsd.org/pipermail/freebsd-python/2014-February/006592.html [2] http://lists.freebsd.org/pipermail/freebsd-python/2014-February/006609.html PR: ports/186706 Approved by: portmgr (miwi)
Notes
Notes: svn path=/branches/2014Q1/; revision=344576
-rw-r--r--Mk/bsd.python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index 5cddb89716f9..64012f5acd62 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -423,11 +423,11 @@ PYTHONPREFIX_SITELIBDIR= ${PYTHON_SITELIBDIR:S;${PYTHONBASE};${PREFIX};}
_CURRENTPORT:= ${PKGNAMEPREFIX}${PORTNAME}
.if defined(USE_PYDISTUTILS) && ${_CURRENTPORT} != ${PYTHON_PKGNAMEPREFIX}setuptools
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:${PORTSDIR}/devel/py-setuptools
.endif
# setuptools support
.if defined(USE_PYDISTUTILS) && ${USE_PYDISTUTILS} == "easy_install"
-RUN_DEPENDS+= ${PYEASYINSTALL_CMD}:${PORTSDIR}/devel/py-setuptools
PYDISTUTILS_BUILD_TARGET?= bdist_egg
PYDISTUTILS_INSTALL_TARGET?= easy_install