aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2018-05-06 02:57:24 +0800
committerNiclas Zeising <zeising@FreeBSD.org>2018-05-06 02:57:24 +0800
commit5f7d55b455510e12d0da5a1fe9a0915865ff3847 (patch)
tree2dd6ac38df1df74b56013e93d667e2eb981bcd16
parent3be16863c9750c8fb1e09cfa76001144a6e44397 (diff)
downloadfreebsd-ports-5f7d55b455510e12d0da5a1fe9a0915865ff3847.tar.gz
freebsd-ports-5f7d55b455510e12d0da5a1fe9a0915865ff3847.tar.zst
freebsd-ports-5f7d55b455510e12d0da5a1fe9a0915865ff3847.zip
MFH: r468774
Fix GL context creation Add patch from upstream to fix errors in creating GL context. See Upstream issue for details: https://github.com/jwilm/alacritty/issues/921 PR: 227846 Submitted by: Sascha Holzleiter Approved by: ports-secteam (riggs)
Notes
Notes: svn path=/branches/2018Q2/; revision=469158
-rw-r--r--x11/alacritty/Makefile2
-rw-r--r--x11/alacritty/files/patch-src_window.rs10
2 files changed, 11 insertions, 1 deletions
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index ffe7e4bd0b15..9333f2754ca1 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -2,7 +2,7 @@
PORTNAME= alacritty
PORTVERSION= g20180126
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11
MAINTAINER= zeising@FreeBSD.org
diff --git a/x11/alacritty/files/patch-src_window.rs b/x11/alacritty/files/patch-src_window.rs
new file mode 100644
index 000000000000..8b3453dd674c
--- /dev/null
+++ b/x11/alacritty/files/patch-src_window.rs
@@ -0,0 +1,10 @@
+--- src/window.rs.orig 2018-04-23 07:37:25 UTC
++++ src/window.rs
+@@ -200,6 +200,7 @@ impl Window {
+ .with_transparency(true)
+ .with_decorations(window_config.decorations());
+ let context = ContextBuilder::new()
++ .with_srgb(true)
+ .with_vsync(true);
+ let window = ::glutin::GlWindow::new(window, context, &event_loop)?;
+ window.show();