aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-11 14:24:43 +0800
committerJan Beich <jbeich@FreeBSD.org>2018-05-11 14:24:43 +0800
commitae42f7a6e69200ea7f8851b08202bd12b789dceb (patch)
tree615c33e95ed7cf70e6d1fa263068c0bb342374e3
parentad95343da39bf5c5816168632263c03a727bdf3d (diff)
downloadfreebsd-ports-ae42f7a6e69200ea7f8851b08202bd12b789dceb.tar.gz
freebsd-ports-ae42f7a6e69200ea7f8851b08202bd12b789dceb.tar.zst
freebsd-ports-ae42f7a6e69200ea7f8851b08202bd12b789dceb.zip
MFH: r469611
emulators/rpcs3: disable assertions Assertion failed: (ObjectBufferMap.find(Key) == ObjectBufferMap.end() && "Second attempt to perform debug registration."), function NotifyObjectEmitted, file llvm/lib/ExecutionEngine/GDBRegistrationListener.cpp, line 167. Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2018Q2/; revision=469612
-rw-r--r--emulators/rpcs3/Makefile1
-rw-r--r--emulators/rpcs3/files/patch-no-asserts15
2 files changed, 16 insertions, 0 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 7ee877fd6f9d..c7916781583d 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -4,6 +4,7 @@ PORTNAME= rpcs3
DISTVERSIONPREFIX= v
DISTVERSION= 0.0.5-259
DISTVERSIONSUFFIX= -g76a1d0d8f
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= jbeich@FreeBSD.org
diff --git a/emulators/rpcs3/files/patch-no-asserts b/emulators/rpcs3/files/patch-no-asserts
new file mode 100644
index 000000000000..36df8ccaa148
--- /dev/null
+++ b/emulators/rpcs3/files/patch-no-asserts
@@ -0,0 +1,15 @@
+https://github.com/RPCS3/rpcs3/issues/3745
+
+--- rpcs3/CMakeLists.txt.orig 2018-05-09 22:44:51.000000000 +0000
++++ rpcs3/CMakeLists.txt
+@@ -81,6 +81,10 @@ add_custom_command(OUTPUT something_that_never_exists
+ # Check for a sufficient compiler and set build options
+ include(ConfigureCompiler)
+
++if(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
++ add_definitions(-DNDEBUG)
++endif()
++
+ if(WIN32)
+ add_definitions(-DUNICODE)
+ add_definitions(-D_WIN32_WINNT=0x0601)