aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-05-05 01:46:25 +0800
committerMatthias Fechner <mfechner@FreeBSD.org>2018-05-05 01:46:25 +0800
commite5e97b6227dd83a4ca0a6e0fcf69fd598c4b220e (patch)
tree14d699eca1b42af7a11dcd355fc110fb70b13f3f
parentd146bc08cd2d0f40f4c24a89f1b4d37a387db360 (diff)
downloadfreebsd-ports-e5e97b6227dd83a4ca0a6e0fcf69fd598c4b220e.tar.gz
freebsd-ports-e5e97b6227dd83a4ca0a6e0fcf69fd598c4b220e.tar.zst
freebsd-ports-e5e97b6227dd83a4ca0a6e0fcf69fd598c4b220e.zip
MFH: r467327
Updated devel/gitaly to version 0.91.0 which is required for gitlab 10.6.x. Reviewed by: swills (mentor) Approved by: swills (mentor) Differential Revision: https://reviews.freebsd.org/D15033 Approved by: ports-secteam (feld)
Notes
Notes: svn path=/branches/2018Q2/; revision=469040
-rw-r--r--devel/gitaly/Makefile17
-rw-r--r--devel/gitaly/distinfo6
-rw-r--r--devel/gitaly/pkg-plist7
3 files changed, 20 insertions, 10 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index 55819b414ec4..34a1409ea138 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= gitaly
-DISTVERSION= 0.82.0
+DISTVERSION= 0.91.0
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= idefix@fechner.net
@@ -11,16 +12,18 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
# define dependencies that are required for build and run under MY_DEPENDS
-MY_DEPENDS= git>=2.14.3:devel/git \
- rubygem-github-linguist47>=4.7.0:textproc/rubygem-github-linguist47 \
+MY_DEPENDS= git>=2.16.2:devel/git \
+ rubygem-github-linguist53>=5.3.3:textproc/rubygem-github-linguist53 \
rubygem-bundler>0:sysutils/rubygem-bundler \
rubygem-gitlab-markup>=1.6.2:textproc/rubygem-gitlab-markup \
- rubygem-gitaly-proto083>=0.83.0:net/rubygem-gitaly-proto083 \
+ rubygem-gitaly-proto088>=0.88.0:net/rubygem-gitaly-proto088 \
rubygem-activesupport50>=5.0.2:devel/rubygem-activesupport50 \
rubygem-rdoc>=4.2:devel/rubygem-rdoc \
rubygem-gollum-lib-gitlab>=4.2.0:www/rubygem-gollum-lib-gitlab \
rubygem-gollum-rugged_adapter>=0.4.4:www/rubygem-gollum-rugged_adapter \
- rubygem-grpc>=1.8.0:net/rubygem-grpc \
+ rubygem-grpc>=1.10.0:net/rubygem-grpc \
+ rubygem-sentry-raven>=2.7.2:devel/rubygem-sentry-raven \
+ rubygem-licensee8>=8.7:devel/rubygem-licensee8 \
rubygem-google-protobuf351>=3.5.1:devel/rubygem-google-protobuf351
BUILD_DEPENDS= go>=1.8:lang/go \
@@ -29,7 +32,7 @@ BUILD_DEPENDS= go>=1.8:lang/go \
${MY_DEPENDS}
RUN_DEPENDS= ${MY_DEPENDS} \
- gitlab-shell>=6.0.3:devel/gitlab-shell
+ gitlab-shell>=6.0.4:devel/gitlab-shell
USES= gmake
USE_RUBY= yes
@@ -37,7 +40,7 @@ USE_RUBY= yes
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/tags
-GL_COMMIT= 8f7e18974599c47f542e083d56faf45af106788b
+GL_COMMIT= 89298fe8b80b73a34352023555fe061866aff3ad
post-patch:
${MV} ${WRKSRC}/config.toml.example ${WRKSRC}/config.toml.sample
diff --git a/devel/gitaly/distinfo b/devel/gitaly/distinfo
index 964d071d7bc3..af5b9dc0b94d 100644
--- a/devel/gitaly/distinfo
+++ b/devel/gitaly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522736881
-SHA256 (gitlab-org-gitaly-8f7e18974599c47f542e083d56faf45af106788b_GL0.tar.gz) = 22f2b66067ebdb87907b6cb1698ee471dbbe1beecaa3208a9877033c110a9ebb
-SIZE (gitlab-org-gitaly-8f7e18974599c47f542e083d56faf45af106788b_GL0.tar.gz) = 3572308
+TIMESTAMP = 1523378733
+SHA256 (gitlab-org-gitaly-89298fe8b80b73a34352023555fe061866aff3ad_GL0.tar.gz) = c1a8e836b572f249e05c3a821002781af6a3a1bf3434dff5fe515078700994b3
+SIZE (gitlab-org-gitaly-89298fe8b80b73a34352023555fe061866aff3ad_GL0.tar.gz) = 3586830
diff --git a/devel/gitaly/pkg-plist b/devel/gitaly/pkg-plist
index 4ae54639c2d5..d727a5cb6aa4 100644
--- a/devel/gitaly/pkg-plist
+++ b/devel/gitaly/pkg-plist
@@ -9,10 +9,13 @@
%%DATADIR%%/ruby/lib/gitaly_server/commit_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/conflicts_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/diff_service.rb
+%%DATADIR%%/ruby/lib/gitaly_server/exception_sanitizer_interceptor.rb
%%DATADIR%%/ruby/lib/gitaly_server/operations_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/ref_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/remote_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/repository_service.rb
+%%DATADIR%%/ruby/lib/gitaly_server/sentry.rb
+%%DATADIR%%/ruby/lib/gitaly_server/sentry_interceptor.rb
%%DATADIR%%/ruby/lib/gitaly_server/utils.rb
%%DATADIR%%/ruby/lib/gitaly_server/wiki_service.rb
%%DATADIR%%/ruby/lib/gitlab/config.rb
@@ -25,9 +28,13 @@
%%DATADIR%%/ruby/spec/gitaly/ref_service_spec.rb
%%DATADIR%%/ruby/spec/gitaly/repository_service_spec.rb
%%DATADIR%%/ruby/spec/integration_helper.rb
+%%DATADIR%%/ruby/spec/lib/gitaly_server/exception_sanitizer_interceptor_spec.rb
%%DATADIR%%/ruby/spec/lib/gitaly_server/utils_spec.rb
+%%DATADIR%%/ruby/spec/lib/gitaly_server/sentry/url_sanitizer_spec.rb
+%%DATADIR%%/ruby/spec/lib/gitaly_server/sentry_interceptor_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/config_spec.rb
%%DATADIR%%/ruby/spec/spec_helper.rb
+%%DATADIR%%/ruby/spec/support/sentry.rb
%%DATADIR%%/ruby/spec/test_repo_helper.rb
%%DATADIR%%/ruby/vendor/gitlab_git/ORIGIN
%%DATADIR%%/ruby/vendor/gitlab_git/REVISION