aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2018-06-05 22:44:26 +0800
committerMatthias Fechner <mfechner@FreeBSD.org>2018-06-05 22:44:26 +0800
commitef0b0eebfeaac86995bc41b3c1cb33ebe32737cd (patch)
tree15c96f23d62c49ad69563ada269c1fd8a38333ea
parentafadae85a06e19465da1dd40e9ec19537538bbd5 (diff)
downloadfreebsd-ports-ef0b0eebfeaac86995bc41b3c1cb33ebe32737cd.tar.gz
freebsd-ports-ef0b0eebfeaac86995bc41b3c1cb33ebe32737cd.tar.zst
freebsd-ports-ef0b0eebfeaac86995bc41b3c1cb33ebe32737cd.zip
MFH: r469930 r470014
Mark devel/libgit2-glib as broken, upstream does not support libgit 0.27.0 Reviewed by: wg (maintainer) Approved by: wg (maintainer) Differential Revision: https://reviews.freebsd.org/D15321 devel/libgit2-glib: Unbreak with libgit2 0.27. The fix is two-fold: * Adjust the path for the sed call in devel/libgit2 so that we leave out openssl from libgit2.pc's Requires.private line, otherwise libgit2-glib will look for openssl.pc, which does not exist when OpenSSL from base is used. * Reset libgit2-glib back to 0.26, and import a patch both Arch Linux and openSUSE have been carrying to fix the build with libgit2 0.27. PORTEPOCH was not set because there is no libgit2-glib 0.27 and no package could have possibly been built after r469930. Approved by: mfechner, gnome (kwm) Differential Revision: https://reviews.freebsd.org/D15437 Approved by: ports-secteam (eadler)
Notes
Notes: svn path=/branches/2018Q2/; revision=471765
-rw-r--r--devel/libgit2-glib/files/patch-libgit2-glib_ggit-config.c13
-rw-r--r--devel/libgit2/Makefile3
2 files changed, 15 insertions, 1 deletions
diff --git a/devel/libgit2-glib/files/patch-libgit2-glib_ggit-config.c b/devel/libgit2-glib/files/patch-libgit2-glib_ggit-config.c
new file mode 100644
index 000000000000..b7beae253cc3
--- /dev/null
+++ b/devel/libgit2-glib/files/patch-libgit2-glib_ggit-config.c
@@ -0,0 +1,13 @@
+Fix the build with libgit2 0.27.
+
+Obtained from: https://git.archlinux.org/svntogit/packages.git/commit/trunk/libgit2-0.27.0.diff?h=packages/libgit2-glib&id=5c8af6b8236ed9a108ad980899477cb50ffeb324
+--- libgit2-glib/ggit-config.c.orig 2015-08-10 06:33:13 UTC
++++ libgit2-glib/ggit-config.c
+@@ -295,6 +295,7 @@ ggit_config_add_file (GgitConfig *config,
+ ret = git_config_add_file_ondisk (_ggit_native_get (config),
+ path,
+ (git_config_level_t)level,
++ NULL,
+ force);
+ g_free (path);
+
diff --git a/devel/libgit2/Makefile b/devel/libgit2/Makefile
index 2f8e6fdb954f..2c7660a31bd2 100644
--- a/devel/libgit2/Makefile
+++ b/devel/libgit2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libgit2
PORTVERSION= 0.27.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= devel
@@ -38,7 +39,7 @@ post-patch:
@${REINPLACE_CMD} -e "/LIBGIT2_PC_REQUIRES.*zlib/ d" ${WRKSRC}/CMakeLists.txt
.if ${SSL_DEFAULT} == base
@${REINPLACE_CMD} -e "/LIBGIT2_PC_REQUIRES.*openssl/ d" \
- ${WRKSRC}/CMakeLists.txt
+ ${WRKSRC}/src/CMakeLists.txt
.endif
.include <bsd.port.post.mk>